none
BUG in Microsoft SCOM 2016 Web Console: "500 - Internal Server Error" !!!! SOLVED !!!!

    Question

  • Dear Microsoft IIS/SCOM Developer Team,

    we have a absolutely new SCOM 2016 infrastructure and had had until today issue with the SCOM 2016 Web Console.

    I created related to "500 - Internal server error" some forum questions. Also I read the similar 500 error on other discusiions in Technet forums.

    Finally I found the BUG in SCOM 2016 Web Console!

    I will list the bug in IIS/SCOM and my solution, and also want that MICROSOFT should make a statement to this issue!

    ISSUE

    If any user try to access to SCOM 2016 Web Console,  "500 - Internal server error" will be displayed.

    IIS/SCOM BUG

    1) Applicaton Pools are set not correctly in the sites "MonitoringView" and "OperationsManager"

    - the site "MonitoringSite" has as application pool "OperationsManager".

    - the site "OperationsManager" ahs as application pool "OperationsManagerMonitoringView".

    SOLUTION

    Logically, these applications pools must be set contrary.

    - I changed both sites to the correct application pools.

    - Make iisreset (better start the Web Console server)

    BINGO! It works....

    NOTICE: We did never changed in the deployment or afterwards the applications pools!

    But how about with "physical path"?

    I checked both physical paths of the sites "MonitoringView" and "OperationsManager". It is very strange. The site "MonitoringView" uses "C:\Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\WebHost", and the site "OperationsManager" uses "C:\Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\MonitoringView".

    I expect here also contrary settings. But NO! If I change the settings contrary, the Internet browser prompt the following:

    If this configured,

    But, the Web Console does not work and give the following error:

    "This view cannot be displayed because this computer is not configured for the Operations Manager web console. refresh the browser to configure"

    OK.... I set the physical path again back! In my opinion, "physical path" is also a bug which Microsoft developer should try to fix.

    NOW...

    MICROSOFT developer team should make a statement, please!

    Best Regards

    Birdal




    • Edited by _Birdal Friday, January 19, 2018 12:46 PM
    Thursday, January 18, 2018 3:36 PM

All replies

  • Hi Birdal,

    glad to hear that you've resolved it. Can you reproduce it? Or put in other words: How can I encounter the "bug"?
    I've quite a few installations of the SCOM 2016 web console, but had never experienced it. 

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Thursday, January 18, 2018 9:11 PM
    Moderator
  • Hello Birdal,

    Great work!

    I have build a new SCOM 2016, which the web console on the same server with the management server. I can access the web console on the management server.

    But when I try to access the web console on another Windows 2016 server, encounter the same issue as yours, and I modified the application pool for "MonitoringView" and "OperationsManager" site, it works. 

    I suggest you open a case to Microsoft, hope next UR fix this issue. 

    Regards,

    Yan 


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, January 19, 2018 2:40 AM
    Moderator
  • Hi Stoyan,

    yes, I can reproduce it.

    As I wrote above I did never change application pool. Why the application pools are set in IIS not correctly, Microsoft should say about it. That is definetly a bug.

    Best Regards

    Birdal



    • Edited by _Birdal Friday, January 19, 2018 7:40 AM
    Friday, January 19, 2018 7:06 AM
  • Hi Yan,

    I had had long time headache because of this issue/bug. You tested also the same! I am sure some (or all) SCOM 2016 have the same bug/issue.

    In my opinion, "Physical path" is also a BUG. I think Microsoft developer mismatched the physical path / application pools during the development. 

    Best Regards

    Birdal



    • Edited by _Birdal Friday, January 19, 2018 7:40 AM
    Friday, January 19, 2018 7:10 AM
  • Hey Birdal,

    great work. I think opening a case will drive this further, but what you can also do for ALL of us is to file the bug here:

    General Operations Manager Feedback

    The SCOM community will be grateful to you when the netx (or the next after the next) relase comes. 

    Thanks, Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Friday, January 19, 2018 12:19 PM
    Moderator
  • Friday, January 19, 2018 1:03 PM
  • Hey Birdal,

    great. I already voted! That is how the SCOM community work. 

    Cheers,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Saturday, January 20, 2018 9:02 PM
    Moderator
  • Hi Stoyan,

    thank you.I see there 6 votes. But how can I see who has voted.

    Best Regards

    Birdal

    Monday, January 22, 2018 12:30 PM
  • Hi,

    i have the same case on 3 environment

    Change pool name not solve the problem.

    Always, Error 500 !

     

    Thursday, January 25, 2018 3:34 PM
  • Hello, 

    I suggest you open a new thread with more details about your issue, so that others can reply there and troubleshoot the issue. 

    Regards,

    Yan


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 26, 2018 7:50 AM
    Moderator
  • Hi Birdal,

    I cannot say I have come across this issue before, therefore I have a few questions.

    • What Operating System is SCOM installed on and all updates applied prior to install?
    • Where is the Web console installed (Stand alone or on a management server)?
    • Do you have any policies in place that apply to Microsoft installer or IIS, either via DSC, GPO or by other means?
    • Can you reproduce the bug from a clean install, if so what are the steps you are taking to repro the bugs (if you are using an online guide, could you send me the link?)

    Monday, February 05, 2018 4:31 PM
  • hi,

    for me,

    OS Windows 2016 for MS / SQL et WEB but test on windows 2012 R2 for Web console

    Standalone (but on ms is same problem)

    NO GPO

    Yes, on 3 environnement, BUILD, PREPROD and PROD 

    regards.

    E. Y.


    • Edited by YvEric Thursday, February 08, 2018 2:27 PM
    Thursday, February 08, 2018 1:51 PM
  • Hi Robert,

    the issue "500 Internal Server Error" is very strange and complicated to solve, I think.I think the main problem is that Web Console for SCOM not good and not coded correctly on Microsofts side.

    Thousands of IT- experts have the same problem.

    There is no clear and transparent documentation from Microsoft about SCOM Web Console and troubleshootings.

    For example, if I deploy SCOM 2016 UR4, this installation changes AppPools again...Clients get sometimes "500 Internal Server Error", although Management Servers or Web Console do not get this error.

    Permissions?

    A strange part is "To configure permissions inheritance for the Web console" in the article https://docs.microsoft.com/en-us/system-center/scom/deploy-install-web-console?view=sc-om-1711.

    There is no such kind of "Change Permissions" tab. Also, it is absolutely not clear for me, why the permissions should change there and Administrators and SYSTEM should be deleted?!

    All is very strange.

    Best Regards

    Birdal
    Friday, February 09, 2018 12:08 PM
  • To help others...Where are these application pools edited?

    1. Open IIS

    2. Click on the server

    3. Click on sites to expand 

    4. Click on MonitoringView and then "Basic settings" in the right column

    5. Make your changes and do the same for the other view.

    Friday, February 09, 2018 7:43 PM
  • What about all these others steps you took.

    Do we need to change all of those too?

    1) all SPNs are registered definetly correct. Delegation for the SDK-Account, etc. in AD correct.
    2) Kerberos authentication
    3) IIS authentication is as recomended:
    - VirtualSite "OperationsManager" > Authentication > Windows Authentication is enabled.
    - Provider (Negotiate first, then NTLM)
    - "Enable Kernel-mode authentication" is OFF
    - The same settings above also for the VirtualSite "MonitoringView"
    4) Application Pools
    - .NET CLR Version is v4.0 for both "OperationsManagerAppMonitoring" and "OperationsManagerMonitoringView". It did not help to switch Version 2.0. It did not help also to switch the "Managed Pipeline Mode" from "Integrated" to "Classic".
    5) There is no problem on the Web Console Server to access the SCOM Web Console.
    6) On the client site, in Internet EXplorer, the Web Console Server is trusted server in the local intranet. Kerberos authentication is enabled, etc..

    Wednesday, February 14, 2018 1:04 AM