locked
Unable to uninstall exchange 2007 UM server after migrating them to exchange 2013. RRS feed

  • Question

  • I am getting event ID 4999 while trying to uninstall exchange 2007 UM roles from the server.

    Watson report about to be sent to dw20.exe for process id: 18412, with parameters: E12, c-RTL-AMD64, 08.03.0389.002, exsetupui, M.E.U.Management, M.E.U.M.T.UmLanguagePackUtils.ComputeCommonLangs, System.NullReferenceException, 2911, 08.03.0389.002. ErrorReportingEnabled: False

    - <Eventxmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="MSExchange Common" />
      <EventID Qualifiers="16388">4999</EventID>
      <Level>2</Level>
      <Task>1</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2016-06-08T15:17:00.000Z" />
      <EventRecordID>14944674</EventRecordID>
      <Channel>Application</Channel>
      <Computer>EMEAWP-EXUM02.corp.brocade.com</Computer>
      <Security />
      </System>
    - <EventData>
      <Data>18412</Data>
      <Data>E12</Data>
      <Data>c-RTL-AMD64</Data>
      <Data>08.03.0389.002</Data>
      <Data>exsetupui</Data>
      <Data>M.E.U.Management</Data>
      <Data>M.E.U.M.T.UmLanguagePackUtils.ComputeCommonLangs</Data>
      <Data>System.NullReferenceException</Data>
      <Data>2911</Data>
      <Data>08.03.0389.002</Data>
      <Data>False</Data>
      </EventData>
      </Event>

    This is the error i m getting while trying to uninstall.

    PS C:\Exchange2007SP3EN64> .\setup /mode:uninstall

    Welcome to Microsoft Exchange Server 2007 Unattended Setup

    Preparing Exchange Setup

    The following server roles will be removed
        UM Language Pack for de-DE
        UM Language Pack for fr-FR
        UM Language Pack for es-ES
        Unified Messaging Server Role
        Management Tools

    Performing Microsoft Exchange Server Prerequisite Check

        Unified Messaging Role Checks    ......................... COMPLETED

    Configuring Microsoft Exchange Server

        UM Language Pack for (de-DE)     ......................... FAILED
     An unexpected error has occurred and debug information is being generated: Object reference not set to an instance of a
    n object.
         Object reference not set to an instance of an object.

    Friday, June 17, 2016 11:12 AM

Answers

  • I had to clean up the dial plan from Server object in ADSIEDIT and then run the uninstall to make this happen.

    thanks

    • Marked as answer by yspintu Monday, August 1, 2016 3:27 PM
    Monday, August 1, 2016 3:27 PM

All replies

  • I am getting event ID 4999 while trying to uninstall exchange 2007 UM roles from the server.

    Watson report about to be sent to dw20.exe for process id: 18412, with parameters: E12, c-RTL-AMD64, 08.03.0389.002, exsetupui, M.E.U.Management, M.E.U.M.T.UmLanguagePackUtils.ComputeCommonLangs, System.NullReferenceException, 2911, 08.03.0389.002. ErrorReportingEnabled: False

    - <Eventxmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="MSExchange Common" />
      <EventID Qualifiers="16388">4999</EventID>
      <Level>2</Level>
      <Task>1</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2016-06-08T15:17:00.000Z" />
      <EventRecordID>14944674</EventRecordID>
      <Channel>Application</Channel>
      <Computer>EMEAWP-EXUM02.corp.brocade.com</Computer>
      <Security />
      </System>
    - <EventData>
      <Data>18412</Data>
      <Data>E12</Data>
      <Data>c-RTL-AMD64</Data>
      <Data>08.03.0389.002</Data>
      <Data>exsetupui</Data>
      <Data>M.E.U.Management</Data>
      <Data>M.E.U.M.T.UmLanguagePackUtils.ComputeCommonLangs</Data>
      <Data>System.NullReferenceException</Data>
      <Data>2911</Data>
      <Data>08.03.0389.002</Data>
      <Data>False</Data>
      </EventData>
      </Event>

    This is the error i m getting while trying to uninstall.

    PS C:\Exchange2007SP3EN64> .\setup /mode:uninstall

    Welcome to Microsoft Exchange Server 2007 Unattended Setup

    Preparing Exchange Setup

    The following server roles will be removed
        UM Language Pack for de-DE
        UM Language Pack for fr-FR
        UM Language Pack for es-ES
        Unified Messaging Server Role
        Management Tools

    Performing Microsoft Exchange Server Prerequisite Check

        Unified Messaging Role Checks    ......................... COMPLETED

    Configuring Microsoft Exchange Server

        UM Language Pack for (de-DE)     ......................... FAILED
     An unexpected error has occurred and debug information is being generated: Object reference not set to an instance of a
    n object.
         Object reference not set to an instance of an object.

    Can you try removing the UM language pack first before uninstalling Exchange?

    Blog:    Twitter:   

    Friday, June 17, 2016 11:49 AM
  • Welcome to Microsoft Exchange Server 2007 Unattended Setup

    Preparing Exchange Setup

    The following Unified Messaging language packs will be removed:

        UM Language Pack for de-DE

    Performing Microsoft Exchange Server Prerequisite Check


    Configuring Microsoft Exchange Server

        UM Language Pack for (de-DE)     ......................... FAILED
     An unexpected error has occurred and debug information is being generated: Object reference not set to an instance of a
    n object.
         Object reference not set to an instance of an object.

    Exchange Server setup encountered an error.

    This is the error i m getting while trying to remove the language first.


    • Edited by yspintu Friday, June 17, 2016 11:54 AM update
    Friday, June 17, 2016 11:53 AM
  • have you get a chance to go through following thread 

    https://social.technet.microsoft.com/Forums/office/en-US/dabc91c9-29de-4c14-bd0a-7994acc9b977/unable-to-uninstall-exchange-2007-sp3-after-migration?forum=exchangesvrgeneral

    and 

    https://social.technet.microsoft.com/Forums/office/en-US/3d400e93-08fa-46ac-990b-d1bac5e385f9/uninstall-exchange-2007-after-migrating-to-exchange-2010?forum=exchange2010

    looks you need to uninstall the server in order.


    Regards, Rajukb

    This posting is providedwith no warranties and confers no rights. If my reply answers your question please mark as answer/helpful if its helpful.


    Monday, June 27, 2016 10:56 AM
  • I had to clean up the dial plan from Server object in ADSIEDIT and then run the uninstall to make this happen.

    thanks

    • Marked as answer by yspintu Monday, August 1, 2016 3:27 PM
    Monday, August 1, 2016 3:27 PM