locked
SCCM WSUS Updates won't appear in Software Center RRS feed

  • Question

  • I am running SCCM 2012 SP1 on Windows 2012 R2. The configuration is a primary site in our colo and secondary sites at each office.  The primary site has a database hosted on a separate SQL 2008 R2 instance. I installed WSUS on the primary site and added the SUP role. Synchronization appeared to complete successfully as I have all of the updates I need in the software library.

    I have a test collection for testing updates. I went through the deployment wizard which created a deployment package and software update group which it deployed to the test collection. I confirmed that the content has been distributed properly to the local site server.

    The problem is that I still can't get these updates to show up in Software Center.

    I did some research and learned of the group policy to point Windows Updates to the local WSUS instead of Microsoft. Some info I read said that software center is supposed to update the local policy on the machine. Some info I read said that we need to push out a group policy ourselves. I checked gpedit on one of the machines in the test collection but the WSUS server was not specified. I specified the WSUS server on that machine and the number of available updates in Control Panel | Windows Updates has changed (so it appears to be communicating with WSUS) but there are still no updates in Software Center.

    I didn't find anything useful in WUAHandler, UpdatesStore, UpdatesHandler, or WindowsUpdate logs but would be happy to post any of these.

    Thanks in advance for the help!

    Thursday, October 30, 2014 11:27 PM

Answers

All replies

  • Just wait until WSUS Finish Collecting information and check for the required updates you can also open Wsus and check the complete percentage.

    for more information about Software Update please check the following:-

    http://prajwaldesai.com/deploy-software-updates-using-sccm-2012-r2/

    or

    http://www.windows-noob.com/forums/index.php?/topic/4467-using-sccm-2012-rc-in-a-lab-part-6-deploying-software-updates/

    Thursday, October 30, 2014 11:59 PM
  • WSUS has finished synchronizing. I initially set this up over a week ago so it's had plenty of time but I just double checked. I have done everything in your guide but the updates are never installed on any of the machines in the collection. I never receive any Software Center Notifications. When I open Software Center, other packages I have deployed appear but no updates.

    I have even tested removing a package and deploying it again and these changes are reflected in Software Center... so software center is working on all of these machines. The updates just never show up.


    • Edited by HAQER Friday, October 31, 2014 12:15 AM Add info
    Friday, October 31, 2014 12:11 AM
  • did you make Schedule as soon as possible and i think software update it's no appear in software Center 

    Friday, October 31, 2014 12:16 AM
  • Hi,

    Please make sure that

    •    Enable software updates on clients is set to Yes in Software Updates of Client Settings.
    •    The Software available time in Scheduling tab of deployment has reached.

     After you deploy the updates to a specific collection, have you tried to manually initiate a  "Machine Policy Retrieval & Evalution Cyce" from a client? Please check Policyagent.log to see if the client receives the policy.

    Please check the deployment status in the Monitoring workspace.

    Best Regards,

    Joyce


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.



    • Proposed as answer by Joyce L Monday, November 3, 2014 2:18 AM
    • Edited by Joyce L Thursday, November 6, 2014 9:08 AM
    • Marked as answer by Garth JonesMVP Saturday, November 29, 2014 4:07 PM
    Friday, October 31, 2014 6:16 AM
  • Cause
    ————-
    “Configure automatic updating” policy need to be configured in GPO as:  “2- 
    Notify for download and notify for install” or “3- auto download and notify 
    for install”.
    Is there any communication problem between WSUS server and client?

    Resolution
    ————-
    Confirm the GPO settings.
    WSUS MPS Report on WSUS server and WindowsUpdate.log on WSUS client.
    Monday, November 3, 2014 9:33 AM
  • Sorry for the late reply all. Thank you for all of the input. All of these settings were set but I double-checked them. I noticed one of the machines in the test collection received updates via software center so I feel like it's working. I'll check the others to make sure updates in the update package are needed.

    I AM having a weird issue though (which partially caused me to put this thread off for a bit). My SCCM/WSUS server D drive filled up with software updates because apparently WSUS was trying to download 220GB of updates. I think the problem was that I had automatic approvals for critical and security updates on in WSUS.

    I turned that off and changed the WSUS options to "Do not store update files locally", I stopped the WSUS services, deleted the contents of the WsusContent folder, and then did a wsusutil reset. The space was fine then but somehow the option keeps getting changed back to "Store update files locally".

    I checked GPO and there doesnt appear to be anything changing the WSUS options from "Do not store update files locally" to "Store update files locally". Could it be SCCM that's changing the option? I don't see anywhere in SCCM for that.

    Monday, November 17, 2014 9:42 PM