locked
Epic fail restoring user account after permissions nightmare RRS feed

  • Question

  • To my sorrow, I am using Windows 7 Home Premium 64-bit 6.1 build 7600.

    So I was using an FTP client to upload files to my website's control panel when it started to spit out errors saying that I was unable to write to c:\users\local\myusername\temp\local\softwarename\bunch of subdirectories.  I found this odd because it had no trouble writing every third or fourth file, even after I rebooted (I thought maybe some files were being used by another program or service, so...) 

    I looked at the permissions of of the users\local\myusername file and saw that it was set to "read only."  I turned that off, clicked to confirm yes to the "do you want to do this to every file and subfolder?" question, and discovered that the change didn't stick.  It would let me do it multiple times, but it kept switching itself over to read only.  I even did the old Vista trick of keeping the right click/properties dialog box open, but still no dice. 

    I rebooted again.  To my surprise it only allowed me to log in as Admin.  I looked in the user CP and saw that my username had disappeared.  My actual userfile was still in the users directory, so I tried to just recreate the login.  Yeah, right.  I got the error message: "The specified account name is not valid, because account names cannot contain the following characters:"  Well, the username doesn't have those characters.  I made sure I wasn't putting in an erroneous space or something, and still no go.  It would let me make other user accounts, even admin ones, as my new accounts named "IHateMS" and "BlowMe" now attest.  Still, I couldn't create my original userid.  Certain now that Windows is having fun with me, I went a-Googling. 

    I got this mostly useless MS article: http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3b840001 after a little bit.  It's mostly useless because it's not very explanatory for a non-MCSE type (just who thought "If you cannot issue the Repadmin command immediately, remove all network connectivity from the latent global catalog until you can use Repadmin to disable inbound replication, and then immediately return network connectivity" was clear?) so I'm sort of up a creek.  I don't have a sort of recent restore point, either. 

    How do I unscrew this?  Am I spending the evening reinstalling Windows because of this stupidity?

     

    Tuesday, July 20, 2010 12:27 AM

Answers

  • The folder users\local\myusername is not present in Windows 7 by default. I believe that this folder in your system was created by the FTP client. Which application is it? I suspect that it is compatible with Windows XP. Because in Windows XP the location of the temp folder is under \Document and Settings\local\username.

    I suggest you run the FTP client in Windows XP compatibility mode. If it does not work, contact the FTP client publisher for more information.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, August 6, 2010 5:20 AM
    Thursday, July 22, 2010 9:30 AM