locked
Outlook Search results incomplete / not highlighted when messages contain Asiatic chars RRS feed

  • Question

  • Hello, 

    Our customer has a quite large mailbox (20 GB, 100+ folders) on Outlook 365 connected to o365 account, installation language is IT-it. He receives emails from all over the world and sender addresses/subjects/attachments often contain foreign charsets (Chinese, Indian, ecc.).

    As the title says, Instant Search is not working properly, mainly in those folders used to arrange Chinese / Japanese messages.

    I’m a 2nd level support specialist and I’ve already performed all suggested procedures:
    - Deleted and rebuilt Search Index
    - Deleted and rebuild .ost file
    - Full repaired, uninstalled-reinstalled Office 365
    - Checked Search Locations, MAPI registry entries
    - Set HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\DisableBackoff to 1 (speeds up indexing)
    - Set HKCU\Software\Microsoft\Office\16.0\Outlook\Options\Search\DisableServerAssistedSearch to 1 (customer bandwidth is poor, I tried this to narrow down search engine operations to local cache only)
    - Tried in Safe Mode: search works, because Windows Search is disabled. This confirms that the problem is with indexing. Anyways, search results remain non-highlighted.
    - Disabled all plugins: same problem
    - Run the Support and Recovery Assistant for Office 365 twice, got no relevant messages.

    I ended up analyzing Systemindex.xx.gthr logs in C:\ProgramData\Microsoft\Search\Data\Applications\Windows\GatherLogs\ and found them full of  entries like this one (the error description translates to “Interface is not supported”):

    ac7c7b7 1d503ee mapi16://{S-1-5-21-2262189747-2569672509-1650840272-1105}/[omitted_email_address]($e28d8349)/0/Posta in arrivo/REVA/[chinese text]/at=[chinese text]:image001.gif 8000001c 0 80041201 Interfaccia non supportata.
    10 4294967295 6608

    or the same message with “8000000c 0 80041201” codes and no text.

    My knowledge stops here… Thanks for any help!


    • Edited by GabriwareIT Tuesday, May 7, 2019 9:58 AM asian characters displayed as ????
    • Moved by Perry-Pan Thursday, May 9, 2019 5:01 AM
    Tuesday, May 7, 2019 1:37 AM

All replies

  • Hi,

    This is a quick note to let you know that I am trying to research this issue and will get back to you later.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Edited by Perry-Pan Wednesday, May 8, 2019 3:14 AM
    Wednesday, May 8, 2019 3:13 AM
  • Hi,

    For Exchange account, do you have cached Exchange mode enabled?

    Do you have any antivirus software running on this PC? To eliminate whether this issue was related with their integration into Outlook client, please temporarily close all antivirus programs to test if search works normally.

    Have you tried a new profile?

    Besides, I've noticed that the data file size is very large(20 GB). Based on my experience, the recommended size would be around 10GB otherwise users may experience some performance issue.

    User can archive mailbox and maintain the data file to less than 10GB. Reference: Archive items manually

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Edited by Perry-Pan Wednesday, May 8, 2019 5:34 AM
    • Proposed as answer by Perry-Pan Sunday, May 12, 2019 8:44 AM
    Wednesday, May 8, 2019 5:33 AM
  • Hello Perry,

    thanks for answering and sorry for taking time to give feedback (I’m really busy these weeks)

    Yes, cached mode is enabled with “Mail to keep offline” set to All.

    Yes, we have Kaspersky antivirus installed, I removed (uninstalled) it but nothing changed.

    Also, we already created a new profile and rebuild ,ost (and I took days), but search problem persisted.

    And yes I know, the mailbox is too big and the customer has quite a low internet bandwidth so I suspect that some problems may result from this. But that MAPI search error is quite specific and I doubt that it’s performance related.

    Anyway, I also opened a support case with our partner CSP, but didn’t hear them for days now.

    Any further suggestion will be appreciated

    Wednesday, May 15, 2019 9:46 AM
  • >> Tried in Safe Mode: search works, because Windows Search is disabled. This confirms that the problem is with indexing. Anyways, search results remain non-highlighted.

    Large size of data file could possibly leads to this problem.

    If you don’t want to archive mailbox currently, we can restart Windows Search service.

    To do this, please open Run and type “services.msc”. Scroll down to find Windows Search and click Restart.

    Please also focus on your support case with partner CSP. If there are any updates, you can share here.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, May 17, 2019 5:00 AM