none
Unable to connect to hidden wireless network.

    Question

  • I have tried to follow those solved posts.  However I can't make any progress.

    Eventually I have to unhide the network to connect it.

    Having been able to connect to the hidden wireless network, I then hide the network again.  However the computer won't automatically connect to the hidden network again after the computer restarts until I unhide the network.  In this scenario, it seems to perform much worse than Windows XP.
    • Edited by healee Friday, October 18, 2013 12:34 AM
    Thursday, October 17, 2013 6:34 AM

Answers

  • Hi,

    Regarding current situation, I suggest we try to set up a new connection or network again by following these steps:

    1. Select "Manually connect to a wireless network" and click or tap "Next.

    2. Enter the security information for your network in the spaces provided. Please check on the option “Connect even if the network is not broadcasting.”

    Note Be sure to enter the information exactly as it was set up on your wireless router to ensure the connection. Once the information is completed, click or tap "Next.

    3. Provided you entered the information correctly, you’ll receive a notice of success.

    Then, please make sure that you turn off the power-save on your network adapter:

    1. Open Network and Sharing Center.
    2. Click the Change adapter settings link in the upper left of the navigation pane.
    3. Right click the network connection you want to enable/disable power management support on and click Properties .
    4. Click Configure .
    5. On the Power Management tab, clear the Allow the computer to turn off this device to save power check box.

    Then, please check the issue again.

    Hope these could be helpful and keep post.


    Regards,

    Kate Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Saturday, October 19, 2013 12:48 PM
    Owner

All replies

  • Hi,

    Regarding current situation, I suggest we try to set up a new connection or network again by following these steps:

    1. Select "Manually connect to a wireless network" and click or tap "Next.

    2. Enter the security information for your network in the spaces provided. Please check on the option “Connect even if the network is not broadcasting.”

    Note Be sure to enter the information exactly as it was set up on your wireless router to ensure the connection. Once the information is completed, click or tap "Next.

    3. Provided you entered the information correctly, you’ll receive a notice of success.

    Then, please make sure that you turn off the power-save on your network adapter:

    1. Open Network and Sharing Center.
    2. Click the Change adapter settings link in the upper left of the navigation pane.
    3. Right click the network connection you want to enable/disable power management support on and click Properties .
    4. Click Configure .
    5. On the Power Management tab, clear the Allow the computer to turn off this device to save power check box.

    Then, please check the issue again.

    Hope these could be helpful and keep post.


    Regards,

    Kate Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Saturday, October 19, 2013 12:48 PM
    Owner
  • Thanks for the advice.

    In fact I had already tried what you suggested before I posted the question.  I Googled and found that somebody had tried this.  I followed but it hadn't made any difference to me.  I have just tried again, but no difference.

    I have to select to use the existing network.  The "Connect to a network" dialog never comes up and the invisible network is never connected.

    In the meantime, my XP system is happily connected to the same hidden network wirelessly.

    Sunday, October 20, 2013 8:22 AM
  • You are not alone with this problem.

    There is a flaw in Windows 8.1 which prevents it from connecting to hidden networks even though the network profile exists and has been connected to successfully many times previously. This behaviour appears fairly random as I can get my hidden network connected automatically for some weeks and then mysteriously Windows will refuse to connect to it.

    It's very frustrating to have to create a new wireless network profile for a connection which is already present and can and should connect automatically, particularly as Microsoft have removed the GUI to manage wireless profiles.

    My Android phone and even my PS3 are able to connect to the hidden network without issue (and without fail each and every time) and yet Windows cannot manage this basic function of wireless networking.

    Microsoft need to address this issue.

    Friday, February 28, 2014 11:33 PM
  • You are not alone with this problem.

    There is a flaw in Windows 8.1 which prevents it from connecting to hidden networks even though the network profile exists and has been connected to successfully many times previously. This behaviour appears fairly random as I can get my hidden network connected automatically for some weeks and then mysteriously Windows will refuse to connect to it.

    It's very frustrating to have to create a new wireless network profile for a connection which is already present and can and should connect automatically, particularly as Microsoft have removed the GUI to manage wireless profiles.

    My Android phone and even my PS3 are able to connect to the hidden network without issue (and without fail each and every time) and yet Windows cannot manage this basic function of wireless networking.

    Microsoft need to address this issue.

    I have the same problem. Every time I connect I also get a new number (by now the network connection name is "HiddenNetwork 2 3 4 5 6 7 8 9 10 11 12 13 14 15". The hidden profiles also don't show up when typing 'netsh wlan show profiles' in the command prompt.
    Thursday, March 20, 2014 9:12 AM
  • Thanks guys!

    I wonder when Microsoft is going to fix this problem.  It is very important to me.  I don't want to expose my private network.  Now because of the so-called modern technology, I have to put everything backwards.

    Thursday, March 20, 2014 8:41 PM
  • the Same problem is here :( I have lot's of networks with postfix 2 3 4 5..... on the name


    Wednesday, April 2, 2014 5:29 AM
  •      I just "upgraded" a working installation of Windows 8 Pro MAK (like volume license) on an older laptop we were doing testing on (Dell Latitude with Core 2 Duo).  I had to do a fork-lift upgrade from 8 Pro to 8.1 Enterprise (evaluation) because my 8.0 installation is under a volume license (MAK) program.  So after the fork lift upgrade was done not only can I not connect to my hidden network, if I try to create a new connection to a hidden network manually it appears to create it but the connection never shows in my list of wi-fi...just the old "Hidden network" at the bottom.  I've manually added it many times, and I know the OS knows it is there because it tells me it already exists, yet it never shows in the wi-fi list.  Please Microsoft, don't ignore these issues as we are a large enterprise poised to make OS purchase decisions for the furture and if Windows 8.1 is going to have so many more issues than 8.0 has (like no "real" Start Button) we might well become a Linux-use company.

    Bill IT

    Tuesday, April 8, 2014 9:45 PM
  • I had been a very strong Windows supporter.  However I am very disappointed that Microsoft still hasn't fixed this bug since I reported long time ago.  This is a very important feature as far as I feel.  How can something go backwards while systems are supposed to improve as time goes by.

    By the way, I wonder how you could connect Windows 8 to a hidden wireless network.  I couldn't do that at all, not to mention Windows 8.1.

    Tuesday, April 8, 2014 11:56 PM
  • I have the same issues, windows 7 works great, windows 8.1 does not.  Please make window 8 go away and bring back XP.
    Friday, April 18, 2014 2:01 PM
  • On Windows 8.0 I was successfully able to connect to the Hidden Networks. The moment I upgraded Windows to the Version 8.1, I couldn't connect anymore to any hidden network!

    Thursday, May 8, 2014 6:52 PM
  • Great this solution solved my hidden wireless network connection problem. Thanks again Kate Li
    • Edited by Moshiur Rahman Khan Friday, July 4, 2014 8:50 AM Hidden wireless network connection problem
    Friday, July 4, 2014 8:48 AM
  • What have you done to fix the problem?

    Please elaborate!

    Saturday, July 5, 2014 12:58 AM
  • healee

    Did you read Kate Li's post which is marked as an answer?


    Wanikiya and Dyami--Team Zigzag

    Saturday, July 5, 2014 1:36 AM
    Moderator
  • Hi, I am currently on a windows 10 operating system, I have updated my drivers, re-tried adding the hidden network, and tried multiple different methods. When I try to connect to the network from CMD to get a more specific error, it says The network specified by profile "Network Name" is not available to connect. Any solution? I do not know the username and password of my router, so I cannot broadcast the SSID, because of the idiot who set it up... Thanks for the feedback.
    Saturday, August 20, 2016 6:30 PM
  • Other day I had the same problem - my win 8.1. laptop could not found hidden wifi or any other wifi. All I had to do to make it work again was to turn of my bluetooth and then restart my computer. Maybe this will be helpful for someone.
    Saturday, September 10, 2016 2:05 PM
  • Hi,

    After apply the upgrade from windows 7 to windows 10, I was unable to connect to hidden networks, to solve this issue I followed the nexts steps:

    1. Add manually your hidden network connection, don't forget to enable the option "Connect even if the network is not broadcasting".
    2. If your SSID has not enable the broadcasting, you must enable the broadcasting on your Wireless device(Router, Modem, AP, etc.).
    3. Connect to the network and then enter on your wireless device and disable the broadcasting. If your computer still connected to the network, the issue probably was solved, you can restart you PC and must connect to hidden network.

    This Workaround works for me, but I was not able to test on other computer, after that I applied the steps above, the issue apparently was solved. Please leave your commentaries about is this quick steps work for you.

    Monday, August 7, 2017 5:16 PM