none
IE 11 blocks access to "Microsoft Update" service

    Question

  • Using Windows Update on Windows 7 SP1, there is an option to enable "Microsoft Update" at the bottom to also update Office and other Microsoft applications:

    Get updates for other Microsoft products. Find out more.

    ,

    This opens a webpage, which in IE 10 and earlier, allows me to enable Microsoft Update.

    However, IE 11 does not show the page to enable Microsoft Update but shows a useless and unrelated help message:

    Use your Start menu to check for updates

    How am I supposed to enable the optional Microsoft Update service now?

    Thursday, December 12, 2013 6:22 AM

Answers

  • You can add microsoft.com under compatibility view settings and then you'll get the correct page.
    • Proposed as answer by Gboxpro Monday, December 16, 2013 9:28 PM
    • Marked as answer by Cloud_TSModerator Monday, December 23, 2013 8:09 AM
    Monday, December 16, 2013 9:26 PM

All replies

  • I have exactly the same issue and have seen it a few times on IE11.  The only way I was able to continue to get updates on other MS Products like Office was to remove IE11 and allow it to go back to IE10.  Then ALLOW UPDATES to other MS Products option is available again.

    Hope this helps.

    Friday, December 13, 2013 9:54 PM
  • How am I supposed to enable the optional Microsoft Update service now?

    Click on the Change Settings button.  There is a checkbox for Microsoft Update in  Choose how Windows can install updates.



    Robert Aldwinckle
    ---


    Saturday, December 14, 2013 2:08 PM
    Answerer
  • Hi,

    You may clear the temporary Internet files and the history for a test.

    1.Click Tools.

    2.Click Internet Options and then click the General tab.

    3.In the Temporary Internet Files section, click Delete Files, and then click OK.

    4.In the History section, click Clear History, and then click OK.

    Based on my test, I also would like to suggest you try the following to fix the issue:

    Reset Internet Explorer settings:

    http://support.microsoft.com/kb/923737

    Please understand that reset Internet Explorer to its default configuration. This step will also disable any add-ons, plug-ins, or toolbars that are installed.

    Then, open the Microsoft Update webpage, you will see "The webpage wants to run the following add-on: "Windows Update Vista Control from "Microsoft Corporation"." at the bottom of the page.

    You should click "allow".

    In addition, I would like to suggest you try to use compatibility mode (go to tools --> Compatibility View Settings) to check the issue.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Sunday, December 15, 2013 9:49 AM
    Moderator
  • Will try this next time I hit the issue and let you know. Thanks for the suggestions.
    Sunday, December 15, 2013 2:53 PM
  • You can add microsoft.com under compatibility view settings and then you'll get the correct page.
    • Proposed as answer by Gboxpro Monday, December 16, 2013 9:28 PM
    • Marked as answer by Cloud_TSModerator Monday, December 23, 2013 8:09 AM
    Monday, December 16, 2013 9:26 PM
  • Thanks Gboxpro, that fixed the problem
    Wednesday, December 18, 2013 12:23 PM
  • You can add microsoft.com under compatibility view settings and then you'll get the correct page.

    Worked a charm Gboxpro. TYVM!
    Sunday, December 22, 2013 3:22 AM
  • Thank you!

    Adding microsoft.com under compatibility view worked !!!

    Saturday, February 22, 2014 7:30 AM
  • I had the same issue as reported here "IE 11 ate my Microsoft Update" (Win 7 Ultimate SP1).

    There is no check box at all under "Choose how Windows can install updates" in Windows Update > Change Settings, there is only a link "How does automatic updating help me?".

    Further down there are two check boxes "Give me recommended updates the same way I receive important updates" and "Allow all users to install updates on this computer". There are no other check boxes in this dialog.

    After I added microsoft.com to the compatibility list in IE11 and enabled Microsoft Update, several new check boxes appeared in the "Choose how Windows can install updates" dialog.
    • Edited by Per Mildner Wednesday, March 19, 2014 9:14 AM
    Wednesday, March 19, 2014 9:08 AM
  • This is still broken 4+ months later? Come on Microsoft, get your butt in gear

    Wednesday, April 30, 2014 2:15 AM
  • This is still broken 4+ months later? Come on Microsoft, get your butt in gear

    http://social.technet.microsoft.com/Forums/en-US/51fd7dbf-1647-486e-af59-07af6be22ce3/enable-the-microsoft-products-updates-problem?forum=w7itproinstall

    log a bug on connect...


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Proposed as answer by Ralph Malph 2 Monday, February 13, 2017 9:27 PM
    Wednesday, June 25, 2014 9:22 PM
  • You can add microsoft.com under compatibility view settings and then you'll get the correct page.

    I have a similar situation at the Hospice I support. We access our vendor's Citrix servers via the web. The https web site loads, but we get a black window. Addint the url to the "Compatibility Settings" resolves the issue. The problem lies in the fact that these computers are shared by a large number of nurses. The first time each nurse tries to load the Citrix Access Gateway, they have to add it to the compatibility settings. Needless to say, this generates a number of support calls.

    With the help of the vendor, I was able to create a batch file that imports a REG file to add the to the registry. I added it to the All Users Startup folder, but this generates an "Access Denied" message when when user logs on.

    All logons are domain logons and users basically are locked down from making any changes. Is there a way to automatically add the url to the compatibility settings?


    Regards, Hank Arnold (MVP - DS)

    Thursday, August 07, 2014 11:04 AM
  • Is there a way to automatically add the url to the compatibility settings?

    Here's one method:
    http://blogs.msdn.com/b/asiatech/archive/2013/10/23/how-to-add-web-site-to-compatibility-view-list-via-gpo.aspx

    and another, for EMIE:
    http://technet.microsoft.com/en-us/library/dn640699.aspx


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)


    • Edited by DonPick Thursday, August 07, 2014 10:05 PM
    Thursday, August 07, 2014 10:02 PM
  • HAHA! How ironic! Microsoft's own browser is not compatible with the Microsoft website. EPIC FAIL!
    Friday, August 29, 2014 8:00 AM
  • HAHA! How ironic! Microsoft's own browser is not compatible with the Microsoft website. EPIC FAIL!

    ***SNICKER*** Well yeah, I really do think...
    https://www.youtube.com/watch?v=-GuOceSJWas
    Friday, August 29, 2014 9:01 AM
  • Thanks for this. I have been looking at this issue over 6 weeks. So simple. So stupid.


    Robert Tankersley

    Wednesday, October 15, 2014 5:28 PM
  • You can add microsoft.com under compatibility view settings and then you'll get the correct page.

    On 2012 + IE10 I also had to add it to trusted sites as show on picture:

    2012 with IE10

    Thursday, December 11, 2014 8:03 AM
  • Thank you for this information, Gboxpro! I can't imagine how many times I have just given up on this setting because it wouldn't load right! Microsoft, if you are reading this, please post this solution to the stupid page that loads letting users know that if they are seeing the useless page, to add microsoft.com to the compatibility view list! How hard can that be! 

    If all you users out there think Microsoft should put the solution on the useless page, please vote on this reply! 

    • Edited by Creeddude98 Friday, December 12, 2014 11:54 PM
    Friday, December 12, 2014 11:52 PM
  • Thanks
    Friday, February 13, 2015 1:34 AM
  • You can also check "Use Microsoft compatibility lists" in Compatibility View Settings.  Apparently Microsoft adds their own domain to this list.  After checking this box, closing IE I could then options to check for other Microsoft products. 
    Thursday, February 19, 2015 4:04 PM
  • Thank you so much!

    This saved my day. As a matter of fact, I just used your last tip to solve my issue ("Use Microsoft compatibility lists" in Compatibility View Settings).


    • Edited by Zorbinho Wednesday, March 18, 2015 2:35 PM misspelling
    Wednesday, March 18, 2015 2:27 PM
  • WRONG..!
    Saturday, August 08, 2015 12:24 PM
  • Looks like the help message will be (mostly) right in W10  <eg>

    https://social.technet.microsoft.com/Forums/en-US/e6475259-bc27-48f4-bf28-bc0baa2b0d25/wuappexe-missing?forum=win10itprogeneral

    In W8.1 RT  Alt-T U still works but it doesn't have the Change Settings option.  I'll try to remember to check on W7sp1 when I see one.



    Robert Aldwinckle
    ---

    Sunday, August 09, 2015 5:57 PM
    Answerer
  • I'll try to remember to check on W7sp1 when I see one.

    It's still there.



    Robert Aldwinckle
    ---

    Monday, August 10, 2015 4:32 AM
    Answerer
  • For those whose default browser is no longer Internet Explorer:  You can also get at the setting by opening IE, enabling compatibility view for microsoft.com (as described below) and then navigating to:

    http://go.microsoft.com/fwlink/?LinkId=70156

    That's where the hyperlink points.

    (Not sure why Microsoft couldn't just make this work like a normal setting).

    Thursday, November 19, 2015 9:23 AM
  • @rkagerer, Thank you!!

    The windows update screen was not updating after the the compatibility view changes were made.

    And I really did not want to reboot this machine just to get it to take effect.

    So, using that link, it has been fixed immediately.

    Thank you!!

    Thursday, December 03, 2015 4:37 PM
  • Simply install Microsoft Silverlight which will ask to enable Microsoft updates at the end of setup ...
    • Proposed as answer by bobutler Sunday, February 07, 2016 10:24 AM
    • Unproposed as answer by bobutler Sunday, February 07, 2016 10:26 AM
    • Proposed as answer by bobutler Sunday, February 07, 2016 10:26 AM
    Tuesday, January 26, 2016 8:05 PM
  • THANK YOU.

    It worked like a charm!

    Friday, March 04, 2016 7:42 AM
  • @rkagerer,

    Thank you! Of all the many assorted "answers" to this common problem, yours was the only one that worked for me! How could Microsoft allow this apparently easy to fix problem go on? Simply ridiculous!

    Sunday, March 06, 2016 4:11 PM
  • opening IE, enabling compatibility view for microsoft.com (as described below) and then navigating to:

    http://go.microsoft.com/fwlink/?LinkId=70156

    That redirects here

    http://www.update.microsoft.com/windowsupdate/v6/vistadefault.aspx?ln=en-US

    which says to use the Vista Start Menu.

    even if I try to simulate that using the Developer Tools, Emulation tab.  E.g., it already is getting Document Mode 5 but with User-Agent string for IE11.  So I override that with IE7 and then use right-click Go to Copied address (for the go.microsoft one) and still get that Vista Start Menu tip.

    How does this help?  Just as a way to find  wuapp.exe?  Then just use  Win-R to get that.

    BTW instead of Run... wuapp.exe  in W10 we now need to use  Run...  ms-settings:windowsupdate



    Robert Aldwinckle
    ---

    Sunday, March 06, 2016 5:06 PM
    Answerer
  • Worked great on 2 computers that I was having the problem on.
    Thursday, March 10, 2016 5:14 PM
  • Thanks, that's a massive help
    Thursday, June 23, 2016 11:48 PM
  • worked for me!

    Dan C.

    Wednesday, August 17, 2016 12:44 PM
  • Gboxpro listed here has the correct answer!!!

    You can add microsoft.com under compatibility view settings and then you'll get the correct page.


    Steve Merena


    Thursday, October 20, 2016 6:30 PM
  • Awesome, I was having the same issue and this solved the problem immediately!

    Friday, February 24, 2017 1:53 PM
  • Yup this worked but still What the Foie Gras?

    Friday, March 03, 2017 10:26 PM
  • Gboxpro thank you that fixed the problem. Another instance of MS software engineers doing a sloppy job with ie11. Instead of fixing it they release a new browser that is just as bad.

    Tuesday, March 14, 2017 3:57 PM
  • Gboxpro thank you that fixed the problem. Another instance of MS software engineers doing a sloppy job with ie11. Instead of fixing it they release a new browser that is just as bad.

    Aye.  And they wonder why so many people have defected to Firefox or Chrome.

    So, I assume the best solutions out there are to try it Gboxpro's way, or activate Microsoft Update BEFORE installing Internet Explorer 11, yes?

    Saturday, March 18, 2017 9:14 AM
  • Gboxpro thank you that fixed the problem. Another instance of MS software engineers doing a sloppy job with ie11. Instead of fixing it they release a new browser that is just as bad.


    Actually this appears to occur the first time you open Internet Explorer 11 and it gives you the dialogue box asking to "use recommended settings" such as enabling compatibility view, SmartScreen Filter, etc. or not to use recommended settings.  When you select not to use recommended settings or just exit out of the prompt without selecting either, it will not create the Compatibility View "trusted" exception for Microsoft.com.
    Saturday, April 22, 2017 4:28 PM