locked
Server Manager: Catastrophic failure RRS feed

  • Question

  • On a Windows Server 2008 with SP2 server, I'm experiencing errors running Windows Updates and when opening Roles/Features in Server Manager. The error I'm getting is "Unexpected error refreshing Server Manager: Catastrophic failure (Exception from HRESULT: 0x8000FFF (E_UNEXPECTED))". I ran the system update readiness tool and the first time around it looks like it fixed an issue. I've ran it again and I believe it's reporting clean now. I'm not really sure where to go from here but any help would be appreciated. Thanks

     

    Here is the bottom of the servermanager.log:

    5356: 2010-08-23 10:49:26.673 [LoadExtensionAssemblies]   No extension assemblies registered.

    5356: 2010-08-23 10:49:26.807 [OobOptionalComponentInfo]  Loading OCs from registry.

    5356: 2010-08-23 10:49:29.505 [CBS]                       LastModified CBS Time (UTC): 07/24/2010 08:47:26

    5356: 2010-08-23 10:49:29.511 [CBS]                       Cache Last Write Time (UTC): 03/05/2010 19:14:02

    5356: 2010-08-23 10:49:29.518 [CBS]                       IsCacheStillGood: False.

    5356: 2010-08-23 10:49:29.629 [CBS]                       CreateSessionAndPackage: begin

    5356: 2010-08-23 10:49:47.811 [CBS]                       CreateSessionAndPackage: done

    5356: 2010-08-23 10:49:47.822 [CBS]                       >>>GetUpdateInfo--------------------------------------------------

    5356: 2010-08-23 10:50:32.445 [CBS] Error (Id=0) Function: 'ReadUpdateInfo()->Package_EnumerateUpdates' failed: 8000ffff (-2147418113)

    5356: 2010-08-23 10:50:32.457 [CBS]                       <<<GetUpdateInfo--------------------------------------------------

    5356: 2010-08-23 10:50:32.706 [ExceptionHandler] Error (Id=0) An unexpected exception was found:

    System.Runtime.InteropServices.COMException (0x8000FFFF): Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))

       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)

       at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()

       at Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection documents)

       at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)



    The first time I ran the system update readiness tool, here is the CheckSUR.log:
    =================================
    Checking System Update Readiness.
    Binary Version 6.0.6002.22359
    Package Version 8.0
    2010-08-22 21:12

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store
    (f) CSI Manifest Zero Length 0x00000000 winsxs\Manifests\x86_a313cfb3d6e8b410cc327d5ae24cb1ba_31bf3856ad364e35_6.0.6001.22581_none_74373b8beeda2468.manifest x86_a313cfb3d6e8b410cc327d5ae24cb1ba_31bf3856ad364e35_6.0.6001.22581_none_74373b8beeda2468
    (fix) CSI Manifest Zero Length CSI File Replaced File: x86_a313cfb3d6e8b410cc327d5ae24cb1ba_31bf3856ad364e35_6.0.6001.22581_none_74373b8beeda2468.manifest From: C:\Windows\CheckSur\v1.0\windows6.0-6001-servicing-x86-apr10.cab

    Summary:
    Seconds executed: 336
     Found 1 errors
     Fixed 1 errors
      CSI Manifest Zero Length Total count: 1
      Fixed: CSI Manifest Zero Length.  Total count: 1
    (w) Unable to get system disk properties 0x0000045D IOCTL_STORAGE_QUERY_PROPERTY Disk Cache

    The second time I ran the system update readiness tool:

    =================================

    Checking System Update Readiness.

    Binary Version 6.0.6002.22359

    Package Version 8.0

    2010-08-23 10:07

     

    Checking Windows Servicing Packages

     

    Checking Package Manifests and Catalogs

     

    Checking Package Watchlist

     

    Checking Component Watchlist

     

    Checking Packages

     

    Checking Component Store

     

    Summary:

    Seconds executed: 374

     No errors detected

    (w) Unable to get system disk properties 0x0000045D IOCTL_STORAGE_QUERY_PROPERTY Disk Cache

     

     

    Monday, August 23, 2010 4:12 PM

Answers

All replies

  • Try the following article below.

    http://blogs.technet.com/b/roplatforms/archive/2010/05/12/how-to-fix-server-manager-errors-after-installing-updates-hresult-0x800f0818-hresult-0x800b0100.aspx

     


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    Monday, August 23, 2010 7:29 PM
  • That article talks about running the System Update Readiness tool. I've already did that during my initial troubleshooting, and my CheckSUR.log file logs are in the first post. It found an error during the first run, but after the second run, it came back clean.
    Monday, August 23, 2010 7:35 PM
  • Hi Cody,

     

    Please check the permissions on  the root of C: and ensure that BUILTIN\Users have Read access referring to the article below and see whether it can be fixed.

     

    Windows Update fails with 8000FFFF (E_UNEXPECTED)

    http://blogs.technet.com/b/brad_rutkowski/archive/2008/07/03/windows-update-fails-with-8000ffff-e-unexpected.aspx

     

    If that won’t work, I’m afraid you will have to perform an in-place upgrade of Windows Server 2008 to fix the problem if your computer is not a DC.

     

    Regards,

    Karen Ji


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ” This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, August 24, 2010 6:05 AM
  • # for hex 0x45d / decimal 1117 :
      ERROR_IO_DEVICE                               winerror.h
    # The request could not be performed because of an I/O device
    # error.
     
    I was wondering if running chkdsk on the system volume (without any
    parameters) returns any inconsistencies? Also, do you have any errors or
    warnings in the event logs?
     

    -- Mike Burr
    Tuesday, August 24, 2010 2:41 PM
  • Karen,

    I don't have that error in my event logs. Also, this is on a domain controller. I don't have the builtin\users group, but do have a domainname\users group and the permissions on the root of the C:\ look to be correct.

     

    Mike,

    I ran a readonly chkdsk and it appears to have found errors, below. I'll see about fixing those tonight.

    C:\Users\Administrator>chkdsk

    The type of the file system is NTFS.

     

    WARNING!  F parameter not specified.

    Running CHKDSK in read-only mode.

     

    CHKDSK is verifying files (stage 1 of 3)...

      133248 file records processed.

    File verification completed.

      1318 large file records processed.

      0 bad file records processed.

      0 EA records processed.

      156 reparse records processed.

    CHKDSK is verifying indexes (stage 2 of 3)...

    Index entry Microsoft.WinFX.targets in index $I30 of file 804 is incorrect.

      176604 index entries processed.

    Index verification completed.

     

    Errors found.  CHKDSK cannot continue in read-only mode.

     

    I also have event 55 in my event logs that appears to happen when the system state backup job kicks off.

    The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume VHD.

    Tuesday, August 24, 2010 3:21 PM
  • It might be worth trying a chkdsk /R (which will prompt to run a check
    and attempt to repair inconsistencies in the filesystem and on the disk
    at the next reboot), from there, I would verify the protected OS files with
     
    sfc /scannow
     
    and then re-run the SUR tool. I would also recommend running a
    diagnostic on the disk affected as these corruptions may be an early
    warning of a failing disk.
     

    -- Mike Burr
    Tuesday, August 24, 2010 4:57 PM
  •  Hi Cody,
     
    I was wondering if you were able to run the chkdsk and if you were able
    to re-run the SUR tool? Was there anything different in the CheckSUR.log
    file?
     

    -- Mike Burr
    Saturday, August 28, 2010 9:19 PM
  • I know this post is very old but I kept running across it when searching for a solution to this issue, and I figure other people are as well. The way I fixed it, after days of trying different things and being on the verge of formatting the server, is detailed in my own thread here: http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/582e885f-8a33-4791-ad99-3470c1f010be

    This is for people who tried system update readiness tool and found no errors in the logs and who are still able to receive updates but can't view any features or roles in server manager. 

    Extremely simple solution!

    Sunday, July 3, 2011 8:33 AM
  • Try the solution in this thread (worked for me):

    http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/582e885f-8a33-4791-ad99-3470c1f010be/#abf85855-a3a1-4bd4-a3b3-906dd4a8662b

    Quote from noamo48  "

    Go to registry and delete the following keys (i only had two of the three and it worked anyways):

    • HKEY_LOCAL_MACHINE\COMPONENTS\PendingXmlIdentifier
    • HKEY_LOCAL_MACHINE\COMPONENTS\NextQueueEntryIndex
    • HKEY_LOCAL_MACHINE\COMPONENTS\AdvancedInstallersNeedResolving

    Reboot and that's it!

    "

    Tuesday, July 12, 2011 1:32 AM