locked
Game Mode results in screen off in Dishonored 2 RRS feed

  • Question

  • Hi,

    I tried to deal with the occasional stutter in DH2 by means of the new game mode. Unfortunately, after activating the game mode initially and a really bad gaming experience (game slows down massively during character movement, sometimes comes to a complete halt), when I start the game now, my display goes to soft off after a couple of seconds.

    I can tab out and the display returns, and I can tab in again and sometimes I am lucky and the display stays on initially. But never for long. The game itself seemingly continues to run fine in the background.

    I tried the following things, but nothing helped.

    - disable game mode in the Windows settings

    - validate game files in steam

    - disable SLI

    - disable the on-screen display of the MSI Afterburner

    - press Win+G to get back the Game Bar to disable Game Mode for this game myself, but the bar won't reappear

    So...

    1. I am looking for a solution for this particular problem.

    2. I would be happy for a way to undo any changes, game mode does to a particular game.

    3. I would be very happy about an option for taking individual games "off the list" of the game mode in case it just won't start correctly anymore.

    Thanks for any input!


    Sunday, April 16, 2017 7:49 AM

All replies

  • Hi pegnose,

    Is this the first time to play the game (DH2) on this machine? What is the exact machine model? Did the issue only occur with the specific game or all the games? Did the issue occur when we run the game with the "Game mode" disabled previously? 

    First of all, please ensure the machine is up to date. Update all the drivers from the device manufacturer website for Windows 10 compatible drivers.

    Turning on Game Mode will isolate some CPU resources and prioritizes GPU access to the game that is running. This is done by dedicating one or more processor cores to the game as well as prioritizing GPU access for use by the game. To disable the game mode for the specific game, we should enable the game bar for the game (Win+G)and choose the settings option to disable game mode but it seems that it didn't work for this issue. So I think the issue is not caused by the game mode. You could try to disable the game mode  before we ran the game then check the symptom again.

    According to my research, there is specific hardware requirement to play that game. Please ensure your machine hardware met the requirement.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, April 17, 2017 2:22 AM
  • Hi MeipoXu,

    Thank you for the quick reply! I'll try to address all or your questions and suggestions:

    - I have played DH2 for extended periods on this machine. Never showed that behavior

    - Here is my rig:

    Mainboard: ASUS M. VIII Hero (Bios 1902)
    CPU: 6700k @ 4.6 GHz (4.7 for 2 cores; via BIOS settings)
    CPU Cooler: Noctua NH-D15
    RAM: 32 GB (2x16) Corsair Vengeance LPX 3000 MHz 15-17-17-35 2T (XMP; currently 3200 MHz 1T)
    GPUs: 2x GTX 1080 FTW SLI with HB bridge (OC: +70 Core +400 Vram)
    Power supply: Corsair CX850M (v2)
    System Drive: Samsung SM951 256 GB AHCI M.2 SSD
    Games Drive: Sandisk Ultra II 1 TB SATA SSD
    Data Drives: 2x WD Green 3 TB in Raid 1 (connected to Intel Z170)

    - I think I meet the game's requirements.

    - So far I have only tried this game as I didn't want to break my complete library.

    - The issue did not occur prior to enabling the game mode for this particular game. The issue also does not occur for any other game I play. The performance and reliability of my system is outstanding otherwise.

    - So I am indeed pretty sure the issue is caused by the game mode.

    - Windows is up to date, obviously.

    - The GPU driver is up to date (381.65).

    - Which system drivers should be relevant in particular?

    - I can't disable the game mode for this game anymore, as the game bar won't reappear pressing Win+G (as I explained above). I also tried disabling the game mode altogether via the Windows settings. But that didn't help either.

    - You think the game mode is not responsible, because the game bar won't reappear?! I think exactly this fact shows pretty well that there is a problem with the game mode and this particular game.

    Thanks again!


    Monday, April 17, 2017 9:53 AM
  • Ok, so I updated the following drivers and rebooted:

    - Chipset

    - Management Engine

    - USB 3.0 (ASM)

    - Intel Storage

    - Audio

    Then I was able to start the game again normally. Without the screen going to soft off.

    Game mode surprisingly was off then for that game. I could turn it on again (via the game bar), and the slowing down/freezing reappeared. I could also turn it off again via the game bar, and the performance was back to normal. Repeated this twice. So game mode is not working well with DH2.

    SLI was off at that time. Out of curiosity, I turned SLI on an this behavior stayed the same.

    Then I rebooted my PC (because I did that the last time before the sceen-off thing was there), and now (I left game mode on before the reboot) still the slowing down/freezing, but I can't turn game mode off any more for this game! When I try to open the game bar, my screen blinks 2 or 3 times, and then nothing happens. So again this game is STUCK. Game bar and game mode are enabled in the Windows settings.

    Game mode seems to be bugged to me. At least for that game, but I doubt it is that specific.

    MS please fix that.



    • Edited by pegnose Monday, April 17, 2017 11:32 AM typos
    Monday, April 17, 2017 11:30 AM
  • Great, now the Event Log service is constantly hogging a CPU core (persists reboot). That's certainly a situation where the Game Mode comes in handy. Haha.

    I'll go roll back my system now. Creators Update is not ready for release, yet.

    x_x

    Monday, April 17, 2017 12:10 PM