Drive with an unrecognised configuration - Storage spaces


  • Hi guys,

    I've got an issue with storage spaces that I can't solve.

    In the Storage spaces panel I got the message that I have "Drives with an unrecognized configuration" (but no further information regarding which disk). I got the option to repair one of the storage space which had reduced resiliency. Then I thought that the problem was solved but the "unrecognized configuration" message is still there. I have tried to re-attach the bad disk but the message is still there (and the disk doesn't show up in the "physical disks" tab).

    I ran these Power Shell commands (I'm completely new to PS):

    Get-PhysicalDisk | fl *
    Get-StoragePool | fl *
    Get-VirtualDisk | fl *

    It seems that my RAID 1 boot disks are unhealthy but they aren't included in the Storage spaces.

    What can I do to solve this problem?

    Saturday, July 27, 2013 9:59 PM

All replies

  • Hi,

    Please attach this unhealty disk separately and check disk on it. If any error message is received, please let me know.

    Niki Han
    TechNet Community Support

    Monday, July 29, 2013 9:09 AM

  • Hi and thanks for your reply

    I've now attached the disk to another machine running Win 8. Unfortunately the disk isn't visible in explorer but I can see it in "Disk management" as an Basic online disk with all space unallocated:

    I'm sorry for my lack of knowledge dealing with things like these.

    How do I move on from here?

    • Edited by FrvBr Tuesday, July 30, 2013 7:20 PM edit
    Tuesday, July 30, 2013 7:19 PM
  • Is there any data on this disk? If not, I suggest you change this disk to MBR partition style.

    Niki Han
    TechNet Community Support

    Saturday, August 03, 2013 8:23 AM
  • Hi!

    I formatted the disk as a MBR with NTFS and ran chkdsk with this result:

    Microsoft Windows [Version 6.2.9200]
    (c) 2012 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>chkdsk E: /f /x /r
    The type of the file system is NTFS.
    Volume label is New Volume.

    CHKDSK is verifying files (stage 1 of 5)...
      256 file records processed.
    File verification completed.
      0 large file records processed.
      0 bad file records processed.

    CHKDSK is verifying indexes (stage 2 of 5)...
      274 index entries processed.
    Index verification completed.
      0 unindexed files scanned.
      0 unindexed files recovered.

    CHKDSK is verifying security descriptors (stage 3 of 5)...
    Security descriptor verification completed.
      9 data files processed.

    CHKDSK is verifying file data (stage 4 of 5)...
      240 files processed.
    File data verification completed.

    CHKDSK is verifying free space (stage 5 of 5)...
      488285455 free clusters processed.
    Free space verification is complete.
    Adding 2 bad clusters to the Bad Clusters File.
    Correcting errors in the Volume Bitmap.

    Windows has made corrections to the file system.
    No further action is required.

    1953381375 KB total disk space.
        113728 KB in 5 files.
             4 KB in 11 indexes.
             8 KB in bad sectors.
        125819 KB in use by the system.
         65536 KB occupied by the log file.
    1953141816 KB available on disk.

          4096 bytes in each allocation unit.
     488345343 total allocation units on disk.
     488285454 allocation units available on disk.

    Do you have any clue on what I can do to solve my Storage Spaces issue?

    Monday, August 05, 2013 12:14 PM
  • OK,

    I gave up on this since no help was available.

    I created a new storage pool and moved every file to this one and then deleted the old pool. Now everything works fine.

    Saturday, August 31, 2013 11:18 AM