none
DPM 2016 Tape Backup problem Error ID 2019 RRS feed

  • Question

  • I have been struggling with an issue backing up to tape for nearly a week now. One of our long term protection jobs started throwing a variety of error but I primarily see the 2019 event Which indicates "an existing connection was forcibly closed by the remote host". When it refers to a remote host I'm not entirely sure what it is talking about since the tape backup should be using the replica on the DPM server and not the source when it backs up to tape.

    So far all of our other Tape backups are fine and all of our backup to disk jobs are running including the one in the protection group that this long term protection belongs to. 

    I had seen some information indicating the files were corrupt and was able to track down the volume label for the offender and run chk disk against it on the DPM server. It repaired a few things and I have not seen an inconsistent replica or corruption message since but the job still fails.

    I updated SQL to sp2, DPM to Rollup6, patched everything I could think of and updated the .Net version post encountering this problem and the issue remains. Can anyone explain what is going on?

    Thursday, August 30, 2018 4:10 PM

All replies

  • Hi,

    Could you provide us the exact errors you are receiving? Anything interesting in the Event Log as well?

    Also have you tried removing the backup from the protection group and re-add it?


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 30, 2018 4:17 PM
  • I have not tried removing from the protection group as of yet, although that does leave me with another question. If I were to remove the server from the protection group (it is the only member of the group) wouldn't that cause DPM to create a new volume and a new replica when I add it back? I should have mentioned but the source machine is a 2008 R2 server and we are backing up the volumes not the files. I only ask since the size of the volume is relatively large for our environment, somewhere near the 1 TB mark.

    I'll check the log and post back with what I see there.

    Thursday, August 30, 2018 4:56 PM
  • The back up to tape job failed for the following reason: (ID: 3311)

    (ID: 2019)

    This is really all I am getting now each time I run the job. It does begin to run and gets somewhere above 25 GB into transfer before I see this typically.

    Thursday, August 30, 2018 5:00 PM
  • Try the following on the protected server

    Add the following DWORD with name ConnectionNoActivityTimeout in the path HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent and set the value to 180.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 30, 2018 8:29 PM
  • If I may ask why would this be needed on the protected server since the tape backup writes from the replica?
    Thursday, August 30, 2018 9:19 PM
  • Could you provide a screenshot of the error that is displayed in the Monitoring

    There's an old post but with similar issue here, the registry fix seems to have fixed the problem there.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 30, 2018 9:28 PM
  • Reran the backup after your suggestion. It's still running right now so we will see what happens. I was just very curious why this solution could work / what is going on with the tape backup since the documentation says the replica is used to backup to tape but if this fixes things then clearly something is happening at the source.
    Thursday, August 30, 2018 10:00 PM
  • Let's hope it helps!

    Regarding how the tape-based protection works in DPM:

    When you use short-term disk-based protection and long-term tape-based protection, DPM can back up data from the replica volume to tape so that there is no impact on the protected computer. When you use tape-based protection only, DPM backs up the data directly from the protected computer to tape.

    DPM protects data on tape through a combination of full and incremental backups from either the protected data source (for short-term protection on tape or for long-term protection on tape when DPM does not protect the data on disk) or from the DPM replica (for long-term protection on tape when short-term protection is on disk).


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 30, 2018 10:09 PM
  • It took a little longer I think but still running in to the same error: 
    (ID 2019 Details: An existing connection was forcibly closed by the remote host (0x80072746))
    Thursday, August 30, 2018 10:20 PM
  • Ok, then I would try removing it from the protection group and re-add it (retain data). 

    It's important to choose Retain protected data, this will retain the replica on disk with associated recovery points and tapes for the retention range.


    Blog: https://thesystemcenterblog.com LinkedIn:

    • Proposed as answer by Karl Massera Tuesday, September 4, 2018 4:40 PM
    Thursday, August 30, 2018 10:29 PM
  • So here is the update: I removed the D volume from the protection group, I was a little surprised because I was not prompted to retain the data or if I was I skipped past it. However when I re-added the volume to the protection group it was as if all the recovery points were retained and the tape backup began to work again for that volume. The other volume on the same server (which was not removed) continues to work as it always had. While I am obviously happy the system is working again I would love to get a better explanation of what happened.
    Tuesday, September 4, 2018 4:40 PM