none
after a dpmsync -sync and -reallocatereplica, all replicas are inconsistent RRS feed

  • Question

  • i had two disks go missing in my 9TB array.  after repairing the array, all replicas were present, but no recovery points.

    I had to run a dpmsync -sync followed by a dpmsync -reallocatereplica.  this resolved the missing recovery points, but now no matter what, all replicas are inconsistent. 

    I tried stopping protection of a single protected source (like on a SQL group, I stopped protection of one of the 10 DBs, then re-added)  no resolve.

    I then tried stopping an entire protection group.  after re-adding it, it did perform a successful backup.  however, the replica is still inconsistent after the scheduled jobs. 

    I wanted to try to chkdsk the volume, but I have been unsuccessful as of yet. 

    any thoughts out there?

    Thanks


    Ian

    Sunday, August 19, 2012 5:37 PM

All replies

  • Hi The_Krayze

    Is there enough free space on the system?

    If you run a consistency check does it fail at all?

    Monday, August 20, 2012 5:01 AM
  • The consistency checks that are ran manually do not complete successfully. I believe there is enough free space,, but I am not sure on how much data it needs to transfer.

    Ian

    Monday, August 20, 2012 10:57 AM
  • ok, let me add an update now since i have been back to the office.  There DPM server had about 400+ backed up jobs. the pagefile.sys was high.  (that last statemen it on revalent in the next set of sentances)

    i wanted to "shrink" the page file, so i changed it from automatic to a manual configuration.  I had to reboot.

    while rebooting (we have remote access cards in many of our server) i was watching the rac and saw that it went to chkdsk.  a handful of voumes were checked and now i am getting random successful backups (except it says it failed to back up to tape which is another issue i will tackle later)

    it seems that it is not so random.  although i did no see all the volumes that were checked by a chkdsk, a lot of them turn out to be in one that i did notice. 

    so i think if i run a chkdsk on the volume, i should be able to resolve my issues. 

    how can i run a chkdsk on the volume.  i attempted this on friday night, but all attmpts failed to read the volume.  i tried a few commands, like chkdsk [vol\?\\...] c:\prog....  etc...

    what am i missing?

    thanks


    Ian

    Monday, August 20, 2012 2:28 PM
  • Hi

    You can try using chkdsk /f but will require a restart to get exclusive access to the drive:

    http://support.microsoft.com/kb/176970

    Monday, August 20, 2012 4:14 PM
  • we did run chkdsks on a few, and it would work, but we also had about 10 volumes there were raw and we could not do anything to them

    we ended up removing all protected data and starting over.  this only affected disk based backups, we kept the tape recovery points.


    Ian

    Thursday, August 23, 2012 6:07 PM
  • u may never run chkdsk or defrag on a dpm volume!
    Friday, August 24, 2012 2:10 PM
  • in an other normal cercumstance, i would agree to never run a chkdsk.

    however, my scenario was not normal i would suspect.

    moreover, when i rebooted the server, i connected to the remote access card we have and watched it boot.  it ran a chkdsk on about 5 -6 volumes on its own.  they were dpm volumes.

    the chkdsk we performed manually was just a last ditch effort to see if we could recover without a data wipe.  in my previous statement, you will see that it did not play out that way.


    Ian

    Friday, August 24, 2012 3:25 PM
  • cancel them when windows think it should check the disk....i have seen multiple dpm volumes died when checkdisk was run on them either manually or automatic, just a tip.
    Friday, August 24, 2012 3:50 PM
  • I just want to point out that after dpmsync -sync it is NORMAL for all protected members to be insonsistent and require CC's. I realize you have other issues too.
    Tuesday, September 4, 2012 9:28 PM