Installing Bhold Core on a named instance RRS feed

  • Question

  • Gentlemen,

    i'm facing an extremely unexpected situation, i was able to install FIM Service and BHOLD Core on a database named instance. However when i try to install the BHOLD FIM Integration it seems like it's not able to connect the database, it keeps throwing this exception on the log file:

    The property 'SqlConnectionString' was found with value ''

    Could the problem by that i'm installing on a named instance not the default what? is there any special configurations should i perform?


    Monday, October 27, 2014 3:50 PM

All replies

  • Hello,

    Check values for registry keys under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\bhold\b1Core:

    SQLConnectionString, SQLServer, SQLDatabase


    Monday, October 27, 2014 4:03 PM
  • Dear Antho,

    i really think you reached the bottom of the problem. However, i'm not able to see any registry called SQLConnectionString! i can see SQLServer and SQLDatabase but no SQLConnectionString.

    It the url you provided says that it's not there by default,

    Should i add it manually?


    • Edited by Majd Andoni Monday, October 27, 2014 11:43 PM
    Monday, October 27, 2014 11:41 PM
  • Hello,

    I think you can try to add it due to the use of a named instance.

    Maybe you have to restart B1 core service to take into account the new key.

    Let me know if it's okay, if not, delete the key and restart B1 core service.


    Tuesday, October 28, 2014 9:09 AM
  • Antho,

    i'm not sure if i'm using the correct value of SQLConnectionString, what i did is create a new string registry with the name SQLConnectionString and value of Server=myServerName\SQLInstance;Database=B1;User Id=FIM-Admin1;Password=myPassword

    i restarted the server, what it was back on the bhold core didn't work and gave a database connection exception.

    Is that the correct value of SQLConnectionString?


    Tuesday, October 28, 2014 1:15 PM
  • It seems good...

    okay, try this solution :

    delete this key and restart B1 Core.

    - use this process to declare SQL Alias for your instance:

    - Change the value of the registry key "SQLServer" and set the SQL Alias.

    - Restart B1 Core.

    - Check if the service is up.

    - If it's okay, try to install FIM Integration.

    Tuesday, October 28, 2014 1:26 PM
  • i was very positive it was going to work with the idea you suggested. Unfortunately it didn't :( 

    The B1 Core worked but the FIM Integration is showing the same problem.

    Any other suggestions?


    Tuesday, October 28, 2014 4:18 PM
  • MMmm... Are you sure that you are installing FIM Integration by using BHOLD Core root account ?

    During the installation, make sure that Use Security Provider on Domain is checked.

    Did you create the folder C:\BHOLD before the installation ?

    Wednesday, October 29, 2014 11:30 AM
  • Yes Antho,

    i did all the steps in the document including all the ones you said :(


    Wednesday, October 29, 2014 3:05 PM