locked
Failed install of build 10041 in the KVM virtual machine (SYSTEM THREAD EXCEPTION NOT HANDLED)

    Question

  • When trying to install freshly downloaded Win10 build 10041 in kvm virtual machine (running on RHEL-7), I get the following screen just briefly after the beginning of the bootup.

    Failed setup screenshot

    I believe I have followed all advice on setting up the virtual machine (I have set it up to Windows 8.1 compatiblity, which set 4GB RAM, I have over 20GB space on the virtual drive). The definition of the virtual machine is http://paste.fedoraproject.org/214225/42969592/

    Any idea, what's wrong? Previous builds of Win10 worked just fine.



    • Edited by mcepl Thursday, April 23, 2015 2:37 PM
    Thursday, April 23, 2015 2:35 PM

Answers

  • I've found that with Nehalem chips you have to tell kvm to report them as core2duo or you get this error. Ran into this problem with e5430, e5540, and e5640, all worked fine after changing to core2duo.

    Also had one machine that I had to add the following to the features list for Windows to not crash constantly:

    <hyperv>
          <relaxed state='on'/>
    </hyperv>

    Things look to be going OK at this point with those changes using build 10074

    • Marked as answer by mcepl Wednesday, May 27, 2015 7:06 AM
    Saturday, May 23, 2015 7:29 PM

All replies

  • mcepl,

    For the error system thread exception not handled, we have an MSDN article talking about it:

    Bug Check 0x7E: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

    Follow the resolution part:

    If you are not equipped to debug this problem, you should use some basic troubleshooting techniques.

    • Make sure you have enough disk space.

    • If a driver is identified in the bug check message, disable the driver or check with the manufacturer for driver updates.

    • Try changing video adapters.

    • Check with your hardware vendor for any BIOS updates.

    • Disable BIOS memory options such as caching or shadowing.

    Besides, you may also contact linux side for further assistance, regarding VM settings.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 24, 2015 7:59 AM
    Moderator

  • Only build 9926 worked fine in kvm virtual machine. Latest builds get this exception.
    Friday, May 01, 2015 6:11 AM
  • Exact same issue both with 32 and 64bit iso. Every build after 9926 have suffered from it and updating within 9926 resulted in the same issue.

    Running in Qnap's Virtualization Station allocating 4gb ram, 2 or 4 cores (have tried various combinations), ca 200gb hdd space, tried with the three different graphics options (vga, vmvga and cirrus).

    No idea what's causing it but the fact that 9926 runs smoothly (until it updates) along with 8.1 and 7 suggests it is some definite change somewhere between 9926 and 10041.

    Thought 10074 might work as it's one of the more significant updates but no joy.

    I'm sure it'll be solved sooner rather than later but just letting the folks at ms know somethings up in vmland.

    keep up the good work

    Monday, May 04, 2015 2:56 AM
  • I get error when model of cpu my virtual machine is Sandy Bridge.

    Try this solution.

    Edit your virtual machine's xml-file. In <cpu> section set <model fallback='allow'>Nehalem</model>.


    It is working for me.
    • Edited by vvk2001 Friday, May 22, 2015 4:47 PM
    Friday, May 22, 2015 4:41 PM
  • I've found that with Nehalem chips you have to tell kvm to report them as core2duo or you get this error. Ran into this problem with e5430, e5540, and e5640, all worked fine after changing to core2duo.

    Also had one machine that I had to add the following to the features list for Windows to not crash constantly:

    <hyperv>
          <relaxed state='on'/>
    </hyperv>

    Things look to be going OK at this point with those changes using build 10074

    • Marked as answer by mcepl Wednesday, May 27, 2015 7:06 AM
    Saturday, May 23, 2015 7:29 PM
  • Yes, core2duo helped, hand editing to Nehalem as suggested before didn't for me.

    Thank you

    • Proposed as answer by dwightjl Tuesday, June 23, 2015 3:27 AM
    • Unproposed as answer by dwightjl Tuesday, June 23, 2015 3:28 AM
    Wednesday, May 27, 2015 7:06 AM
  • Ran into this issue again with the 10130 build.

    The 'core2duo' configuration fixes the issue. Very strange.

    Tuesday, June 23, 2015 3:30 AM