none
Cannot display the folder. The inbox folder cannot be found. RRS feed

  • Question

  • I have a customer who has Exchange 2003.  He goes onto the Exchange server, finds an existing user (user B) in AD Users/Computers, Properties, Exchange Advanced, Mailbox Rights..., and adds a new user via "Add..." and gives User A - Read/Full perms (or even Del/Read/Change/Take Ownership/Full).  Then he waits a while (even days and server reboots).

    On the client side, User A uses Outlook (various versions) but let's stick with 2010.  Goes to File / Open / Other User's Folder, selects User B and inbox. On almost all users, User A, can then open the delegate email inbox.  But on a few users he gets the error in the subject:

    Cannot display the folder.  The inbox folder cannot be found.

    And it is consistent, no matter which user (C, D, ..) is assigned to User B's mailbox, none of them can open it, but on other mailboxes on the same system/storage group, it works fine.  All permissions in the "Mailbox Rights..." are the same for all users.  In other words, it does not appear to be a setting there.

    How can we debug this?  Fix this?  VERY FRUSTRATING!

    Tuesday, September 11, 2012 4:06 PM

Answers

  • I believe I have solved it.  It had nothing to do with Cache mode, I had even tried open up the user by logging into OWA via USER A:

    http://mail1/exchange  (or http://mail1/exchange/usera/#)

    Then trying to open USER B's box via OWA:

    http://mail1/exchange/userb/#  (note: this is their email address not login username from my tests)

    In any case, I kept getting "Unauthorized" type messages from this method.  So I went back into the permissions (mail server, active dir user/comp, user properties, exchange advanced, mailbox perms) where everything looked the same as working user perms.  But when I went into the advanced mode, there were a whole slew of non-inherited settings.  I deleted by clearing every one that was not inherited EXCEPT "SELF".  Then I saved that and went back in an using the normal mode (not advanced) added a new user.  Saved, exited.

    Immediately worked.

    Tuesday, September 11, 2012 7:33 PM
  • On Tue, 11 Sep 2012 19:34:02 +0000, CBaker007 wrote:
     
    >by the way, no-one knows where those other setting came from???
     
    If they aren't inherited then your customer put them there.
     
    If you want someone to be able to open a mailbox, why not just grant
    them "Full Mailbox Access" from the "Mailbox Rights..." button on the
    "Exchange Advanced" tab of the user's property page? Then they'll be
    able to add the mailbox as a delegate mailbox from their profile's
    "Advanced" tab.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, September 11, 2012 9:50 PM

All replies

  • Try taking the user out of cached mode.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Tuesday, September 11, 2012 5:40 PM
  • I believe I have solved it.  It had nothing to do with Cache mode, I had even tried open up the user by logging into OWA via USER A:

    http://mail1/exchange  (or http://mail1/exchange/usera/#)

    Then trying to open USER B's box via OWA:

    http://mail1/exchange/userb/#  (note: this is their email address not login username from my tests)

    In any case, I kept getting "Unauthorized" type messages from this method.  So I went back into the permissions (mail server, active dir user/comp, user properties, exchange advanced, mailbox perms) where everything looked the same as working user perms.  But when I went into the advanced mode, there were a whole slew of non-inherited settings.  I deleted by clearing every one that was not inherited EXCEPT "SELF".  Then I saved that and went back in an using the normal mode (not advanced) added a new user.  Saved, exited.

    Immediately worked.

    Tuesday, September 11, 2012 7:33 PM
  • by the way, no-one knows where those other setting came from???
    Tuesday, September 11, 2012 7:34 PM
  • On Tue, 11 Sep 2012 19:34:02 +0000, CBaker007 wrote:
     
    >by the way, no-one knows where those other setting came from???
     
    If they aren't inherited then your customer put them there.
     
    If you want someone to be able to open a mailbox, why not just grant
    them "Full Mailbox Access" from the "Mailbox Rights..." button on the
    "Exchange Advanced" tab of the user's property page? Then they'll be
    able to add the mailbox as a delegate mailbox from their profile's
    "Advanced" tab.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, September 11, 2012 9:50 PM