locked
Auto run on pen drives RRS feed

  • Question

  • Hello.

    I have read that pen drive autorun has been disabled in windows 7. On my desktop PC i use Windows 7 Ultimate x64 and on my laptop i use Windows 7 Ultimate x32. When i insert my pen drive into my desktop no autorun is displayed, however when i put the same pen drive into my laptop the autorun window opens.

    I looked at the autorun settings on my desktop and laptop and they are both identical so is there a reason that it works on one and not the other?

    Thanks.
    Spikeys-World Windows Vista Home Premium
    Saturday, January 30, 2010 12:27 PM

Answers

  • The window that appears when you insert a pen drive is called Autoplay, not Autorun. They're two different (but similar) concepts. Microsoft disabled pen drive Autorun (not Autoplay) in Windows 7. This means that when you insert a pen drive into your computer, you still get an Autoplay window with some tasks (open folder, import pictures, etc.). The main difference is that, in Windows 7, all those tasks are from software installed on your computer, not from the pen drive, so it's safer to click on any of them.

    There's more information in this blog post: http://blogs.msdn.com/e7/archive/2009/04/27/improvements-to-autoplay.aspx

    If you are not displayed an Autoplay window when you insert your USB device, maybe a policy is disabling Autoplay: Open Start, type regedit, hit ENTER. Browse to this registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer and delete, if present, the NoDriveTypeAutorun value (on the right). See if you have the same value in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    and delete it as well.


    Microsoft MVP Windows Desktop Experience
    • Proposed as answer by Vivian Xing Tuesday, February 2, 2010 3:08 AM
    • Marked as answer by Joel Thornton Saturday, February 6, 2010 12:47 PM
    Saturday, January 30, 2010 3:42 PM
    Answerer