locked
How to disable call button in SfB Online, Windows Desktop Client? RRS feed

  • Question

  • Hello.  We are using Skype for Business Online, with the windows desktop client.  We do not plan on using any calling features and therefore want to disable the functionality and remove the phone button when using the peer to peer chat.  How can this be disabled using powershell for a large group of users.


    • Edited by O365Tester Wednesday, December 5, 2018 3:53 PM
    Wednesday, December 5, 2018 3:49 PM

Answers

  • Hi chrisgshelter,

    If you want to remove the phone and video button on the SFB client, you could try to set the value of AudioVideoDisabled to true. When you connect to the SFB online in PowerShell, you could run the following command to set it, you need to change the C:\test\xxx.csv in the command to the .csv file which list the users you want to disable this function:
    $users = Import-csv C:\test\xxx.csv
    Get-CsOnlineUser $users | set-csuser -AudioVideoDisabled $true

    After doing this, the result should like the screenshot below in SFB client:


    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by woshixiaobai Friday, December 7, 2018 6:59 AM
    • Marked as answer by O365Tester Monday, December 10, 2018 3:10 PM
    Thursday, December 6, 2018 6:59 AM

All replies

  • Hi chrisgshelter,

    If you want to remove the phone and video button on the SFB client, you could try to set the value of AudioVideoDisabled to true. When you connect to the SFB online in PowerShell, you could run the following command to set it, you need to change the C:\test\xxx.csv in the command to the .csv file which list the users you want to disable this function:
    $users = Import-csv C:\test\xxx.csv
    Get-CsOnlineUser $users | set-csuser -AudioVideoDisabled $true

    After doing this, the result should like the screenshot below in SFB client:


    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by woshixiaobai Friday, December 7, 2018 6:59 AM
    • Marked as answer by O365Tester Monday, December 10, 2018 3:10 PM
    Thursday, December 6, 2018 6:59 AM
  • Hi chrisgshelter,

    Is there any update for this issue? If the reply is helpful to you, please try to mark it as an answer, it will help others who have the similar issue.

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, December 10, 2018 8:27 AM