locked
Explorer view returns empty library RRS feed

  • Question

  • Hi guys,

    I have a document library with files in it. I can use it by http, but when I open it with Explorer view it doesn't contains any docs in it. It appears completely empty.

    And I don't have same problem with any other list.

     

    Any ideas?

     

    Thursday, October 6, 2011 12:50 PM

Answers

  • Hi plastikman,

    It is not recommended to exceed 2,000 items in a list level, and to use Explorer view to view large document libraries. Instead, you may choose to use All Document view, when open a SharePoint document library in Explorer view, placing the pointer over any of the enumerated files requests metadata for all of the files in the folder that you are browsing.

    As in this scenario, it may be the large number of the documents that make the Explorer View not working, here is an article about “Tune Web Server performance(Office SharePoint Server)”, there are some points we need to pay attention to in “Train end-users to work with large files”, for more information, please refer to:
    http://technet.microsoft.com/en-us/library/cc298550(office.12).aspx

    Thanks,
    Qiao

    Friday, October 14, 2011 9:46 AM
    Moderator

All replies

  • Do you have lot's of document in this folder?

    Try F5 (Refresh) and see what happens

    If you still have problem, create a new library and move your files over and open in explorer view and see the results.



    Aryan Nava | Twitter: @cloudtxt | Blog: http://virtualizesharepoint.com
    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    Disclaimer: This posting is provided "AS IS" with no warranties.


    • Edited by Aryan Nava Thursday, October 6, 2011 1:17 PM
    Thursday, October 6, 2011 1:11 PM
  • Thanks for quick reply, Aryan!

    Yes, I suppose there're lots of docs there, but I cannot get exact figure since explorer view is not working and I doesn't not how to count them otherwise

    Thursday, October 6, 2011 2:05 PM
  • Site Actions | Manage Contents and Structure |

    Navigate to your folder and view what's inside

     

     



    Aryan Nava | Twitter: @cloudtxt | Blog: http://virtualizesharepoint.com
    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    Disclaimer: This posting is provided "AS IS" with no warranties.

    Thursday, October 6, 2011 2:11 PM
  • The doc library has lots of folders and subfolders so I just connot manually count them...
    Thursday, October 6, 2011 2:33 PM
  • Hi,

    Check if these files are checked out to some other account or not.

    I have observed a case like this in our environment and found this was the issue.


    Thanks, Rahul Rashu
    Thursday, October 6, 2011 4:48 PM
  • there're like thousands of files and subfolders. All of them cannot be checked out...
    Thursday, October 6, 2011 5:21 PM
  • Hi plastikman,

    It is not recommended to exceed 2,000 items in a list level, and to use Explorer view to view large document libraries. Instead, you may choose to use All Document view, when open a SharePoint document library in Explorer view, placing the pointer over any of the enumerated files requests metadata for all of the files in the folder that you are browsing.

    As in this scenario, it may be the large number of the documents that make the Explorer View not working, here is an article about “Tune Web Server performance(Office SharePoint Server)”, there are some points we need to pay attention to in “Train end-users to work with large files”, for more information, please refer to:
    http://technet.microsoft.com/en-us/library/cc298550(office.12).aspx

    Thanks,
    Qiao

    Friday, October 14, 2011 9:46 AM
    Moderator
  • Hi,

    I have two site collections. In one the explorer view works perfect. In the other i can't use it. For every library that i try to open, i get an empty folder and if i try to copy a document in it I get You need permission to perform this action, but I am the site collection owner. Libraries only have max 10 documents. The other users also can't use explorer view in this collection but can in the other. Any idea why it works in one but not the other?  :\

    Thursday, October 27, 2011 10:24 AM
  • Hi,

    Map your document library as a network drive and then check if you can use it or not.

    This works in a similar way. Also have you gone to your document library settings --> Manage checked out files to see if these files are checked out or not.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Thursday, October 27, 2011 10:44 AM
  • Thank you for your help. Just before i wanted to try your solution i tried again to open a library in the explorer view and it worked! The only thing that i did before that was I upgraded branding solution, so apperantly iisreset helped.

     

    Sandra

    Wednesday, November 2, 2011 8:14 AM
  • Hi,

    i created some new site collections and found out that for them Explorer View returns empty folder! I added a library from one of these site collections as a network location, but it is empty. If i click on the arrow in the address bar to se the list of all content, it shows only the library that is opened. Explorer view work fine in previously created site collections.

    And i don't have checked out files and the libraries contain no more than 10 documents.

    Any idea for this behaviour? :\

    Sandra


    Sandra Ratis
    Monday, November 28, 2011 9:15 AM
  • In my scenario mapping the drive or viewing in explorer view would show an empty folder.  Opening the files 1 by 1 I determined that there was a corrupted file (a pdf) in the library.  Removing the corrupted file resolved the issue.  Explorer view and mapping the drive shows the files within the library again.


    • Edited by pagemichael Monday, November 12, 2012 2:00 PM typo
    Monday, November 12, 2012 2:00 PM
  • One of the reasons is:
    The specified item or folder name is too long.
    The URL path for ALL items and folders must be 260 characters or less
    (AND no more then 128 characters for ANY single item or folder name in the URL).
    Friday, May 26, 2017 2:22 PM