locked
USB Mouse not scrolling RRS feed

  • Question

  • This is a lengthy story, but i feel giving as much info as i can the first time around will get quick and proper replies...

     

    I use a laptop with Vista Home Premium. I bought and installed Trust USB wireless keyboard and mouse 4 months back. It was working fine for some time and then started to throw the BSOD erratically - it could be twice in a day or once a week. Googling gave me some input that TRUST has some problems and their new drivers from their website will resolve the problem. However it did not...

    More BSOD's were coming and i saw that there where 3 KMWDfilter.sys files in my laptop. 1 in c:\Windows\System32, 1 in ..\Trust\keyboa...\*.sys and 1 in ..\Trust\keyboa...\drivers\*.sys.

    Thinking probably there are clashes between these files, I first renamed the drivers in the Trust directory. It seemed to work well for sometime but then again there was this BSOD. Then I renamed the file in System32 dir. And shutdown the system.

    Later, when i started the laptop, the mouse was not working, but the keyboard was working (but the shortcut keys - internet and media keys - were not working).

    So I went back and corrected the renamed files as originally found. And then I faced a new problem...

     

    My keyboard is working fine, but my mouse now erratic... ie..it does not scroll and hold. If I scroll to the bottom of a page, it automatically scrolls to the top. If I open the volume control it automatically scrolls to the max volume.

     

    If I switch of the mouse, my laptop mouse pad works fine. But if my USB mouse is switched on, both the USB mouse and laptop mouse erratically as mentioned above.

     

    I dont know what the problem is - ist it because of any Windows updates or HP updates that was done recently.

    I am told VISTA has some problem with regard to recovering from Sleep / hibernation mode and system behaves erratically.

     

    Also, the Windows Problems & Solutions says something about usbhid.sys. Not sure whether it was driver failed to load or initialize or not recognised...

     

    I just need to know what should be done to correct this....

     

    Thanks

    Awdhil

    Tuesday, April 22, 2008 1:45 PM

Answers