locked
Shared Calendar + Private Meeting RRS feed

  • Question

  • Hey,

    We have a global Absence Calendar that people send meeting requests to (so that it exists in their own calendars too). This Absence Calendar is actually a room mailbox, so by default users cannot directly view the calendar to see what absences are there. We plan to use this for all absences; holidays, sickness, medical appointments, business, working from home etc.

    The end purpose being that if somebody rings for me and I'm not in, someone else will answer the call, check this calendar to see if I am around, see that I'm not and take a message.

    The only problem with giving Reviewer permissions, any meeting requests that are marked as private aren't actually private in the shared calendar - anyone can open them.

    How can I achieve this?

    Thanks

    Thursday, November 16, 2017 3:10 PM

Answers

  • I think I have solved this. On the room mailbox properties (Resource Information tab) there is an option to remove the private flag on accepted meetings.

    This is on by default, so I turned it off.

    • Marked as answer by Lanky Doodle Thursday, November 23, 2017 9:44 AM
    Thursday, November 23, 2017 9:44 AM
  • Thank you Lanky for the update. To make it clearer, I'd like to confirm that the appointment was not directly created in the room calendar but created via sending a meeting request to the room calendar, and the meeting request was marked as private, correct? If this is the case, I'm afraid this is the expected behavior that "the meeting item in the users calendar is still marked as private and cannot be opened" while "the meeting item in the shared calendar can be fully seen and opened, even though it was created as private". This is because you can only mark you own calendar items as private.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Steve Fan Tuesday, November 21, 2017 9:35 AM
    • Marked as answer by Lanky Doodle Tuesday, November 21, 2017 11:51 AM
    Tuesday, November 21, 2017 3:10 AM

All replies

  • Hi Lanky,

    How did you grant the Reviewer permissions? In theory, user cannot see the private items with Reviewer permission. Owner permission is required to see the private items on a shared calendar.

    Instead of giving Reviewer permissions directly, you may consider to add the users as delegates to the calendar.

    Leave the "Delegate can see my private items" option unchecked.


    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    • Edited by Steve Fan Tuesday, November 21, 2017 2:03 AM typo
    Friday, November 17, 2017 8:26 AM
  • I right-clicked the Shared Calendar > Properties > Permissions tab > Set Default to Reviewer.

    Just to confirm, the meeting item in the users calendar is still marked as private and cannot be opened. It is the meeting item in the shared calendar that can be fully seen and opened, even though it was created as private.

    Having a guess, the private flag is not honored for entries in a shared calendar? In this case, the shared calendar is a room mailbox.

    Monday, November 20, 2017 12:00 PM
  • Thank you Lanky for the update. To make it clearer, I'd like to confirm that the appointment was not directly created in the room calendar but created via sending a meeting request to the room calendar, and the meeting request was marked as private, correct? If this is the case, I'm afraid this is the expected behavior that "the meeting item in the users calendar is still marked as private and cannot be opened" while "the meeting item in the shared calendar can be fully seen and opened, even though it was created as private". This is because you can only mark you own calendar items as private.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Steve Fan Tuesday, November 21, 2017 9:35 AM
    • Marked as answer by Lanky Doodle Tuesday, November 21, 2017 11:51 AM
    Tuesday, November 21, 2017 3:10 AM
  • Yes, you have understood correctly. In my opinion that is terrible design. A private item should be private wherever it is.

    Thanks.

    Actually, I've just seen this, which suggests private items are possible:

    https://social.technet.microsoft.com/Forums/exchange/en-US/0f09aa07-3c0b-44b9-ad45-67e5353ac2f5/meeting-room-calendar-permissions?forum=exchangesvrclientslegacy

    ?

    • Edited by Lanky Doodle Tuesday, November 21, 2017 11:55 AM
    Tuesday, November 21, 2017 11:52 AM
  • I think I have solved this. On the room mailbox properties (Resource Information tab) there is an option to remove the private flag on accepted meetings.

    This is on by default, so I turned it off.

    • Marked as answer by Lanky Doodle Thursday, November 23, 2017 9:44 AM
    Thursday, November 23, 2017 9:44 AM
  • Great!! Thank you for sharing the solution here. I believe it will benefits other community members.

    Cheers,

    Steve Fan


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, November 24, 2017 2:06 AM