locked
Outlook 2013 Installed/Project 2010 Virtualized RRS feed

  • Question

  • Actually working pretty well except for some Outlook issues.

    First, at initial logon, after successfully advertising Project 2010 (globally) I now get an error message saying:

    "Either there is no default mail client or the current mail client cannot fulfill the messaging request.  Please run Microsoft Outlook and set it as the default mail client."

    Second (and really I'm sure it's the same problem) I cannot send a project file by using File->Save and Send->Send as Attachment.  When attempting this I get a dialog indicating Microsoft Project has stopped working.

    Everything is AppV-5 SP3.

    I don't suppose there is something really simple I missed?


    d

    Wednesday, March 9, 2016 3:46 PM

All replies

  • When sequencing Project 2010, did you have the outlook 2013 locally installed?

    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Wednesday, March 9, 2016 4:36 PM
  • I'm not 100% sure.  Went back to the sequencer before leaving work today and Outlook would not launch (broken link.) Think I should resequence with it installed for sure?

    d

    Wednesday, March 9, 2016 6:25 PM
  • Kindly re-sequence with Outlook installed locally and check once.

    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Thursday, March 10, 2016 4:57 AM
  • Re-sequenced, confirming that Outlook was installed.  It is.  Still getting the same error message at logon.  There is definitely a default mail profile; I just wonder if Project can't see the registry where it's defined

    Also, when doing File->Save and Send->Send as attachment, I'm getting:

    "Either there is no default mail client, or the current mail client cannot fulfill the messaging request.  Please run Microsoft Outlook and set it as the default mail client."


    d

    Friday, March 11, 2016 8:30 AM
  • I had a workaround for office 2016 C2R. This might give you some idea, though I am not sure whether it will work for 2013.

    Try giving Read permissions for "EVERYONE" and "USERS" in the below Registry Key HKEY_CLASSES_ROOT\Installer\Components\<GUID>

    This will resolve the default mailto issue for locally installed office.


    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Friday, March 11, 2016 5:36 PM
  • I tried this.....interesting.    Now I no longer get the error about the mail client, but Project just stops responding.  I've also discovered this.  When attempting to download files (regardless of file type) from our MS Project server, I'm getting EMET 5.2 caller mitigations.  I disabled EMET and got a little better description of what's happening here form HBSS/HIPS (yeah, I work in one of THOSE organizations.)  HIPS reports "Attack type: Suspicious Function Invocation - Target Address Mismatch."

    So ready to give up.

    Has anyone seen a successful App-V deployment of 2010 Project to a VM with Office 2013 natively installed on it?


    d

    Tuesday, March 15, 2016 1:11 PM
  • Hello,

    The general recommendation here would be to have Outlook 2013 installed, and a mail-profile setup on the sequencer, as a prerequisite before you start sequencing Project 2010.

    Not quite the same topic, but I wrote an article a while back that digests why a virtualized OL 2010 doesn't support all attempts to send email;

    http://www.applepie.se/virtualized-office-2010-and-extended-mapi

    Potentially you can verify if there is something that the virtualized Project can't see in the native registry, to leverage the OL 2013


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, March 19, 2016 10:24 PM