locked
SteadyState and Windows Updates RRS feed

  • Question

  •  

    Please help!!

     

    I've been looking everywhere to try to find out why my machine will not perform Windows Updates using SteadyState and Windows Disk Protection.

     

    Each time it reboots and then tries to update, it times out after 30 minutes and adds the following entry into the System Event log:

     

     "Automatic updates exceeded time limit while trying to run Microsoft updates.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

     

    (Naturally there *is* no more apparent information and I've Google'd this error and found zero results)

     

    Updating via the Microsoft site is not a problem (all critical updates now installed manually) we rely on a proxy server for internet access and I have changed the connections config within Group Policy from 'user' to 'machine'-specific (so as to ensure the proxy settings apply to ever account).

     

    This machine is part of our domain, logging in with a domain account. Manual updates have been performed while logged in as local admin.

     

    The custom updates script that I have created works fine with SteadyState (simply downloads and copies virus definition files for Sophos Anti-Virus) which takes place after the Windows Update failure.

     

    Machine responds to ping while updates are taking place (according to the warning dialogue).

     

    Any advice extremely welcome.

    Thursday, January 10, 2008 3:36 PM

Answers

  • Hi,

     

    Thanks for posting here and also Todd's suggestions.

     

    Does the system Automatic Updates work? You may need to run it at least once, then configure WDP to save changes. It will remember the Update manner. If Automatic Updates doesn't work, Schedule Software Updates in SteadyState may not work either.

     

    1. Change WDP to “Retain changes permanently” ( you can also disable WDP).

    2. Turn off Schedule Software Updates.

    3. Configure Automatic Updates from Control Panel -> Automatic Updates

    4. Please check if update can be installed properly. If yes, change WDP to “Remove all changes at restart”, configure Schedule Software Updates to test.

     

    If Automatic Updates doesn't work, we may need to fix it first. One clue is checking the WindowsUpdate.log under C:\Windows. Windows Update Newsgroup is also a good choice:

     

    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windowsupdate&lang=en&cr=US

     

    Best Regards,

     

    Friday, January 11, 2008 9:00 AM

All replies

  • Benji, do the proxy logs show any activity when you have the updates scheduled to happen?

    Are you able to move a machine so it is not behind a proxy server and then have it try updates?

    Another idea would be to put up a temp WSUS server and have a machine try and update against that machine.

     

    Todd

     

     

    Thursday, January 10, 2008 7:56 PM
  • Hi,

     

    Thanks for posting here and also Todd's suggestions.

     

    Does the system Automatic Updates work? You may need to run it at least once, then configure WDP to save changes. It will remember the Update manner. If Automatic Updates doesn't work, Schedule Software Updates in SteadyState may not work either.

     

    1. Change WDP to “Retain changes permanently” ( you can also disable WDP).

    2. Turn off Schedule Software Updates.

    3. Configure Automatic Updates from Control Panel -> Automatic Updates

    4. Please check if update can be installed properly. If yes, change WDP to “Remove all changes at restart”, configure Schedule Software Updates to test.

     

    If Automatic Updates doesn't work, we may need to fix it first. One clue is checking the WindowsUpdate.log under C:\Windows. Windows Update Newsgroup is also a good choice:

     

    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windowsupdate&lang=en&cr=US

     

    Best Regards,

     

    Friday, January 11, 2008 9:00 AM