none
Hyper-v Replica RRS feed

  • Question

  • Hello,
    I have a problem with the configuration of replication using Manager Hyper-v. an error occurs when using replication.

    (https://gardaochrona-my.sharepoint.com/:i:/g/personal/techniczny_gardaochrona_onmicrosoft_com/ERr5iM7K90lLlHkqvKm5FK4BBdKVNDiQusEFm82iGrUEcg?e=1z73LQ

    where to look for a problem and what can I check. I use Hyper-v server 2016

    certificates are issued with the help of makecert and are theoretically correct (according to instructions)

    Please help

    Wednesday, May 15, 2019 6:21 AM

Answers

  • Sorry, I forgot you have core. 

    Run regedit on hyper-v host and go to HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\. Check for Domain and NV Domain key. Both should be set to your domain name garda.local. 

    If the keys are missing, right click and create String Value.


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    • Marked as answer by Techniczny Thursday, May 16, 2019 3:43 PM
    Thursday, May 16, 2019 3:06 PM
  • Specify the full name of your hyperv host when enabling replication hyper2.garda.local 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    • Marked as answer by Techniczny Friday, May 17, 2019 6:36 AM
    Thursday, May 16, 2019 3:29 PM
  • I'm glad it helped. Please mark as answered. 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    • Marked as answer by Techniczny Thursday, May 16, 2019 3:42 PM
    Thursday, May 16, 2019 3:39 PM

All replies

  • Hi  ,

    >>The certificate's CN name does not match the passed value. (0x800B010F).

    According to the error message, it implies that the CN name was not configured correctly .

    Please refer to the following article regarding step-by-step guide for certificate based replica:

    How to implement Hyper-V replica in Workgroup environment

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Wednesday, May 15, 2019 7:27 AM
  • Thank you for your response.

    I used this article, but I encountered a problem. on the server side I do not have the "ETC" folder and the "hosts" file. However, servers can see themselves by name using the router and DNS. I understand that assigning names by the router is synonymous with editing the server "HOSTS" file.
    I am using HYPER-V SERVER 2016 and there is no GUI, I added certificates using the command:
    certutil -addstore -f Root "PrimaryReplikaRootCA.cer"
    certutil -addstore -f Root "SecondaryReplikaRootCA.cer"


    Is the computer on which the HYPER-V MANAGER (windows10 pro) must have some certificates added. HYPER-V MANAGER on windows 10 view and both servery by name and I have full control over virtualnymi systems.


    Which CN name exactly goes. How should it look?

    Wednesday, May 15, 2019 11:58 AM
  • Hi ,

    This is a quick note to let you know that I am currently performing research on this issue and will get back to you as soon as possible. I appreciate your patience.
    If you have any updates during this process, please feel free to let me know.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Thursday, May 16, 2019 8:31 AM
  • Can you copy paste makecert command that you've used to create your certificates? As far as I can see you didn't add HYPERV2 hostname to the certificate subject common name (CN). 

    Example, for Hyper-V Host named HYPERV2: 

    #RootCA
    makecert -pe -n "CN=PrimaryRootCA" -ss root -sr LocalMachine -sky signature -r
    #CA
    makecert -pe -n "CN=HYPERV2" -ss my -sr LocalMachine -sky exchange -eku 1.3.6.1.5.5.7.3.1,1.3.6.1.5.5.7.3.2 -in "PrimaryRootCA" -is root -ir LocalMachine -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12
    Modify the CN values and run the same command on your secondary host. Make sure to copy both Root CA to Trusted Root Authority on both hosts. 


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, May 16, 2019 10:58 AM
  • Thank you for your answer and I count on your help.

    After analyzing the various descriptions, I still have not found a solution.

    Best Regards,

    Arek

    Thursday, May 16, 2019 11:11 AM
  • such commands have been entered for both servers:

    makecert -pe -n “CN=PrimaryReplikaRootCA” -ss root -sr LocalMachine -sky signature -r “PrimaryReplikaRootCA.cer”


    makecert -pe -n “CN=HYPER3.garda.local” -ss my -sr LocalMachine -sky exchange -eku 1.3.6.1.5.5.7.3.1,1.3.6.1.5.5.7.3.2 -in “PrimaryReplikaRootCA” -is root -ir LocalMachine -sp “Microsoft RSA SChannel Cryptographic Provider” -sy 12 Hyper3Cert.cer


    makecert -pe -n “CN=SecondaryReplikaRootCA” -ss root -sr LocalMachine -sky signature -r “SecondaryReplikaRootCA.cer”


    makecert -pe -n “CN=HYPER2.garda.local” -ss my -sr LocalMachine -sky exchange -eku 1.3.6.1.5.5.7.3.1,1.3.6.1.5.5.7.3.2 -in “SecondaryReplikaRootCA” -is root -ir LocalMachine -sp “Microsoft RSA SChannel Cryptographic Provider” -sy 12 Hyper2Cert.cer


    certutil -addstore -f Root “PrimaryReplikaRootCA.cer”
    certutil -addstore -f Root “SecondaryReplikaRootCA.cer”





    Thursday, May 16, 2019 11:16 AM
  • As I create a certificate with the name "CN = HYPER2", the hyper-v manager does not see this certificate. In addition, the "name.domain.local" is clearly written in the guides.

    Thursday, May 16, 2019 11:23 AM
  • Did you enter the hostname (hyper2) or fqdn (hyper2.garda.local) of your Hyper-V host on the enable Replica Server wizard?

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, May 16, 2019 12:01 PM
  • can you give me a command how to check or where to check if the name is correct. I do not have GUI on servers (HYPER-V SERVER 2016). To create certificates, I made the commands as in the previous post. Replication I want to start using a computer with Windows 10 pro, MANAGER HYPER-V. I am sending a link to the photo.

    (https://gardaochrona-my.sharepoint.com/:i:/g/personal/techniczny_gardaochrona_onmicrosoft_com/EZ50iKIlVvdBqk5XBMT9cOIB9ThwhFS10bnOtv6OA5PQXw?e=hSleF0

    Thursday, May 16, 2019 12:29 PM
  • Replication I want to start using a computer with Windows 10 pro, MANAGER HYPER-V. I am sending a link to the photo.

    When you try to enable replication for a VM, you need to enter the name of the Replica Server. 

    Did you enter HYPER2 or HYPER2.garda.local?


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered"Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]


    Thursday, May 16, 2019 12:51 PM
  • Also I've noticed that you have HTTP enabled, you should disable HTTP when using HTTPS with certificates. 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, May 16, 2019 12:53 PM
  • The replication is to be made from a server called HYPER3 on a server named HYPER2. to start replication with HYPER3 I must first set up HYPER2 to be a replica server. At this point, I have a choice:
    "Use the KERBEROS (HTTP) protocol"
    or
    "Use certificate-based authentication (HTTPS)"
    as I try to add a certificate, I have a mistake like in the picture from an earlier post.


    If I choose "use KERBEROS protocol" then I can go to the part you described and enter the name "HYPER2" there and go on but I can not finish the task.


    I am sending a link to all photos.

    )https://gardaochrona-my.sharepoint.com/:f:/g/personal/techniczny_gardaochrona_onmicrosoft_com/EgtHBIQAbFFKhRGp-tSuTTsBshpoToaY0wxFZ0BNo0Wf5A?e=GdCopo

    Best Regards

    Arek

    Thursday, May 16, 2019 1:25 PM
  • Lets start at the beginning. Are you Hyper-V Hosts added to an AD Domain or Workgroup? 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, May 16, 2019 2:20 PM
  • Workgroup

    Thursday, May 16, 2019 2:27 PM
  • Ok then you cannot use HTTP Kerberors, because it requires Active Directory. This means you need to deselect HTTP option. 

    Did you set the primary DNS suffix on your Hyper-V Hosts to garda.local ? 


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, May 16, 2019 2:41 PM
  • I'm sorry I can not put in photos so I'm screaming at one drive. picture number 6, the same link
    Thursday, May 16, 2019 2:48 PM
  • take a look at picture No. 7 whether it is about options in red or green. how to set it without a GUI as far as it can be a problem.
    • Edited by Techniczny Thursday, May 16, 2019 2:58 PM
    Thursday, May 16, 2019 2:55 PM
  • Sorry, I forgot you have core. 

    Run regedit on hyper-v host and go to HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\. Check for Domain and NV Domain key. Both should be set to your domain name garda.local. 

    If the keys are missing, right click and create String Value.


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    • Marked as answer by Techniczny Thursday, May 16, 2019 3:43 PM
    Thursday, May 16, 2019 3:06 PM
  • OK, I'm one step further. I am going to the MANAGER HYPER-V replication enable point I am selecting the "hyper3" certificate and at the end I have the error photo number 8
    Thursday, May 16, 2019 3:25 PM
  • Specify the full name of your hyperv host when enabling replication hyper2.garda.local 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    • Marked as answer by Techniczny Friday, May 17, 2019 6:36 AM
    Thursday, May 16, 2019 3:29 PM
  • YES works. Thank you very much for your help. great respect for your knowledge.

    Thursday, May 16, 2019 3:37 PM
  • I'm glad it helped. Please mark as answered. 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    • Marked as answer by Techniczny Thursday, May 16, 2019 3:42 PM
    Thursday, May 16, 2019 3:39 PM
  • Is switching from a backup machine a big problem or just turn off replication and start the system
    Thursday, May 16, 2019 3:41 PM
  • Don't think if I understand your question? 

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, May 16, 2019 3:45 PM
  • I am sorry I have to go because I will be waiting for you tomorrow. If I wrote something wrong, write, correct it

    Best Regards

    Arek

    Thursday, May 16, 2019 3:46 PM
  • Hi ,

    >>Is switching from a backup machine a big problem or just turn off replication and start the system

    I am a bit confused about your question. Could you please clarify more details?

    What did you mean about switching from a backup machine? Did you mean that switch to the target secondary replica server?

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Friday, May 17, 2019 2:24 AM
  • Sorry for my English. Yes, disable the main server and run the second server
    Friday, May 17, 2019 6:05 AM
  • Hi ,

    Did you mean that you want to know how VM works when you disable the main server?

    Hyper-V Replica is designed to help both planned (scheduled events) and unplanned (disaster recovery) failover situations.

    When the primary site experiences a problem(for example, power outage or server failure)and the Replica virtual machines are brought online at the Replica site.

    For more details, you could refer to the following link:

    Set up Hyper-V Replica

    If you want to start replicating from the secondary site to the primary, and fail back to the primary site. You could click on Reverse Replicate.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   


    Friday, May 17, 2019 6:29 AM
  • Thank you very much for your response and thank you again for helping me solve the problem. I hope that I have marked "Vote as helpful" well.

    Best Regards

    Arek

    Friday, May 17, 2019 6:37 AM