locked
Windows 2012 R2 + Hyper-V 3.0 + CentOS 6.5 - network issues RRS feed

  • Question

  • Hello,

    I am experiencing strange problems with CentOS 6.5 on Windows Server 2012 R2 + Hyper-V. 

    Two CentOS 6.5 virtual machines that are located on same host have extremely high ping between each other (sometimes up to 200ms). I have tried to migrate both machines to another 2012 R2 host and nothing changed.

    However, it seems that problem exists only when VLAN identification is set.

    4 Broadcom NetXtreme Gigabit adapters are teamed in LACP mode.

    Same thing works OK on previous version of Windows Server 2012 / Hyper-V.

    Has anyone experienced similar problem?

    Thanks,

    Petar

    Wednesday, January 15, 2014 8:52 AM

All replies

  • Hi Petar, I can have this investigated. Could you also check if this is the same case for other distributions? How about RHEL 6.4 or SLES 11 SP3? Please give me some time to get back to you.

    Thanks,

    Abhishek

    Thursday, January 16, 2014 7:02 AM
  • Hello,

    I have the same problem with network. And this problem exists with centos 6.4 and 6.5. As far as I've discovered, it is all about Linux integration components drivers for hyper-v, integrated in Linux kernel. Version of kernel hyper-v drivers is 3.1.

    To test this moment I've made virtual machine on CentOs 6.3 (with no integrated drivers in kernel) and after installation LIS v3.5 all work fine, long pings have gone.

    And main problem for me is to update kernel hyper-v drivers to latest version. How can I do it?

    Thanks,

    Alexander.

    Friday, January 17, 2014 5:53 AM
  • Hello Alexander & Abhishek,

    Thank you for your response.

    I have tried to install LIC 3.5 on CentOS 6.5 however it didn't work - I still have identical problem. Documentation says LIC 3.5 is for CentOS 6.0 - 6.3 so this may be the problem.

    Here is output: http://pastebin.com/yC6wsr8B

    @Alexander, did you try only on Server 2012 R2 or also on 2012 ? Issue seems to be only with R2 - at least we couldn't reproduce on 2012.

    I will try CentOS 6.3 + LIC 3.5 and let you know if it works for me too.

    Kind regards,

    Petar

     

    Friday, January 17, 2014 1:18 PM
  • Hello,

    same was with CentOS 6.3 + LIC3.5.

    However, looks like we found a problem, and it was WMQ that must be disabled on all adapters and Team.

    http://www.altaro.com/hyper-v/troubleshooting-the-hyper-v-virtual-switch-part-1/

    Both CentOS 6.3 + LIC 3.5 and CentOS 6.5 work fine now.

    We will test few more days so I will let you know if there are some other issues.

    Thanks for your help.

    Petar

    Friday, January 17, 2014 3:45 PM
  • Petar, I  can test only on Server 2012 R2.

    In my case CentOS 6.3 + LIC 3.5 work fine with  WMQ enabled on all 4 adapters in team.

    Monday, January 20, 2014 7:39 AM