locked
Sequence of SQL 2008 Management Tools RRS feed

  • Question

  • I have been trying to sequence the SQL 2008 Management suite of tools.  The basic sequencing has worked for the management console, profiler, etc. The one component that I'm having an issue with is the SQL Server Business Intelligence Development Studio. 

    If I try to launch that application on a client I receive an error message:  "Invalid license data. Reinstall is required" and then the application shuts down.  I happen to have Visual Studio 2008 loaded on my local machine and I have no issues running the virtual application.

    I have tried searching on this error as it relates to Visual Studio and the only solution I seem to see are to re-load Visual Studio which isn't exactly what you can do virtually.

    Anyone else conquered this issue?

    Thursday, April 1, 2010 2:27 PM

Answers

All replies

  • Thursday, April 1, 2010 7:24 PM
  • Thanks for the reply.  Yes, I've seen that article.  I tried to apply the hotfix in the article, but the message came back and stated that none of the products were installed impacted by this hotfix.  The Business Intelligence Development Studio is just a part of the SQL install.  I'm sure it is related to this article, I'm just not sure how to incorporate it in a solution.
    Thursday, April 1, 2010 8:29 PM
  • Hello,

    Since the hotfix says it doesn't apply, it probably doesn't apply....

    Now, that article contains loads of steps - and _one_ of the hotfixes downloaded should be applied - however there are many more steps than that specific step that should be valid.

    Try looking into the rest of the steps...

    /Znack

    • Edited by znack Thursday, April 1, 2010 8:39 PM clarification
    Thursday, April 1, 2010 8:37 PM
  • Has anyone been able to get BIDS 2008 R2 working in App-V 4.5?

    I have also been trying to incorporate the entire VS2008 fix into SS 2008 R2 Management Tools in order to fix the "Invalid License Data" errors, but it just isn't working.

    Steps taken:

    1. Installed pre-reqs outside of sequencing
    2. Remove exclusions on Local App Data / Personal
    3. Begin sequence
    4. Install SS 2008 R2 Management Tools (tried installing to either VFS or MNT) using Enterprise media + key.
    5. Installed VS2008 SP1
    6. Extracted MavVak2008.dll to "Microsoft Visual Studio 9.0" directory and regsvr32'd it
    7. Stopped sequencing
    8. Launch Management Studio & BIDS into FB1 [optional]
    9. Saved

    Running BIDS through App-V will launch with the Invalid License Data prompt.

    I remember sequencing SS 2005 Management Tools with BIDS worked fine with the VS2005 fixes, clearly the same isn't applying to 2008.

    Anyone actually managed to get this working?

    Wednesday, October 13, 2010 3:15 PM
  • Hello,

    Have you tried using SS 2008 Management Tools?

    /Znack
    Wednesday, October 13, 2010 9:26 PM
  • Sorry, not sure what you mean... I am using SS 2008 Management Tools... Or do you mean using non R2 media (think we can still get 2008 SP1 via MVLS)?

    /update

    Now tried with non R2 enterprise media. Exactly the same result.

    1. Clean VM
    2. Install pre-requisites to VM
    3. Sequence SSMS 2008 (Client Management Tools & BIDS)
    4. Apply SS SP1
    5. Apply VS 2008 Service Pack 1
    6. Register MavVak2008.dll
    7. Stop sequencing

    Still no luck :/

     

    Thursday, October 14, 2010 8:08 AM
  • Is Management Studio 2008 Express Tools enough for you need? I recently sequenced SQL 2005 Express tools without any problems with licensing data..

    /Kalle

    Friday, October 15, 2010 7:19 AM
    Moderator
  • The client seems to think not, but I will attempt it nonetheless; hopefully if BIDS is the same (but working), I can provide just that component from the express package alongside the working Management Tools from full.
    Friday, October 15, 2010 7:30 AM
  • Nope, I can confirm that 2008 Express doesn't have the BIDS components/IDE.

    I've also tried sequencing VS2008, then SS2008 BIDS on top, applying the various fixes, but even with a stringent set of excludes, I hit the 4Gb barrier preventing launch.

    Monday, October 18, 2010 2:05 PM
  • I'm also now trying to go back and sequence the SQL 2008 R2 Management Tools currently with no success.  If anyone has a recipe for this would sure like to try it.  My first attempt has failed miserably.  I have no idea where I went wrong in the sequence.  I am trying to sequence on a clean VM (Windows 7 Enterprise).  I didn't come across any pre-requisites to load.

     

    Thursday, October 21, 2010 1:28 AM
  • Unfortunately I can only confirm the full SS 2008 Management Tools (+R2, excluding Visual Studio/BIDS) sequence successfully on XP SP3 with App-V 4.5 (SP1).

    Following the post Nicke made on his blog was enough to get the main tools working. (http://www.viridisit.se/eng/blog/?p=690).

    The only additional point I can make is that you need plenty of RAM available to and in your VM in order to avoid the installation hanging.

     

     

    • Proposed as answer by znack Tuesday, November 30, 2010 10:58 PM
    Thursday, November 18, 2010 10:08 AM