none
Windows Server 2012 R2 wouldn't response SMB Negotiate Protocol Request RRS feed

  • Question

  • Hello

    I've got an windows 2012 r2 as a file server,  it worked fine with windows client but not with lunix-based client

    I first discovered this problem on an Android phone:http://social.technet.microsoft.com/Forums/en-US/b3a8a7f9-f4b7-4b9f-b586-2ec87fc14d71/cant-access-shared-folders-on-win-2012-r2-with-android-phone?forum=winserverPN

    then I did some test on a newly installed lunix OS on a VM today, I found that my server do not response SMB Negotiate Protocol Request from my phone or the testing OS at all.

    when I try smbclient -L ServerIP, I get

    read_socket_with_timeout: timeout read. read error = Connection reset by peer.
    Receiving SMB: Server stopped responding
    protocol negotiation failed

    the wireshark capture are like this:

    35 22.704658 192.168.1.20 192.168.1.10 SMB 260 Negotiate Protocol Request
    36 22.704745 192.168.1.10 192.168.1.20 TCP 54 microsoft-ds → 41733 [RST, ACK] Seq=1 Ack=195 Win=0 Len=0
    37 23.090116 192.168.1.20 192.168.1.10 TCP 74 41734 → microsoft-ds [SYN] Seq=0 Win=5840 Len=0 MSS=1460 SACK_PERM=1 TSval=8758786 TSecr=0 WS=16
    38 23.090237 192.168.1.10 192.168.1.20 TCP 74 microsoft-ds → 41734 [SYN, ACK] Seq=0 Ack=1 Win=8192 Len=0 MSS=1460 WS=256 SACK_PERM=1 TSval=5473099 TSecr=8758786
    39 23.090382 192.168.1.20 192.168.1.10 TCP 66 41734 → microsoft-ds [ACK] Seq=1 Ack=1 Win=5840 Len=0 TSval=8758787 TSecr=5473099

    I don'tknow what's causing this problem ,is there anyone could help me?

    Saturday, March 15, 2014 11:40 AM

Answers

All replies

  • Hi,

    If you access files stored on Windows Server 2012 R2 from other non-Windows client computers, you need to use NFS protocol.

    Using the NFS protocol, you can transfer files between computers running Windows and other non-Windows operating systems, such as Linux or UNIX.

    In Windows Server 2012, NFS includes the components, Server for NFS and Client for NFS. Server for NFS enables a computer running Windows Server 2012 to act as a NFS file server for other non-Windows client computers. Client for NFS enables a Windows-based computer that is running Windows Server 2012 to access files that are stored on a non-Windows NFS server.

    For more detailed information, please refer to the articles below:

    Network File System Overview
    http://technet.microsoft.com/en-us/library/jj592688.aspx

    Server for Network File System First Share End-to-End
    http://blogs.technet.com/b/filecab/archive/2012/10/08/server-for-network-file-system-first-share-end-to-end.aspx

    Regards,

    Mandy

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.


    Monday, March 17, 2014 8:59 AM
    Moderator
  • Hi,

    thanks for reply.

    I’m aware of the NFS sharing function on Windows 2012, but it‘s not an option to me as long as it does not support UTF-8 or other unicode charasets( I have lots of non-English name files to share).

    Besides, my android devices does not support NFS sharing , so any other solutions?

    Monday, March 17, 2014 12:46 PM
  • Hi,

    UTF-8 is supported in Win2012, it is built into NFS 4.1 protocol. NFS v2 and v3 support only ASCII strings.
    You need to enable NFSv4.1 on client systems. If client systems does not support NFS v4, you may use 3rd party NFS servers.

    For more detailed information, please refer to the thread below:

    How to configure UTF8 encoding for NFS server
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/6115901c-d14a-4c2c-b663-a2e27193cd7a/how-to-configure-utf8-encoding-for-nfs-server

    Regards,

    Mandy

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, March 19, 2014 6:06 AM
    Moderator
  • Unfortunately, my lunix client does not support nfsv4, maybe I’ll try a 3rd party solution

    Thanks anyway

    Wednesday, March 19, 2014 7:40 AM
  • Hello,

    Did you find any solution for this problem. I have the same one. On two out of three Domain Controllers, we can#t join the Domain with Linux Clients with teh same wireshark Trace.

    Thanks

    Dominik

    Thursday, January 22, 2015 2:04 PM
  • This is a Microsoft bug!
    • Proposed as answer by andrew.deans Monday, May 22, 2017 7:52 PM
    • Unproposed as answer by andrew.deans Monday, May 22, 2017 7:52 PM
    Sunday, June 7, 2015 1:20 AM
  • More likely than not, the Windows Server 2012 system that you were trying to connect to does not have the optional feature for SMB 1.0 support (FS-SMB1) install and your Samba client is not advertising that is supports a SMB 2.x dialect in its SMB 1.0 Negotitate Protocol Request.  When this occurs, the Windows Server 2012 system will reset the connection between it and the client, just as we see in the packet summaries that you provided in your initial post.  To confirm this, you can run the following PowerShell command on the Windows Server 2012 system:

    Get-WindowsFeature -Name FS-SMB1

    Under the "Install State" column, this will likely show as "Available" for a system where the issue is occurring and "Installed" for a system where it does not occur.  To enable the feature, you can run the following PowerShell command:

    Add-WindowsFeature -Name FS-SMB1

    After this, you will need to restart the Windows Server 2012 system for it to complete the necessary changes.

    If the feature is installed but you are still experiencing issues, you can run the following PowerShell command to determine if SMB 1.0 is actually enabled in the server configuration on the Windows Server 2012 system:

    Get-SmbServerConfiguration | Select EnableSMB1Protocol

    If this is set to "False", this issue can also occur since the client and server will not be able to negotiate to a mutually supported SMB version.  To enable it, you can run the following PowerShell command:

    Set-SmbServerConfiguration -EnableSMB1Protocol $True
    As long as the feature is already installed, you should not have to restart after running this command.
    • Edited by Reign1 Friday, July 24, 2015 12:13 PM
    Tuesday, July 21, 2015 8:16 PM
  • Hi,

    Do we have any solution on the issue. We have 6 domain controller with Windows 2012 R2, Linux servers are configured with with arcsight smart connectors, the smart connectors will archive logs from domain controllers over SMB protocol. We domain controller are sending logs to the smart connectors and few are failing with SMB negotiation packet reset 

    Thanks

    A

    Friday, December 4, 2015 5:53 AM
  • I had a pretty much verbatim problem. Turned out someone had completely uninstalled SMB1. It can be reinstalled by running this in PowerShell:

    Add-WindowsFeature FS-SMB1

    After reboot, make sure SMB1 is enabled by running:

    Get-SmbServerConfiguration | Select EnableSMB1Protocol

    If not, run:

    Set-SmbServerConfiguration -EnableSMB1Protocol $true


    Wednesday, June 22, 2016 9:22 PM