none
Azure AD (synchronized identity) and Exchange Online - migrating account/mailbox RRS feed

  • Question

  • Hi everyone,

    We are using Azure Active Directory (synchronized identity) with Office 365 integration and Exchange online. Everything is synching properly from two local AD domains to the Azure AD. We have two sites (locations) with two different local AD domains. Both domains are trusted to each other. These two domains are syncing to the same Azure AD. I am in the process of decommissioning the one site's domain and adding those users (only 6) to the main domain. I already have an RODC onsite and it tests fine. My next step is to migrate the users from the old domain to the main domain and have them retain their Exchange online mailboxes and Azure AD account.

    So far I have not been able to do this. Using the AD migration tool I was able to migrate a "test" user from the old domain to the main domain. I migrated the SID as well. All of the required fields for the user to be synchronized were correctly filled in, email address, UPN, and ProxyAddresses and this user was placed in the correct OU. As soon as I remove the account from the old domain it gets deleted in Azure AD along with its mailbox. The account in the main domain doesn't "takeover" as I had hoped it would.

    Does anyone have any ideas on how I can migrate an account from one local AD to another that's synching to the same Azure AD and retain its Exchange online mailbox and Azure AD account?

    Thanks,

    Vossa

    Tuesday, September 13, 2016 5:01 PM

All replies

  • HI, 

    have you checked this link and follwed the process

    https://azure.microsoft.com/en-gb/documentation/articles/active-directory-aadconnect/

    http://www.codetwo.com/admins-blog/sync-premises-ad-office-365/

    Regards

    Azhar 

    Please mark as answer if this help


    Thanks and Regards Azhar Amir

    • Proposed as answer by Azhar_Amir Tuesday, September 27, 2016 12:43 PM
    Tuesday, September 27, 2016 12:27 PM
  • Hi Vossa,

    What you need to do, is stop the AAD synchronizing the OU of the domain that you are moving the accounts from and this should resolve the issue.

    Thank you.

    JA


    Tuesday, September 27, 2016 12:33 PM