unable to protect a SharePoint instance that is located in a DMZ RRS feed

  • Question

  • I’m unable to protect a SharePoint instance that is located in a DMZ.

    I have 3 servers that are located in a DMZ.

    1.       Domain Controller

    2.       SQl 2008 R2

    3.       Sharepoint 2010

    All 3 machines are joined to the same domain that is hosted by the DC (server 1) in the dmz.

    On the other side of the firewall there is the DMP 2010 ser ver.

    On the firewall the following ports are opened from the agents to the dpm server

    TCP                        5000-5100
    TCP                        135
    TCP                        5718-5719
    TCP/UDP             88
    TCP/UDP             389
    TCP                        139
    TCP                        445
    UDP                       53
    UDP                      137-138

    On the 3 server in DMZ I manually installed the DPM agent and attached them to the DPM server. Status of the 3 clients in the DPM console is “OK”.

    For DC server I can select  “All Shares”, “All Volumes” and “System Protection”
    For the SQL server I can select the same + All SQL databases
    For the SharePoint server I can also select Shares, volumes and system
    , but the SharePoint instance does not show up at all!

    On the SharePoint server I ran ConfigureSharepoint.exe –EnableSharepointProtection and ConfigureSharepoint.exe -EnableSPSearchProtection (multiple times) but without the expected result. I’m not able to select the SharePoint instance when editing my protection group.

    The SharePoint instance that runs inside the corporate network is protected by DPM already, so I don’t think the DPM server is the issue.

    As a test I opened all ports on the Firewall but result is still the same.

    What I’m I missing here?

    Tuesday, April 5, 2011 1:22 PM