locked
RemoteApp behaviour after connecting/disconnecting a external monitor/sreen RRS feed

  • Question

  • If i start a remoteapp on my 11" laptop and then connect a external monitor of 22" to my laptop and use the 22" as my primairily screen, the RemoteApps correctly sizes with the new screen. But after i disconnect the external monitor, i can't drag the remoteapps over the right side of my 11" laptop screen. I have to logoff my session and start a new session to get the normal behaviour. Can someone tell me more about this behaviour?

    Im using Win08R2Sp1 and Win7Sp1, rdp 7.1.

    Thursday, August 16, 2012 11:10 AM

Answers

  • Hi,

    Thanks for your post.

    Please check the following requirement for RemoteApp supported with multi-monitor.

    ◦Equal resolution monitors

    ◦Total resolution of all monitors not exceeding 4096 x 2048

    ◦Top-left monitor being the primary

    Any other kinds of multi-monitor configurations are not supported with TS RemoteApp. Here are a few examples of multi-monitor setups that are unsupported:

    ◦L-shaped multi-monitor configuration

    ◦Unequal number of monitors on the top and bottom row (if there is a two row multi-monitor setup)

    ◦Center or right monitor being the primary

    For more detailed information, please refer to the following blog. Hope it helps.

    Using Terminal Services RemoteApp™ programs on multi-monitor client computers

    http://blogs.msdn.com/b/rds/archive/2007/05/07/using-terminal-services-remoteapp-programs-on-multi-monitor-client-computers.aspx?PageIndex=3

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    • Proposed as answer by Aiden_Cao Thursday, August 23, 2012 1:30 AM
    • Marked as answer by Aiden_Cao Tuesday, August 28, 2012 4:48 AM
    Tuesday, August 21, 2012 1:57 AM

All replies

  • Hi,

    Thanks for your post.

    Please check the following requirement for RemoteApp supported with multi-monitor.

    ◦Equal resolution monitors

    ◦Total resolution of all monitors not exceeding 4096 x 2048

    ◦Top-left monitor being the primary

    Any other kinds of multi-monitor configurations are not supported with TS RemoteApp. Here are a few examples of multi-monitor setups that are unsupported:

    ◦L-shaped multi-monitor configuration

    ◦Unequal number of monitors on the top and bottom row (if there is a two row multi-monitor setup)

    ◦Center or right monitor being the primary

    For more detailed information, please refer to the following blog. Hope it helps.

    Using Terminal Services RemoteApp™ programs on multi-monitor client computers

    http://blogs.msdn.com/b/rds/archive/2007/05/07/using-terminal-services-remoteapp-programs-on-multi-monitor-client-computers.aspx?PageIndex=3

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    • Proposed as answer by Aiden_Cao Thursday, August 23, 2012 1:30 AM
    • Marked as answer by Aiden_Cao Tuesday, August 28, 2012 4:48 AM
    Tuesday, August 21, 2012 1:57 AM
  • The problem is not a multi-monitor setup, but changing between resolutions due to switching to different monitors.

    So i have 1 laptopscreen thats 11", 1366x786 resolution. I connect a 22" monitor AND close my laptop screen. So in my display config i have a setup with 1 monitor with a 1920x1080 resolution. Afterwards i disconnect the 22" screen and open up my laptopscreen so im once again at 11" resolution.

    So in every change i end up with just 1 monitor in my display config settings.

    Wednesday, October 24, 2012 10:17 PM
  • This seems to be fixed in the rdp8 client;
    http://blogs.msdn.com/b/rds/archive/2012/10/23/rdp-8-0-update-for-windows-7-sp1-released-to-web.aspx

    please note that i installed the hotfix http://support.microsoft.com/kb/2574819 prior to installing http://support.microsoft.com/kb/2574819 as mentioned in the blog.

    Update1: It seems this hasn't been fixed, i will post some funny examples soon.

    Update2: examples here: http://www.360ict.nl/blog/remoteapps-do-not-scale-correctly-after-attaching-a-monitor/

    Monday, November 12, 2012 8:21 AM