locked
Windows Auto update problem Error 8007000D RRS feed

  • Question

  • I've been having problems running windows update,  either Automagically or manually I get an error code 8007000D.  I'm suspect that vista is deciding since I have a wSUS server in the environment that it should be using that for updates.  my machine and user accounts are in OUs that have no gp and no policy inheritance,  any thoughts on how to make it work??
    Wednesday, June 21, 2006 7:09 AM

Answers

  • Have you configured your WSUS server to get Vista updates from the Microsoft Update Beta site?

    If not just copy the following line in to a command prompt and run it.

    cscript.exe "%programfiles%\update services\tools\ToggleMUUrl.vbs" beta

    Note that your WSUS server must be using WSUS SP1 for this script to work.

     

     

    Monday, June 26, 2006 5:39 AM
  • After some investigation,  I discovered that recreating the computer account inside my specifically inheritance blocked OUs stopped the problem for me.  I can happily update using windows update now :)

     

    Thanks for the replies.

    Tuesday, July 4, 2006 5:41 AM
  • Do not perform the script to update WSUS in your production WSUS. It will point WSUS to the Beta update location and basically remove your production environment. Microsoft recommends running the script on a test server specifically for updating beta software. You cannot perform production WSUS and beta WSUS on the same server. At least this is my understanding of the document listed with WSUS SP1 web site. To return the WSUS back to the normal production update location, you have to remove and reinstall WSUS. Not good.

    The best option is to:
    1. Create an OU in Active Directory that is outside the scope of the WSUS Group Policy Object.
    2. Move the computer with Vista into this OU.
    3. At the computer, run GPUPDATE.
    4. This will remove the WSUS from this computer.
    5. Vista will now look automatically to the Microsoft Beta update site and download updates.
    Monday, August 14, 2006 5:33 PM

All replies

  • Have you configured your WSUS server to get Vista updates from the Microsoft Update Beta site?

    If not just copy the following line in to a command prompt and run it.

    cscript.exe "%programfiles%\update services\tools\ToggleMUUrl.vbs" beta

    Note that your WSUS server must be using WSUS SP1 for this script to work.

     

     

    Monday, June 26, 2006 5:39 AM
  • I have the same issue but cannot tweak our WSUS.  Is there any way to bypass it?
    Friday, June 30, 2006 2:09 PM
  • Hi Guys,

    I spent some time researching the problem today

    in order to understand the solution here is alittle explenation about the problem:

    Windows Update doesnt work on VISTA Beta 2 machiens after joining to a domin.

    the thing is that if you have WUS or SUS in your environment the group policy by the domain send the stations the WUS or SUS server for updates and fixes it, thats why when I pulled it out from the domain it worked fine

    so the thing is that you need to make a REG key that look like this : (past this to notepad and save it as .reg)

    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\LocalUser\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate\DisableWindowsUpdateAccess]  

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoUpdate"=dword:00000000
    "AUOptions"=dword:00000000

    [-HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDevMgrUpdate"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "NoUpdateCheck"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
    "DisableWindowsUpdateAccess"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

     

    after saving it , double-click should active it , Restart to Windows Update Service and its done

    now this key will get back your Vista station to work with local policy, witch connect to the internet for updates.

    no messing around with Organizational WUS or SUS ..

    Have a Good Week,

    Ido Goldberg

    Senior Windows System Administator,

    Symantec Corp.

    • Proposed as answer by Exotic Hadron Saturday, September 24, 2011 12:00 PM
    Sunday, July 2, 2006 2:39 PM
  • After some investigation,  I discovered that recreating the computer account inside my specifically inheritance blocked OUs stopped the problem for me.  I can happily update using windows update now :)

     

    Thanks for the replies.

    Tuesday, July 4, 2006 5:41 AM
  • I tried what you offered but still get error 800700D and can't install the update.
    Friday, July 21, 2006 8:56 PM
  • Yes I tried this too but am unable to do updates still.
    Friday, July 21, 2006 10:12 PM
  • The registry fixes worked for me, thank you.
    Tuesday, August 1, 2006 6:46 PM
  • Do not perform the script to update WSUS in your production WSUS. It will point WSUS to the Beta update location and basically remove your production environment. Microsoft recommends running the script on a test server specifically for updating beta software. You cannot perform production WSUS and beta WSUS on the same server. At least this is my understanding of the document listed with WSUS SP1 web site. To return the WSUS back to the normal production update location, you have to remove and reinstall WSUS. Not good.

    The best option is to:
    1. Create an OU in Active Directory that is outside the scope of the WSUS Group Policy Object.
    2. Move the computer with Vista into this OU.
    3. At the computer, run GPUPDATE.
    4. This will remove the WSUS from this computer.
    5. Vista will now look automatically to the Microsoft Beta update site and download updates.
    Monday, August 14, 2006 5:33 PM
  • Hello!

    Your solution worked for me  

    I just runned the .reg on my vista computer and restarted it. After that it was able to go to the WindowsUpdate site without the error appearing again.

    Thanks!

    Thursday, November 23, 2006 9:46 AM
  • glad to be at serive

    have a marry christmass and a happy new year .

    Thursday, November 23, 2006 12:30 PM
  • Worked like a charm, created new OU for vista machines.

    Isn't there a beta 3 for WSUS?

    Need to check that out.  Great thread on this problem.

    Erik

    Thursday, November 30, 2006 3:27 PM
  • Will the registry settings suggested by Ido work on the production version of Vista?  I've noticed some registry changes between beta and live on Vista, so I don't want to run this unless I'm sure.

     

    Thanks

    Friday, January 5, 2007 10:08 PM
  • It's so frustrating when you just don't have time to mess with something like this and even the built in Microsoft help

    doesn't pinpoint the source of the error.

    This worked like a charm and saved me a lot of digging,  Thank you!

    Tuesday, March 6, 2007 4:44 PM
  • Hi Lectrik,

    I'm Glad I could help

    Some questions needs to be addressed,

    A different OU and other game playing with AD location of the VISTA machines

    Will work for you all, but it depends on how you configured the WSUS GPO.

    I came across some people that it wont work for them because they applied the GPO on the SITE level and then and OU solution wont work unless it been told to block GPO’s.

     

    Another issue is that MS Vista is now OUT ! and there is an update to WSUS making him recognize Vista machines therefore no need to go “out” to the internet in order to get the right updates.

     

    Best regards

    Ido Goldberg

     

    Wednesday, March 7, 2007 10:32 AM
  • worked for me...Thanks!
    Wednesday, March 7, 2007 4:37 PM
  • worked for me...Thanks!

     Ido Goldberg wrote:

    Hi Guys,

    I spent some time researching the problem today

    in order to understand the solution here is alittle explenation about the problem:

    Windows Update doesnt work on VISTA Beta 2 machiens after joining to a domin.

    the thing is that if you have WUS or SUS in your environment the group policy by the domain send the stations the WUS or SUS server for updates and fixes it, thats why when I pulled it out from the domain it worked fine

    so the thing is that you need to make a REG key that look like this : (past this to notepad and save it as .reg)

    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\LocalUser\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate\DisableWindowsUpdateAccess]  

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoUpdate"=dword:00000000
    "AUOptions"=dword:00000000

    [-HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDevMgrUpdate"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "NoUpdateCheck"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
    "DisableWindowsUpdateAccess"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

     

    after saving it , double-click should active it , Restart to Windows Update Service and its done

    now this key will get back your Vista station to work with local policy, witch connect to the internet for updates.

    no messing around with Organizational WUS or SUS ..

    Have a Good Week,

    Ido Goldberg

    Senior Windows System Administator,

    Symantec Corp.

    Wednesday, March 7, 2007 4:42 PM
  • worked for me...Thanks!

     Ido Goldberg wrote:

    Hi Guys,

    I spent some time researching the problem today

    in order to understand the solution here is alittle explenation about the problem:

    Windows Update doesnt work on VISTA Beta 2 machiens after joining to a domin.

    the thing is that if you have WUS or SUS in your environment the group policy by the domain send the stations the WUS or SUS server for updates and fixes it, thats why when I pulled it out from the domain it worked fine

    so the thing is that you need to make a REG key that look like this : (past this to notepad and save it as .reg)

    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\LocalUser\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate\DisableWindowsUpdateAccess]  

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoUpdate"=dword:00000000
    "AUOptions"=dword:00000000

    [-HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDevMgrUpdate"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "NoUpdateCheck"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
    "DisableWindowsUpdateAccess"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoWindowsUpdate"=dword:00000000

     

    after saving it , double-click should active it , Restart to Windows Update Service and its done

    now this key will get back your Vista station to work with local policy, witch connect to the internet for updates.

    no messing around with Organizational WUS or SUS ..

    Have a Good Week,

    Ido Goldberg

    Senior Windows System Administator,

    Symantec Corp.

    Wednesday, March 7, 2007 4:42 PM
  • worked also for me...Thanks!
    Wednesday, April 4, 2007 12:32 PM
  • Thanks Ido, that solved my problem on the Vista Ultimate machine I was dealing with.

     

    Ideally, I'd like to figure out why my SUS installation stopped servicing the Vista client -- the XP Clients continued to work fine.  I saw an earlier post in this thread, but didn't want to try it since it was quite old and Vista is no longer in Beta.  If anyone out there knows what to do with SUS to get it to service Vista clients correctly, that info would be appreciated.

    Tuesday, April 17, 2007 6:10 PM
  • "[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\LocalUser\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate\DisableWindowsUpdateAccess]  "

     

    This key does not exist in my Vista Ultimate Registry (using regedt32) therefore the reg file will not import .....

     

     

    Monday, April 23, 2007 1:18 PM
  •  

     

    It works for me. Thanks a lot Ido Goldberg.

     

    Giriraj

    Chennai

    Thursday, April 26, 2007 9:09 AM
  • Hi

     

    I Found another way.

     

    In your WSUSAdmin console under computers, remove the selected computer, do not make it unassigned.

    Restart your Vista pc.

    After login, run the update client manualy.

    In the WSUSAdmin console under computers, check for unassigned computers and add the computer account back to the   

    computer group it was assigned.

    From Vista, run the update client again and install the updates.

     

    This works in a domain envirument.

    Friday, May 18, 2007 2:52 PM
  • Hi,

     

    I saw this old post-hope you can still help.

     

    I am running Vista business (non beta) and get the error code 80007000D when trying to get updates. My environment is a corporate one with a Windows update server.  I tried your reg update, but when I tried to update from the Windows update site,   I now get asked to run the update as an administrator.  I am a domain administrator already.  What do I do now?  Can you help.  Thank you.

    Saturday, May 19, 2007 7:30 AM
  • Worked great for me thanks for your efforts!!!
    Friday, May 25, 2007 10:11 AM
  • I am still running WSUS 2.0.  I had flagged Vista updates to be included and downloaded by WSUS but my Vista Business machine was getting this 8007000D error.

     

    I found that the problem was that I had not installed WSUS 2.0 Service Pack 1.  As soon as the update was applied on my WSUS server, the error disappeared on my client machine and updates were able to be installed.

     

    Jon

    Tuesday, May 29, 2007 3:29 PM
  •  

    Ok I found that the reg edit does work while several say it doesn't maybe this might help them, to stop the windows update service go to control panel, Administrative Tools, double click on services, scroll down to windows update, stop the service, enter the reg edit, and then restart the service. I also tried stopping the service, I went to windows software distribution, data deleted everything in the folder, went back to the software distribution folder and deleted the temporary downloads (you find them under downloads) delete everything in the folder restart the service.

    Monday, September 17, 2007 3:04 AM
  • This link is no good.  Doesn't work.  Still stuck with that stupid error 8007000D

     

    Wednesday, February 13, 2008 4:21 AM
  • Hi Mate

     

    I have tried your registry fix but I still cant seem to be able to install updates.

     

    From my update history it looks like I have been able to get some windows defender updates but nothing else.

     

    Do you have any further ideas on what my machine may be up to?

     

    Many Thanks

     

    Tony

     

     

     

    Tuesday, July 8, 2008 9:57 AM
  • i've tried doing this but im still getting the same error.<code 8007000d> for update <kb955020>

    any other ideas on what i could do.

    Monday, August 25, 2008 8:26 PM
  • ... errr, is there a way of doing this without being a computer geek, something along the lines of  "click this link" or type this into the "run" option? Thanks

     

    Friday, October 24, 2008 11:12 PM
  • i have the same problem the auto or manual update is not working which i dont know really why ?!! i hope i can find a solution within this forum support place thanks
    Friday, November 14, 2008 10:13 AM
  • I am using W XP SP3 with the same problem.
    What should I do?

    Desperated, have not been able to updates since oct, 2008.

    Please help.

    Thanks a lot.

    Cquevedo@bellsouth.net
    Thursday, January 15, 2009 3:59 AM
  • I am having the same problem but I have NO idea what any of you are talking about in your responses.  Please explain in non cyberese.  Thank you.
    Sunday, October 18, 2009 2:06 AM
  • This worked perfect! Thanks!

    David
    Thursday, November 5, 2009 8:38 PM
  • Error 8007000D or "The data is invalid" will generally mean two things.  The first being that the file type you are trying to play is not supported in Windows Media Player.  The link following link describes what formats are and are not supported in WMP.  Windows Media Player Multimedia File Formats

    The other reason you might run into this error is that the file you are trying to play is corrupt.  In the case of a corrupt file you would want to try and re-obtain the file and see if it plays correctly.

    Thursday, June 17, 2010 10:46 AM
  • I experience the same on Windows Developer Preview.

    Ido's fix allowed to change Windows Update settings (nice!), which are defined by a domain GPO, but I still get the 0x800F0906 error when trying to add Windows features that require connecting to Windows Update site. I suspect that Windows Still attempts to connect to regular WU site rather that beta Update.

    Any clue?

    Thank you.


    Well this is the world we live in And these are the hands we're given...
    Friday, September 23, 2011 11:11 AM
  • Installing Ido Goldberg's registry patch, then installing Windows Live Essentials with Windows Messenger and attempting to retrieve updates to install Microsoft .NET Framework 3.5.1 feature resolved the problem. I was able to add .NET to my Windows Developer Preview workstation, which had WSUS policy applied to it and had been causing the 0x800F0906   error code when connecting to Windows Update.
    Well this is the world we live in And these are the hands we're given...
    • Proposed as answer by Exotic Hadron Saturday, September 24, 2011 11:59 AM
    Saturday, September 24, 2011 11:59 AM
  • I have copied and saved this file; however, can you please tell me in a step by step process how to go about doing this.  I have copied and pasted the information in notepad and saved it as fix.reg.  When I click on it, it is asking me if I really trust changing my registry.  I want to make sure I am not going to mess up something else that is unrepairable.   I do not understand what you are talking about when you reference SUS or WSUS or OU I'm not sure about configuring an outside server as I have an outside internet provider. Thank you for your assistance.
    Sunday, July 29, 2012 9:56 PM
  • Has this issue been resolved for you and if so, what was the fix that you used?  Thank you
    Sunday, July 29, 2012 10:00 PM