locked
Client migrations after migrated from SCCM 2012 R2 SP1 to SCCM 1511. (Won't update site code) RRS feed

  • Question

  • Hello!

    Instead of upgrading our SCCM R2 SP1 environment to SCCM 1511 that was running on Windows Server 2008 R2 with SQL 2012 we decided to start from scratch and install 1511 on Windows Server 2012 R2 with SQL 2014. The new site is connected to the old one and we have migrated everyting we need except the clients.

    When I try to make a client push installation from the new site that has system discovery activated the specific client get the new version but the site code won't change. The client is still pointing to the old site. It seems to work if remove the client manually and the following regkeys on the client:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCMSetup

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS

    Even if this works it doesn't feels like a good solutions to do on over 500 clients.

    I have disabled publising to the current domain on the old site and the DNS service value is removed. I have also removed all the boundary groups on the old server just to make sure it should assign clients.

    I have also tried to run the following script on a client without success:

    https://stevethompsonmvp.wordpress.com/2014/03/29/script-to-change-assigned-site-code/

    Client push is using only one property which is:

    SMSSITECODE=C01

    Any help and tips is very much appreciated.

    Thanks in advance.

    // Stylaren
    Wednesday, April 6, 2016 8:14 AM