none
project professional 2010: Physical % Complete field does not roll-up to the summary tasks RRS feed

  • Question

  • Hi,

    I have a project plan which I need to set the physical % complete fields of it in order to use it for earned value over time report. I have assigned costed resources to come of the tasks, set all project task's earned value method to physical % complete, and finally set a baseline. However, the physical % complete still does not get calculated for the summary tasks! It is always zero! 

    I have created another project with only 3 tasks and 3 resources, did the same as above, and was able to get calculated values for the physical % complete.

    I followed the same procedure in both projects. In one I was able to get the physical % complete value of the summary tasks while it was always zero in the other! What may be the problem? 

    Regards,
    George 

    Friday, May 13, 2011 5:52 AM

Answers

  • Hello George,

    Add the Earned Value Method field to the task view and ensure all subtasks are also set the Physical % Complete.  If you start entering physical % complete on subtasks before setting their earned value method to Physical % complete --the values will not roll up.  Likely in the second instance, you set the earned value method before adding tasks -- and the subtasks method was set correctly from the start.

    I hope this helps.

    Julie

    Friday, May 13, 2011 11:35 AM
    Moderator
  • Hi Julie,

    This is what I am seeing as necessary to make Physical % complete roll up to the summary level task.

    1. BEFORE tasks are entered, set the "Default Task Earned Value method" to Physical % complete. File > Options, Advanced.  This will set both the summary and detail tasks to that method.
    2. Add tasks
    3. Add resources with costs.
    4. Assign resources to tasks.
    5. Baseline the file

    Take a look at the Tracking table and enter progress in the Physical % complete field for subtasks. The value should roll up.

    Sadly I don't know of anyway to force the change after the tasks have been added.  You can certainly add the Earned Value Method field to a task view to confirm all is set - but I have never been able to switch mid-flight and get it to work correctly.

    I did, however, just try an experiment.  I created a file that did not work correctly - Physical % complete was not rolling up.  I inserted it into a blank project that had the option set correctly without linking.  After a bit of tweaking (outdenting all tasks to be able to delete the "extra summary task", saving a baseline), it now appears to be working correctly.

    I hope this helps.

    Thursday, March 5, 2015 3:34 PM
    Moderator

All replies

  • Hi George,

    When you add physical % Complete also add resource actual work hours then only the EV Calculations begins, as if you check in resource usage even if your physical % could be 20% your resource doesn't shows any actual work and the moment you enter work EV fields begin to calculate.

    Apart from that somehow the calculation of the Summary Tasks in EV is not Roll up but the individual calcuation based on the summary task values.

    Refer : http://support.microsoft.com/kb/75051

    http://social.technet.microsoft.com/Forums/en-US/projectprofessional2010general/thread/83afc973-6581-49bc-aae8-65618861c510/#164536fc-db61-4c2e-9416-5f44efdb6ea1

     http://social.technet.microsoft.com/Forums/en-US/projectprofessional2010general/thread/e60beac0-c2c7-4fd4-b81e-0be2ec308d38

     


    Sapna S
    Friday, May 13, 2011 6:11 AM
    Moderator
  • Hello George,

    Add the Earned Value Method field to the task view and ensure all subtasks are also set the Physical % Complete.  If you start entering physical % complete on subtasks before setting their earned value method to Physical % complete --the values will not roll up.  Likely in the second instance, you set the earned value method before adding tasks -- and the subtasks method was set correctly from the start.

    I hope this helps.

    Julie

    Friday, May 13, 2011 11:35 AM
    Moderator
  • Hello Julie,

    We were having the same problem on a 2-week old project, so we changed the Earned Value Method field to reflect "Physical % Complete".  The problem is that we couldn't change it for the Summary Bars, and the PPC values aren't rolling up to the Summary Bars.  

    Is there a way to fix it so the Summary Bars are rolling up the PPC values on this in-progress project?

    Julie

    Thursday, March 5, 2015 2:22 PM
  • Hi Julie,

    This is what I am seeing as necessary to make Physical % complete roll up to the summary level task.

    1. BEFORE tasks are entered, set the "Default Task Earned Value method" to Physical % complete. File > Options, Advanced.  This will set both the summary and detail tasks to that method.
    2. Add tasks
    3. Add resources with costs.
    4. Assign resources to tasks.
    5. Baseline the file

    Take a look at the Tracking table and enter progress in the Physical % complete field for subtasks. The value should roll up.

    Sadly I don't know of anyway to force the change after the tasks have been added.  You can certainly add the Earned Value Method field to a task view to confirm all is set - but I have never been able to switch mid-flight and get it to work correctly.

    I did, however, just try an experiment.  I created a file that did not work correctly - Physical % complete was not rolling up.  I inserted it into a blank project that had the option set correctly without linking.  After a bit of tweaking (outdenting all tasks to be able to delete the "extra summary task", saving a baseline), it now appears to be working correctly.

    I hope this helps.

    Thursday, March 5, 2015 3:34 PM
    Moderator
  • Hello Julie,

    Thank you for your prompt response!  We will try this on new projects.  Thanks again!

    Julie

    Thursday, March 5, 2015 4:00 PM
  • You're welcome, Julie.  Let us know how you get along.
    Thursday, March 5, 2015 4:17 PM
    Moderator
  • This did it for me.  There were 3 rows which were not set to "Physical % Complete" as the EVM.  No idea why they were different from the rest, but after changing it, the Phys % Complete immediate rolled up to the project summary task.
    Tuesday, October 10, 2017 8:05 PM