locked
No sound after Vista/Windows 7 wakes up RRS feed

  • Question

  • I put my Vista/Windows 7 laptop to sleep or hibernate when I'm not using it to save power BUT when I resume using it, I no longer have sound. There's a red X on the sound volume icon in the system tray. I have to restart the computer, which sort of does away with the whole reason for sleep/hibernate (to restart faster). Can you help?

    This is actually a known problem and Microsoft released an update to fix it, but that update didn't always work - so now there is an updated update! We hope they got it right this time. You can find the link to download it here:
    http://www.vistanews.com/H5T992/090409-Audio-Device-Error

    I have tried all three of the KB updates in the above link to no avail. They will not work with Win 7. Is there a fix available or in the works for Windows 7. My next to last build of Windows 7 Beta was a clean install.

    Thanks!
    Thursday, April 9, 2009 1:47 PM

Answers

  • It's likely tyhat you need better drivers for the chipset or sound device. The next released version of the beta may help with installing Vista drivers when 7 drivers are not yet available. If you have checked the makers site lately for new drivers, you should probably just wait for the next beta.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Thursday, April 9, 2009 1:54 PM
  • OK Gents (Ladies) - HP has fixed the problem with the sound driver (restart from sleep). The problem was the audio driver which was not compatible with win7. Looked on the HP site and sure enough  they published about 10 or so new WIN7 64 drivers. And yes they all work. My machine is responsive and functional. Now if Microsoft could just fix the Loooooooonnnnnnnnnnnggggggggg running Welcome screen (after login) we'd be good as gold.

    Thanks HP --- too bad it took so long.

    Cheers 
    Tuesday, October 20, 2009 12:49 PM

All replies

  • It's likely tyhat you need better drivers for the chipset or sound device. The next released version of the beta may help with installing Vista drivers when 7 drivers are not yet available. If you have checked the makers site lately for new drivers, you should probably just wait for the next beta.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Thursday, April 9, 2009 1:54 PM
  • This is a work-around that works for me.

    After you wake the computer go to Control Panel
    Click Hardware and Sound
    Click Manage Audio Devices  (under Sound)
    Click on your Speakers
    Click Properties
    Go to the Advanced tab
    Click Test

    You have to do this each time it wakes with no sound :(

    To try to prevent it from doing that in the first place you should uncheck the two boxes under "Exclusive mode" on that same window.

    I've noticed that it seems to only happen if you leave some audio or AV app open when you hibernate.  If you close your MP3 app you can usually avoid it, but video apps can do it too.

    Derek
    Saturday, September 5, 2009 3:09 PM
  • Derek,

    Thanks for the tip.

    However, still no go.

    I have noticed when I restart in order to get my sound back, there are horizontal streaks across the shutdown screen. These are not present during a normal restart, only when restarting in order to get the sound functioning again. I have Realtek embedded sound and just updated to the most recent W 7 drivers. I am running Windows 7 RTM.

    IIRC, I have been having this problem since Windows Vista.

    Best,

    JC

    Monday, September 7, 2009 3:49 AM
  • JC,

    I am having the same exact problem, except that I am using Windows 7 x64 RTM on my laptop. Are you using x64 versions of Vista and 7 RTM? I had Vista Home Premium x86 and never had this problem. It first happened to me when I installed Windows 7 x64 Beta. I then deleted the x64 version of 7 and installed x86 version of Windows 7 Beta and never had the problem. I also encountered the white streaks upon resume WITH no sound. It seems the drivers/hardware are not re-initialized, therefore the drivers show up as not installed and the devices simply 'don't exist.' The only solution I have found thus far is: Install x86 version of Vista/Windows 7, use a non-Realtek sound card, or Restart to re-enable sound/fix graphics.

    It may be a problem with drivers, but its been a lonnnnnngggg time since this problem was documented. Seems to happen to people with Realtek onboard sounds (a good % of laptop users) I hope Microsoft is on this or else it could spell disaster for those that are switching from XP to 7, especially with manufacturers pushing for 4gb as the standard amound of ram on a laptop more people will flock to the x64 of 7 to seel full utilization.

    I'm using x64 and have this problem, I just simply restart. Its a big hassle but I'm hoping for the best. Right now I'm happier w/ 7 vs. Vista (except this VERY annoying problem)

    Cheers,

    Marv

    P.S. On my desktop, Windows 7 RTM runs perfect, no hiccups. Desktop uses a VIA onboard sound, no whitelines on resume or hibernation wakeup.
    • Proposed as answer by marvvv Monday, September 21, 2009 2:22 PM
    Monday, September 21, 2009 1:58 PM
  • Marv,

    Thanks much for your response.

    Just glad to know that I am not alone in this issue. Mine started also with W7Beta x64.

    I am just going to stick with the 64-bit version and deal with it until they get it fixed, which I'm sure they will eventually.

    The only real issue for me is that I can't sleep my laptop, so when I close the lid now, I just have it turn off.

    Appreciate the response...let me know if you hear anything further...

    Best,

    JC
    Monday, September 21, 2009 2:19 PM
  • Don't think so - tried your link - it tells me that the fix is not compatible with my machine running win 7 rtm. I am running amd x2 x64 4gb pavilion dv3 with win7x64. Everything is great once you reboot... not terribly useful... as I tend to use the sleep and hibernate a lot. I have an SSD drive --- which should make the boot faster , however Win7 RTM is very slow to start after you login... LONG RUNNING WELCOME. Actually I believe XP is actually faster to start.
    Thursday, October 1, 2009 11:09 AM
  • Thanks - nice try but it did not work running win7rtm x64 4gb dv3-1124ca pavilion laptop. Believe it or not I cannot get a proper spec on the chipset in the machine??? win 7 shows HIGH DEFINITION AUDIO DRIVER??? no type ... checked the device parms as well like manufacturer ID etc pretty useless information. 
    Thursday, October 1, 2009 11:12 AM
  • I'm also having this problem.  I'm currently running Windows 7 x64 RTM (I was running Vista x64 and also had this problem).  I have a Dell Studio XPS; the sound is built-in on the motherboard; it's listing in Windows as "Realtek High Definition Audio"; the driver version is 6.0.1.5735, dated 11/11/2008.

    I've noticed this only happens when the machine is put to sleep with a application open that was using the sound card, such as Windows Media Player or Firefox with a page open that had embedded media in it (Flash, Silverlight, etc.).  The sound would come back if shut down all the apps that were using the sound card before the machine went to sleep.  Really annoying.

    Today, I found this thread and tried the "speaker test" trick described above.  I didn't work, but I found that if I disabled the speakers (this is in the Sound control panel applet) and then re-enabled them, the sound would come back!

    This seems like a driver issue, and I may hit the Dell website later to see if I can find newer drivers...
    Sunday, October 18, 2009 12:20 PM
  • i have exactly the same problem with Window 7 on my Gateway P-171XL FX laptop. My driver also shows up as HIGH DEFINITION AUDIO DRIVER but when looked up in properties it says Realtek. I tried few different drivers but none of them work so now I have to used disable/enable trick to get my sound back after wakeup

    Is Microsoft aware of that issue ???
    Monday, October 19, 2009 1:27 PM
  • OK Gents (Ladies) - HP has fixed the problem with the sound driver (restart from sleep). The problem was the audio driver which was not compatible with win7. Looked on the HP site and sure enough  they published about 10 or so new WIN7 64 drivers. And yes they all work. My machine is responsive and functional. Now if Microsoft could just fix the Loooooooonnnnnnnnnnnggggggggg running Welcome screen (after login) we'd be good as gold.

    Thanks HP --- too bad it took so long.

    Cheers 
    Tuesday, October 20, 2009 12:49 PM
  • On my HP DV5000, I fixed my problem.  I went to the Windows Mobility Center (just type Mobility into the Start Menu search bar).  Once there I turned off the mute on the sound icon and voila!.  Give it a try.
    Friday, February 25, 2011 2:18 PM
  • You're the man, Derek.
    Saturday, November 2, 2013 4:16 PM
  • Hey.  So while I don't know how to fix your issue, I do know how to save you a bit of time.  Instead of RESTARTING, just LOG OFF and LOG BACK ON.  ;)  Works every time.  

    —Zz

    Saturday, November 2, 2013 4:21 PM