none
Configuring Dell BIOS settings in System Center with a .cctk file from Dell Command Configure RRS feed

  • Question

  • I am brand new to SCCM and my organization is currently trying to configure BIOS settings for our new incoming machines with the help of Dell Command Configure Wizard. I have followed the guides I found online, but most of them include how to update the BIOS instead of setting it, so it is getting a little confusing to me on what I actually need to have in my task sequence. Here is what I have so far... (Only need this to work for 64 bit OS)

    I have created a multi-platform .cctk file in the Dell Command Configure Wizard and put it in a file to be used in a package. In the file is also a HAPI install.cmd and a cctk.exe along with other files suggested by some guides I read. 

    In SCCM - I have created a package using the folder above and set it to not create a program. I then went to my current deployment task sequence and created a new group called "Apply BIOS Config" with the following run commands in it all linked to the package I created. 

    HAPI\HAPIInstall.bat
    cctk -tpm=on
    cctk.exe -i "Dell_BIOS_Settings\multiplatform_201709271651.cctk" -| C:\Temp\CCTK.log

    The first two seem to work fine but it always errors out on the last one. Am I executing the wrong commands or missing something?

    Thank you,

    Thursday, September 28, 2017 11:57 PM

All replies

  • Hi, 

    Here is an example on how to do just that. https://4sysops.com/archives/dell-bios-update-with-sccm-and-dell-command-configure/  

    that example uses a bit different command for the folder where to find the .cctk file and that is probably your issue as well.

    Regards,
    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec


    Friday, September 29, 2017 5:45 AM
    Moderator
  • Hi,

        Could you please share us the complete smsts.log and execmgr.log for further troubleshooting this issue? You can upload the logs on Onedrive. 

    Regards,

    Jimmy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 29, 2017 11:00 AM
    Moderator
  • Hi Shorton17,

    I just happened to be working on a similar goal and found that you probably made the same mistake as me.

    As Jörgen Nilsson's link, there are screenshots and no codes to copy.

    The correct code should be

    HAPI\HAPIInstall.bat
    cctk --tpm=on    (here should be "--" not "-")
    cctk.exe -i "Dell_BIOS_Settings\multiplatform_201709271651.cctk" -l C:\Temp\CCTK.log    (here should be "-l" [may be mean log]not "-|")

    Best regards,

    Yuxiang



    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Yuxiang Shi Wednesday, November 20, 2019 9:14 PM
    Wednesday, November 20, 2019 9:14 PM