Problem with PXE(UEFI) over WAN RRS feed

  • Question

  • Hi,

    Were having problem with PXE and UEFI-clients over WAN. When the client start talking with the WDS-server, a timeout seems to occur and after some seconds it throws the error 0x000000f?

    Clients with legacy-BIOS works just fine.

    Any Idea?

    Best regards
    Magnus Karlsson

    Tuesday, January 8, 2019 10:41 AM

All replies

  • Any Idea?

    Don't PXE over the WAN would be my first. :-)

    BI For SCCM | Register for a Free Demo

    Tuesday, January 8, 2019 7:07 PM
  • +1 for John

    Why not using a Windows 10 Client System as a PXE Responder in the Branch Location starting with CB1806, if you cannot place a server system there?

    Tuesday, January 8, 2019 8:02 PM
  • Hi MGKea,

    0x000000f:The system cannot find the drive specified.

    Is your client a VM or a physical machine?
    If it is a physical machine, has your WinPE imported the correct NIC driver?
    Has the hard disk been reformatted to GPT for UEFI boot?
    Is the uefi task sequence configured correctly?

    Best regards,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact

    Wednesday, January 9, 2019 5:37 AM
  • Hi,

    Are you using IP Helpers or DHCP Scope options for your clients to reach the PXE server? You should transition to IP Helpers if you don't already us it. Check DHCP scope settings if anything is wrong there.


    -- My Enterprise Mobility blog -- Twitter @ccmexec

    Wednesday, January 9, 2019 4:10 PM
  • Hi Jörgen,
    We only use IP Helpers.
    Wireshark tells us that there is a problem to read boot-files over WAN. Some DHCP options are missing... 
    Think our problem is similar to the problem described in this post:
    In our case the deplay part in the SP is missing.

    Best regards


    Thursday, January 10, 2019 11:52 PM
  • Hi,

    your issue is may related to the MTU size over your WAN link. You may have also have additional encryption in place? Try for example to ping thru your WAN to the "other side" with -f (dont fragment) and -l to find out your MTU. Then set the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\DP\RamDiskTFTPBlockSize and HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSTFTP to that value or slighty below. We had this issue some time ago, since this values slowing down the WINPE download a lot we finally put a PXE in place. As already recommended here, place a PXE on site if possible.

    • Edited by --Marc-- Monday, January 14, 2019 10:06 PM bad english
    Monday, January 14, 2019 10:04 PM