none
The established connections/locks on SQL server of my application are lost during the SQL backup process RRS feed

  • Question

  • Hi All,

    My application is losing its connection/locks obtained on a database during the backup process.

    This is the scenario.

    I run an application where it always connects to SQL server, by establishing Locks on my application's database. At Some point of time, the connections/Locks obtained on my application's database are lost. This results in bringing down the application.

    This happens always during a Database backup process. This is a Complete SQL backup.

    But we run this backup daily and the application is not failing daily.

    I found the below error messages repeatedly in the SQL error Logs.

    server  Error: 17883, Severity: 1, State: 0
    server  Process 55:1 (12fc) UMS Context 0x13275BF8 appears to be non-yielding on Scheduler 0. 

    May i know reasons for this error message.

    I would also like to know whether there are any other Logs that can i can look into (or) is there any way to start more debug logs to get detailed information ?

     

    Thursday, October 26, 2006 3:23 PM

All replies

  • Hi All,

               Could any one help me out ?

    To add to the Problem Description above.

    We are also doing vigourous activity [ running some queries that runs on a 15 gb database ] at the same time of the backup process.

    Where both [ backup and our activity ] takes approx 20 mins.

    Any suggestions are immensly appreciated.

    Thanks,

    Gaurav

    Monday, November 6, 2006 8:02 AM