locked
SAP load balancing connection string

    Question

  • Hello all,

     

    trying to connect a ERPMA to the SAP server using a load balancing connection string, (like /M/SAPHOST.localnetwork.net/S/3660/G/RFCLOGON), following error pops up:

     

    Application error occurred.

    An error occurred while connecting to ERP server.
    Max. length for ID/Value exceeded '\è[]...'

     

    The displayed [] is a special character, like square O, rather than 2 square brackets...

     

    Connecting the server works fine using the conventional direct connection string.

    Eg; ASHOST=SAPHOST SYSNR=60 CLIENT=510

     

    The error message is kind of cryptic, not really useful to troubleshoot...

     

    Any help appreciated!

     

    Regards,

    Peter

    Thursday, September 27, 2007 8:16 AM

Answers

  • With assist of MS PSS (Thanks, José!), we found the solution to the problem.

    Finally it comes down to spaces/tabs in the services file.

     

     

    If you look into the help of the ERP Management Agent Configuration Tool, look for 'load balancing'.

    Strangely enough, "Known Issues" is shown, but never mind.

     

    It says, I quote, "

    ... 

    For reference, the below sample shows a connection string which specifies the 'SAPADM' logon group:

    /M/mySap.sap-ag.de/S/4253/G/SAPADM

     

    '/M/' (message server host name

    '/S/' (message server port)

    '/G/' (logon group)"

     

    But it does not tell you that there is another option to use a loadbalancing string, very much alike the normal (direct) SAP connection string example that is displayed by the tool (ASHOST=host SYSNR=## CLIENT=###).

    But you need to use a syntax that is a bit different, like:

    MSHOST=MSGSVR_ALIAS R3NAME=APPSVR_NAME GROUP="logongroup" CLIENT=XXX SYSNR=XX

    In which

    MSHOST = Central Instance of SAP system.

    R3Name = System Name

    Group = Logon Group defined in the SAP system for your application.

     

    To use logon groups, you need to make sure that your connecting to the messaging server, rather than to the application server host.

    (Generally the message server has a name ending with "00" as system number...)

     

    Before you can use that loadbalancing string, you need to add the required entries in the services file. (meaning %WINDIR%\System32\Drivers\etc\services file)

     

     

    But initially this didn’t work neither.

     

    The ERPMA Configuration tool could not connect to the message server.

    And MIIS threw an error, at import:

    "Stack trace is:

    ...

    ERROR service 'sapmsD30' unknown

    ..."

     

    The system/service sapmsD30 could not be pinged.

    For testing purposes we added sapmsD30 to the hostfile with the IP address of the message server eccdev.

     

    Then MIIS threw an error while importing:

    "The stack trace is:

    ...

    ERROR service '?' unknown

    ..."

     

    When searching the internet for “ERROR service '?' unknown”, I found: https://www.sdn.sap.com/irj/sdn/message?messageID=997314

    (SDN = SAP Developer Network)

     

     

    In that post, one of the users, mentions that the services file (in %windir%\system32\drivers\etc) should not use spaces but tabs.

     

     

    For example "sapdpxx <many spaces> 32xx/tcp" must be changed to "sapdpxx <1 tab> 32xx/tcp"

     

    After saving the changes to the services file, the MIIS import of the ERPMA succeeded.

     

    Full details at http://identityunderground.spaces.live.com/ (blog entry dd.16/11/2007)

    Friday, November 16, 2007 8:44 PM

All replies

  • Hi Peter,

     

    Maybe this post here will shed some light.

     

    Cheers,

    Saturday, September 29, 2007 1:06 AM
  • With assist of MS PSS (Thanks, José!), we found the solution to the problem.

    Finally it comes down to spaces/tabs in the services file.

     

     

    If you look into the help of the ERP Management Agent Configuration Tool, look for 'load balancing'.

    Strangely enough, "Known Issues" is shown, but never mind.

     

    It says, I quote, "

    ... 

    For reference, the below sample shows a connection string which specifies the 'SAPADM' logon group:

    /M/mySap.sap-ag.de/S/4253/G/SAPADM

     

    '/M/' (message server host name

    '/S/' (message server port)

    '/G/' (logon group)"

     

    But it does not tell you that there is another option to use a loadbalancing string, very much alike the normal (direct) SAP connection string example that is displayed by the tool (ASHOST=host SYSNR=## CLIENT=###).

    But you need to use a syntax that is a bit different, like:

    MSHOST=MSGSVR_ALIAS R3NAME=APPSVR_NAME GROUP="logongroup" CLIENT=XXX SYSNR=XX

    In which

    MSHOST = Central Instance of SAP system.

    R3Name = System Name

    Group = Logon Group defined in the SAP system for your application.

     

    To use logon groups, you need to make sure that your connecting to the messaging server, rather than to the application server host.

    (Generally the message server has a name ending with "00" as system number...)

     

    Before you can use that loadbalancing string, you need to add the required entries in the services file. (meaning %WINDIR%\System32\Drivers\etc\services file)

     

     

    But initially this didn’t work neither.

     

    The ERPMA Configuration tool could not connect to the message server.

    And MIIS threw an error, at import:

    "Stack trace is:

    ...

    ERROR service 'sapmsD30' unknown

    ..."

     

    The system/service sapmsD30 could not be pinged.

    For testing purposes we added sapmsD30 to the hostfile with the IP address of the message server eccdev.

     

    Then MIIS threw an error while importing:

    "The stack trace is:

    ...

    ERROR service '?' unknown

    ..."

     

    When searching the internet for “ERROR service '?' unknown”, I found: https://www.sdn.sap.com/irj/sdn/message?messageID=997314

    (SDN = SAP Developer Network)

     

     

    In that post, one of the users, mentions that the services file (in %windir%\system32\drivers\etc) should not use spaces but tabs.

     

     

    For example "sapdpxx <many spaces> 32xx/tcp" must be changed to "sapdpxx <1 tab> 32xx/tcp"

     

    After saving the changes to the services file, the MIIS import of the ERPMA succeeded.

     

    Full details at http://identityunderground.spaces.live.com/ (blog entry dd.16/11/2007)

    Friday, November 16, 2007 8:44 PM
  • Hi Peter:

    Many thanks for the information.  I was totally puzzled and frustrated by  ERROR service '?' unknown” issue with my SAP connection.

    The following solution that you pointed out solved the problem:

    the services file (in %windir%\system32\drivers\etc) should not use spaces but tabs.

    For example "sapdpxx <many spaces> 32xx/tcp" must be changed to "sapdpxx <1 tab> 32xx/tcp"

    Bing


    Wednesday, October 28, 2009 9:35 AM
  • Thanks for the feedback!

    Don't forget to mark the post as helpful if it solved your problem.

    Kind regards,
    Peter
    Peter Geelen - Sr. Consultant IDA (http://www.traxion.com)
    Thursday, October 29, 2009 3:54 PM