locked
Complete folders missing from Document Library, but available through search (WSS 2.0) RRS feed

  • Question

  • Dear all,

    We have a WSS 2.0 Server (in Farm mode with SQL backend). About 6 months ago, a user moved a lot of folders around within a Document Library (doing a bit of a cleanup).

    Since then, most folders in the library cannot be seen, either through web browser or Explorer view. They simply don't appear (as though they've been deleted).
    However, if we search for a file it will appear in search, and the URL/path to the file is in the folders that cannot be seen (or seemingly don't exist). You can then view the file as normal if you click the link from the search results.

    If we remove the file name from the URL we can then browse the folder that it resides in, however once we get up to the top level folder in the D/L, we get a 404.

    Eg: Browsing we see:

    Shared Documents/Folder one
    Shared Documents/Folder two

    If we search we see links to:

    Shared Documents/Folder five/Quotes/Australia/quote1.doc (we can then view & download this file fine).

    We can then enter the URL to "Shared Documents/Folder five/Quotes/Australia/" in browser and view all files in the Australia folder. If we click 'Up' we can even view the contents of the 'Quotes' folder, but then we hit 'Up' again to get to Folder Five, we get a 404!

    This is the most bizarre of all WSS problems I've seen, and I've see quite a few. I cannot explain it or solve it. The path to these files is less than 200 characters. There are no illegal characters in the names.

    Has anyone see or dealt with this before? Any help would be greatly appreciated. Thanks in advance!

    Steven


    • Edited by Mike Walsh FIN Wednesday, May 18, 2011 4:44 PM WSS 2.0 added to Title. Way back product
    Monday, May 16, 2011 5:04 AM

All replies

  • The issue may be caused by incremental crawl is not updating the index, please try to create a new search database and re-associate the indexer to the content database.


    --Cheers
    Monday, May 16, 2011 9:54 AM
  • Hi Prasath,

    Thank you for the response. I'm not sure that I understand you correctly - are you suggesting that the search index is damaged?

    If yes then I think you may have misunderstood my issue. The issue is that there are thousands of files that can be found & opened via search, however these items do not appear when browsing via any means. (they do not appear in the Document Library when using either IE, or Explerer view).

    So the search works fine & finds the documents, however when we browse the site these files & folders just don't exist. We can only find the lost files by searching.

    I really want to migrate these files into a new Sharepoint infrastructure, but as we can only access the files by searching - we'd have to open & save them individually. We can't copy/paste via Explorer view, and although we use Metalogix SSMM it can't access the files either. It can only copy the files that are readily accessible in the DL.

    To me it appears as though the database itself is possibly corrupted and doesn't list the files, however the search index still lists the files.
    Does that explain the issue further or have I misunderstood your suggestion?


    Wednesday, May 18, 2011 5:28 AM
  • Hi,

    Can you check if you are able to see those documents/folders in the webfolders view, for me it seems the view files (allitems.aspx and other view files) might get deleted.

    So, can you map your site as a network drive and try browse to see if those documents/folders are visible ? if the crawl is picking up the document, then the document should be available on the site.


    I am suspecting that users might have deleted or overwritten the view files (.aspx files), when they did a bulk upload or cleanup operation.

     


    Thanks, Arun, Posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:43 AM
    • Unmarked as answer by ITechnique Wednesday, June 22, 2011 7:37 AM
    Friday, May 20, 2011 4:21 PM
  • Hi Arun,

    Thank you again for your reply and for taking the time to answer. This is a really strange problem. I have tried using Explorer view, and have tried mapping a network drive also, or using My Network Places. Still we cannot see several folders. I have even tried re-creating new Views (new .aspx files) as I thought that there might be some kind of filtering problem. However nothing has worked.

    To add more info - If we search for files & then click a file address in search results we can view the file. If we then delete the file name from the URL, we can browse the folder that the file resides in. Such as:

    http://sharepoint/Marketing/Shared Documents/Proposals/Government/2010/

    we can then see the full contents of the 2010 folder. If we hit 'Up' we can see the contents of the Government folder (ie: 2009, 2010 etc). If we hit 'Up' again we see the contents of the 'Proposals' folder, but it appears completely empty! We do not see the Government folder (or other folders) at all. This is the same either through Web interface, or Explorer view.

    I'm seriously considering taking a video of this as I understand it would be difficult to comprehend and believe. I have never seen such a strange issue in Sharepoint & I've been working with it for many years.

    I don't fancy restoring a 120GB database from many months ago! These files are there I'm just wondering how we can access them!

    I really appreciate your help.

    Steven

    Friday, June 10, 2011 8:10 AM
  • Hi Arun & all,

    With that new info above - can anyone suggest an explanation/resolution to this bizarre problem?

    Regards,

    Steven

    Wednesday, June 22, 2011 8:35 AM
  • Reducing things to basics often helps, so correct me if I'm wrong but: -

    • The search functionality is retrieving the items
    • The items aren't visible
    • The item visibility only changed after a user manually moved them?

    So, on this basis, my first thought is to have a look at the items themselves and the container that they're in.  My suspicion is that they're either needing approval or they have missing metadata and don't appear as such to the end-users, but still appear in the WSS search results as it's not clever enough to filter them out. so: -

    1. Can you elaborate on the move methodology that the user used?
    2. Have you checked that content approval has been turned off?  Or, have you checked that these items aren't awaiting approval?
    3. Have you tried viewing these items with a fully permissioned administration account?

    Once these have been answered we can look at some more advanced settings.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Wednesday, June 22, 2011 12:01 PM
    Answerer
  • I suspect some webparts might have been closed, go to the siteurl http://urlname/defaul.aspx?contents=1 and open all the  web parts and check once

    Thanks,

    Raj

    Wednesday, June 22, 2011 12:21 PM
  • Dear All,

    We are using WSS 3.0 and with document library facing similar problem. But in our case the search result does not includes the files from missing folder.

    Kindly help.

    Rajkumar

    Tuesday, July 12, 2011 9:45 AM
  • Did you ever find a solution to this issue?  I am experiencing the same problem with folders that are visible in webfldr.aspx missing from the allitems.aspx view.

    I would appreciate any help on this issue.

    Teddi

    Thursday, February 9, 2012 4:15 PM
  • Just in case anyone comes across this in the future, the same thing has happened with our site and it's been a case of a parent folder being renamed and suddenly everything in there becomes invisible.  If you rename the folder back to exactly what it was then all the data should show back up.
    Tuesday, November 27, 2012 7:03 PM