none
Stuck after first reboot RRS feed

  • Question

  • I can successfully deploy my Windows7 x64 image to a VM using MDT2013. So, the next phase of my setup was to start injecting drivers into my Task Sequence based on hardware model in our organisation (Win7\%make%\%model%)

    After the Inject Drivers/Restart tasks execute (was really quick), the PC reboots and sits at the Windows 7 login screen (can't login). As from the above screenshot, I have temporarily disabled DriverGroup001 but this hasn't helped. Any advice?

    Monday, April 20, 2015 1:35 AM

All replies

  • I can't login to the PC to retrieve any MDT log files to assist in troubleshooting. Scratching my head on this one.
    Monday, April 20, 2015 2:04 AM
  • Well if you disable it then no drivers will be injected. Does your Out-of-Box drivers have the matching structure? That part is essential. In your case WIN7\make\model

    Your Inject Drivers task should have a selection profile of "Nothing" and "Install all drivers from the selection profile".


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, April 20, 2015 2:11 AM
  • Here is my Windows 7 structure. I know that "Dell Inc." is correct as I ran following commands on the same system for a Precision T5500. Have I got the "Precision" names correct?

    C:\Windows\system32>wmic
    wmic:root\cli>csproduct


    "Your Inject Drivers task should have a selection profile of "Nothing" and "Install all drivers from the selection profile"."

    My Inject Drivers task looks like the below as per Figure 5 in article below;

    http://www.windowsnetworking.com/articles-tutorials/windows-7/Deploying-Windows-7-Part26.html

    Something to note, I have 2 Inject Drivers tasks. One under Preinstall, one under Postinstall.

    Monday, April 20, 2015 3:00 AM
  • Just checked a Dell T5400. wmic >csproduct listed it as a;

    Precision WorkStation T5400

    Not sure if I should be including WorkStation?
    Monday, April 20, 2015 3:02 AM
  • This didn't work either;

    http://www.windowsnetworking.com/articles-tutorials/windows-7/Deploying-Windows-7-Part23.html

    Are we finished? No, not quite. We have imported the driver into the Workbench, so the driver is now available for installation on the target computer but it hasn't yet been incorporated into our Lite Touch Windows PE image files, that is into the files LiteTouchPE_x64.wim and LiteTouchPE_x64.iso. What we need to do is to inject the driver into our image files so that the driver will be available during the initial WinPE phase of Setup, otherwise Setup will fail because WinPE would not be able to see the hard drives in the system. Fortunately, MDT makes injecting drivers into WinPE images a snap—simply right-click on your deployment share and select Update Deployment Share and any changes made to your environment will be injected if required into your WinPE images. Figure 9 shows the results from doing this, and you can see that the boot image (.wim) file was mounted, the mass storage driver was injected, and the.iso file associated with the boot image was re-created:

    I'm running WDS on a different VM than MDT, so I manually copy LiteTouchPE_x64.wim from D:\DeploymentShare\Boot on my MDT VM and then add the Lite Touch Windows PE (x64) boot image.

    Monday, April 20, 2015 3:27 AM
  • Change it to "Install all drivers from the selection profile". Don't mess with Postinstall, just change the Preinstall. If your screenshot is your current settings, then enable the DriveGroup001 task.

    Unless you're using a Modelalias script, then make sure your folders exactly match the make and model name reported by wmic.

    Example: WIN7 --> Dell Inc. --> Precision WorkStation T5400

    Dell sometimes uses Dell Computer Corporation, Dell Computer Corp., Dell Inc.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, April 20, 2015 10:42 PM
  • OK, I found my problem. I hadn't created a profile in 'Selection Profiles'. So I made one called 'Win7' and associated all my hardware with it. I then configured my Task Sequence as below;

    Done a test on a Precision T5500 with Precision T5500 drivers and even though having some Windows setup issues, it's great progress as at least the driver selection is working. I will now start testing other hardware variants.

    Tuesday, April 21, 2015 11:59 PM
  • SUCCESS! Precision T5610 test worked perfectly.
    Wednesday, April 22, 2015 12:37 AM