locked
Visio and Project 2013 using AppV - issues encountered and clarification sought RRS feed

  • Question

  • Good morning,

    We're looking to publish Visio Pro 2013 and Project Standard 2013 using AppV. Using the following links we've got very close: http://blogs.technet.com/b/odsupport/archive/2013/06/19/using-the-office-deployment-tool.aspx, http://blogs.technet.com/b/office_resource_kit/archive/2013/12/02/announcing-app-v-5-0-sp2-support-for-office-2013-volume-licensing-editions.aspx & http://support.microsoft.com/kb/2915745/en-us . As mentioned we've got very close but encounter a couple of issues which I'll list below:

    The first is that when creating a package for Visio and then a seperate one for Project, we're unable to publish them both together as in the AppV management console the message returned is "A version of this package with version number 15.0.4551.1512 already exists on the server". In the support.microsoft.com link it mentions that the Version can be specified, but it doesn't mention whether this controls what you download or whether this just changes the version number that I can see in the AppV management console. Can anyone confirm whether this relates to the version that is downloaded or just the number that appears in the AppV management console? Also can this version number be amended elsewhere, like in one of the .xml files (I've had a search within both the deployment and user config files, but not found anything yet).

    So as I was unable to publish 2 different AppV packages containing the 1 application each, I decided to create 1 AppV package containing the 2 applications. I modified my configuration.xml file to include both VisioProVolume and ProjectStdVolume. The AppV package is created, I can then publish the package through the AppV but then when opening either of them we receive the Activate Office message "To activate Office, enter the email address that's associated with your Office subscription" (this didn't appear when having either of the individual packages mentioned above published) which leads me to believe that the packager part of the process hasn't converted the package into a volume licensed edition as it is meant to. I've tried the process again in case it had failed but all completes correctly. Can anyone confirm if it is possible to use the processes above to only produce a package containing Visio and Project, or are the only configurations allowed any of them individually, office + visio, office + project, and office + project + visio all together?

    So I then moved onto producing a package that contains all 3 components (office, visio and project). This all went through ok and after publishing I was able to open Visio and Project all ok (and without the Activate Office message as mentioned above). However we currently don't want Office 2013 to be published, just Visio and Project. So I've tried to deselect all the other unwanted applications by clicking on edit default configuration, then going to the Applications section and deselecting the ticks under Enable from the various applications. However the box only displays 5 applications and when scrolling down the box to see any options from 6 downwards, before you've had chance to remove the ticks the box has scrolled back up to the top 5 applications. I've tried different versions of Internet Explorer but the same issue persists. Has anyone else had this problem in the Management console?

    Also, is there a way I can remove the ticks in the console by editing a configuration file anywhere to get around this issue? On the 2nd blogs.technet.com link it mentions about disabling various elements through the Deployment Configuration file by adding Enabled="false" after the Application ID executable name. I've tried this but after publishing the office package, the various individual elements that I was hoping to disable where still present. Has anyone been able to disable individual Office elements using this method and if so, at which part of the DeploymentConfig.xml file did they have to enter the Enabled="false" section?

    Thanks

    Friday, January 17, 2014 10:23 AM

Answers

All replies

  • Packages created from the ODT will have the same GUID hence the issue importing multiple packages. This will be so that user preferences are applied across different packages.

    If you deliver Office/Visio/Project etc. in separate packages, you may have interaction issues when performing some actions, such as copying and pasting a Visio document into a Word document because the applications are in different virtual environments. I'd need to confirm this myself though.

    You might be able to open the generated Office packages in the Sequencer to update the GUIDs; however I would assume that doing so is unsupported.

    As for your scrolling issue, have you installed this update on your Management Servers: http://support.microsoft.com/kb/2897087



    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    • Proposed as answer by znack Friday, January 17, 2014 3:22 PM
    Friday, January 17, 2014 11:29 AM
    Moderator
  • Thanks for the scrolling issue hotfix, I'll give that a whirl and then that will hopefully mean we can get started with the full blown Office 2013 package and then turn a number of the applications off.

    Does anybody know if I'd be able to have an Office pro plus, Visio Pro and Project Standard package at all?

    Wednesday, January 22, 2014 2:40 PM
  • I've tried today the process of using the ODT to produce a Pro Plus, Visio Pro and Project Standard package. My configuration file looks as so:

    <Configuration>
      <Add OfficeClientEdition="32" >
      <Product ID="ProPlusVolume">
          <Language ID="en-us" />
        </Product>
        <Product ID="VisioProVolume">
          <Language ID="en-us" />
        </Product>
    <Product ID="ProjectStdVolume">
          <Language ID="en-us" />
        </Product>
      </Add>
    </Configuration>

    When coming to publish this package and then loading it appears as Project Pro rather than Project Standard. We only have licenses for Project Standard, does anyone know how I can make this configuration work? The following article suggests that standard can be used, but are you able to mix and match the different versions?

    http://blogs.technet.com/b/office_resource_kit/archive/2013/12/02/announcing-app-v-5-0-sp2-support-for-office-2013-volume-licensing-editions.aspx

    Thanks

    Thursday, January 23, 2014 2:59 PM
  • There is a new version of ODT which can be downloaded here. You may want to reattempt creation of the package with this updated tool.

    Brandon
    MDOP on the Springboard Series on TechNet

    Friday, February 7, 2014 4:37 PM
    Moderator
  • I downloaded the updated tool, and attempted to create separate packages, but received the GUID error noted in the original post. Please advise.
    Friday, May 23, 2014 7:27 PM
  • "This summer" yet another ODT will be released with support to set Office version. That way we can have multiple Office 2013 packages imported into the same AppV5 Mgmt server.

    For more info check this excellent presentation from Teched NA 2014: Everything You Need to Know for a Successful Microsoft Office 2013 App-V Deployment (check the slide on 56min15sec "ODT Summer 2014 Updates").

    Saturday, May 24, 2014 5:14 AM
  • Hi Guys

    tried to do the same with the latest update of Office Click-to-run deployment tool and App-V 5.0 SP3 Server and I still get the same error!

    any updates regarding this issue? 

    it's a big bummer


    Tamir Levy

    Wednesday, May 6, 2015 2:05 PM
  • hi

    I added the "Package ID" with a unique GUID before the /packager command.

    worked


    Tamir Levy

    Thursday, May 14, 2015 6:10 AM