locked
Time Zone issue with Windows Server 2008 R2 and Sysprep RRS feed

  • Question

  • Good People,

                    I have come across and issue with Windows Server 2008 R2 when deploying an image created using Sysprep.

     

    My steps are.

     

    1.       Create reference image – very basic.

    2.       Run Sysprep with options /OOBE /Generalize and /Shutdown but no “unattend” file specified.

    3.       Capture image

    4.       Boot Windows PE on new hardware and deploy image to local disk on new hardware, then copy an unattend.xml file to C:\Windows\Pather\unattend

    5.       Reboot from local hard disk, the unattend.xml file is processed.

    6.       Machine reboots a couple of times, joins domain etc, sets region, language. All looks good.

     

    EXCEPT!!!!

     

    On checking the time zone, it displays “Your current time zone is not recognized. Please select a valid time zone using the link below”

     

     

     

    The time zone information show is correct. The time on the server is correct. I can change the setting in the unattend.xml file to test a different time zone and the server time is always correct, but whatever time zone I use in the unattend.xml file, the message is always the same. I have even tried “UTC”, and still same message.

     

    I believe this is probably a bug, but I would love to know if anyone has seen the same issue.

     

    I can include a copy of the unattend.xml for reference also if required.

    Regards
    Andrew Stuckey

    Wednesday, January 27, 2010 1:41 AM

All replies

  • I just called MS and they said this is a bug for Win7 64bit and the bug number is 616551. Because 2008 R2 has same structure with Win7, this should also be a bug for 2008 R2.

     

    I recommend you ignore the error. Once deployed, change the time zone.

    Thursday, January 28, 2010 7:01 AM
  • Any news on this? I have exactly the same thing when rolling out windows server 2008 r2 using ConfigMgr. Thanks!
    Tuesday, May 11, 2010 10:25 AM
  • It seems to be a bug in the unattended installation of W2K8R2. I have had exactly the same problem. Whatever I put in the timezone section of the unattend.xml, the result always is Your current time zone is not recognized... I found out that in my case the entry of timezone from the unattend was placed in the reg key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\StandardName It should be in: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\TimeZoneKeyName Which is empty after the unattended install. If you create a script to move the contents from key StandardName to key TimeZoneKeyName and reboot the machine, the message is gone and your time zone setting is correct. Wijnand
    Friday, June 18, 2010 12:34 PM