locked
Response Group Federation RRS feed

  • Question

  • Hi All,

    I have a few response groups setup and working fine with an internal/remote/PSTN user call the number, however I am not able to get a call from a federated user to work with the response group.

    The status of the response group from a federated user point of view is always "presence unknown".. I have ticked the "enable federation' check box in the response group workflow configuration.  Is there something that I need to do?  Im assumeing I have missed a step somewhere to get the federation working but dont know where/what that step is.

    Any help appreciated.

    Cheers

    J

    Tuesday, February 28, 2012 11:41 PM

Answers

  • I had this exact same issue but I figured out the solution.  Your 'global' policy under 'external access policy' needs to have federation and external user access enabled.  Since all Lync objects need a policy applied to them, RGS objects by default get the global policy, and if it's not enabled for Global federation doesn't work for the RGS.
    • Marked as answer by Jason Harmer Monday, December 17, 2012 10:02 PM
    Monday, December 17, 2012 6:38 PM

All replies

  • Hi,
    Your federation partner can see the presence of your normal user?
    Please check your remote users can see the presence of the Response group.
    You can have a try to create another test response group to check if your federated users can see its presence.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, March 1, 2012 10:23 AM
  • Hi Sean,

    Yep federation patners can see normal user presence fine.

    Remote user are able to see the response group presence fine.

    We currently have 10 Response Groups and Im not able to see any presence from a federated user point of view.

    Im guessing that usually the only thing that needs to be done is tick the "enable federation" box on the response group workflow.

    Cheers

    J

    Thursday, March 1, 2012 10:36 PM
  • Hi,

    Typically, you just need to enable federation on the response group workflow. I think maybe the configuration isn't replicated to edge server. Please check the edge server replication status in Lync server control panel.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, March 5, 2012 5:17 AM
  • Sean,

    All replication is good from the CSCP.  When i take a trace on the edge server, i see the request come through to the FE server and get the following error:

    ms-diagnostics

    : 4033;reason="To User not authorized for Federation";

    Cheers

    J

    Tuesday, March 6, 2012 2:57 AM
  • Hi,

    Looks like the edge server doesn't get the configuartion about response group enable for federation. Please try to install the latest update for your lync server and restart. In my lab environment, my response group presence can work for federated partner. I had install CU4 in my lync servers.

    http://support.microsoft.com/kb/2514981


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by Sean_Xiao Tuesday, March 6, 2012 7:19 AM
    Tuesday, March 6, 2012 3:21 AM
  • Thanks Sean,

    Customer is only running CU3 so that could be it.  Will try and organise an upgrade and see how it goes.

    Cheers

    J

    Tuesday, March 6, 2012 3:43 AM
  • Hi,

    Any update?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, March 9, 2012 2:48 AM
  • Not yet, still waiting on my customer for a CR to get CU4 or CU5 installed..

    Monday, March 12, 2012 12:18 AM
  • Hi Sean,

    So have just upgraded to CU5 on all the Lync servers and I am still seeing the same issue, remote users see the presence fine, but federated users still see "presence unknown", with same error.

    4033;reason="To User not authorized for Federation";

    Any other suggestions?

    Cheers

    J

    Thursday, March 15, 2012 11:13 AM
  • Anyone still seeing this issue, I multiple other deployments running CU4/5 and response group federation works fine.

    Its just this one..

    Cheers

    J

    Tuesday, April 24, 2012 12:18 AM
  • So I have run into this one again.  CU6 Installed and Response Group working fine for Remote/Internal users, but federated users get nothing. Standard Edition Install this time.

    Now Im starting to think that im missing something then setting the enviroment up.

    Edge Server not joined to domain --> I get nothing from Response Group with federated user

    Some systems I have deplyed have Edge on the domain for management --> Response groups with federated user work as expected

    I dont like having Edge servers joined to domain, so hoping someone can confirm they have an edge server NOT joined to domain and have response groups working with federated users.

    Cheer

    Jason


    My UC Thoughts

    Tuesday, August 7, 2012 2:36 AM
  • Same here, I'm getting "To User not authorized for Federation" even my Edge has joined the domain.

    • Edited by Stef-an Thursday, October 11, 2012 4:16 PM
    Wednesday, October 10, 2012 2:12 PM
  • I had this exact same issue but I figured out the solution.  Your 'global' policy under 'external access policy' needs to have federation and external user access enabled.  Since all Lync objects need a policy applied to them, RGS objects by default get the global policy, and if it's not enabled for Global federation doesn't work for the RGS.
    • Marked as answer by Jason Harmer Monday, December 17, 2012 10:02 PM
    Monday, December 17, 2012 6:38 PM
  • Cheers Matt,

    That exactly what the issue was.  Once I enabled federated users in the global "external access policy" it all started working.

    Thanks

    Jason


    My UC Thoughts

    Monday, December 17, 2012 10:03 PM