locked
Exchange 2013 Dashboard error for non admins, object not found RRS feed

  • Question

  • When a user opens the dashboard 'Organization Summary' he get's an error:

    Please provide the following information to the support engineer if you have to contact Microsoft Help and Support :
    Microsoft.EnterpriseManagement.Presentation.DataAccess.DataProviderException: An error occurred executing the command: [Microsoft.Exchange.15.Visualization.Components.DataProviders!GridDataProvider/GetOrganizationGridData] in provider: [Microsoft.Exchange15.Visualization.Components.DataProviders.GridDataProvider, Microsoft.Exchange.15.Visualization.Components.DataProviders, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]. : An object of class MonitoringObject with ID 63dda398-90e3-bba3-ed8e-0363c949bd3a was not found. ---> Microsoft.EnterpriseManagement.Common.ObjectNotFoundException: An object of class MonitoringObject with ID 63dda398-90e3-bba3-ed8e-0363c949bd3a was not found.
       at Microsoft.EnterpriseManagement.InstancesManagement.GetObject[T](Guid id, ObjectQueryOptions queryOptions)
       at Microsoft.EnterpriseManagement.MonitoringInstancesManagement.GetObject[T](Guid id, ObjectQueryOptions queryOptions)
       at Microsoft.Exchange15.Visualization.Components.DataProviders.GridDataProvider.GetOrganizationGridData(String connectionTicket, DateTime startTime, DateTime endTime)
       --- End of inner exception stack trace ---
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.DataProviderCommandMethod.Invoke(CoreDataGateway gateWay, DataCommand command)
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.CoreDataGateway.ExecuteInternal[TResult](DataCommand command)
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.CoreDataGateway.<ExecuteAsync>b__0[TResult](<>f__AnonymousType0`1 data)

    I've found the name of the object with the id 63dda398-90e3-bba3-ed8e-0363c949bd3a via powershell and came to find that the user does not have permissions to view that object.
    We have 11 different exchange 2013 sites in scom all in other domains, monitored via gateways and this user may only see 1 site.
    The permissions on objects to users are being assigned via the site group that is created with the gateway, so a user may only see objects from 'his' site wich works very well, but not in this case.
    So it looks that this dashboard is not obeying the permissions and just wants to show all exchange sites of those class.

    When i as scom admin run this dashboard it works fine.
    I'm using the exchange MP version 15.0.666.19, i see that there is also 1 newer version but it doesn't show this being fixed in it's release notes, also it seems to be no longer available at this moment.
    SCOM 2012r2 UR8
    Friday, July 1, 2016 3:13 PM

All replies

  • Hi Sir,

    Have you tried different User Role?

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .

    Monday, July 4, 2016 7:36 AM
  • Hi,

    I tried only the normal operator and the scom admin role. Those are for us the interesting roles. A read only operator that can see all object probably hasn't have this issue but its not a solution for me.

    Gr,
    Ronald

    Monday, July 4, 2016 7:56 AM