locked
ActiveSync Problem RRS feed

  • Question

  • Need your help to configure Activesync for Exchange 2007. This is my first time to set it up so I am not sure if I am doing it correctly.

    We have 2 CAS Servers, Call it CAS1 and CAS2. Have purchased SSL Certificate and imported it to CAS1 Server using the Exchange Shell Command: Import-ExchangeCertificate ….successfully imported and enabled the certificate on the server.

    External Domain FQDN is  mail.mydomain.com

    When I connect using mobile device, synchronization does not work. I ran test at testexchangeconnectivity.com and gives me error on certificate:

    Host name mail.mydomain.com doesn't match any name found on the server certificate CN=CAS2

    What can I do to resolve this?

    Thanks

      

    Thursday, April 14, 2011 7:51 AM

Answers

All replies

  • Some progress..I managed to resolve this error..found out it was the firewall which was mapping to CAS2 ( instead of CAS1) and the policy was higher in the order so was being executed before the other policy to map to CAS1..

    Running the test again on testexchangeconnectivity.com gives a second error now:

    Validating certificate trust for Windows Mobile devices.  

    Certificate trust validation failed.  

    The certificate chain didn't end in a trusted root

     

    Thursday, April 14, 2011 9:25 AM
  • Solved.

     

     

    Monday, April 18, 2011 5:41 AM