locked
Copy file from VFS to c:\Program files location RRS feed

  • Question

  •  

    Hello All,

                I am doing evaluation of Softgrid.

    One of the application that I virtualized has a requirement which I am finding difficult to resolve in Softgrid.

     

    This application is installed in Q:\Program files\ {application A directory}.

    When this application starts up , it checks for a file in C:\Program files\ {application B directory}

    If it does not find the file it will copy the file to C:\Program files\ {application B directory}

     

     

     In short we are trying to make the virtualized application copy a file into location “C:\Program files\{Application B Directory}” location.

     

    When application tries to do this , softgrid  writes the file to the Virtual file system.

     

    Users should have the ability to manually copy this file to “C:\Program files\{Application B Directory}”. That’s why this location has to be out of VFS.

     

    How can I over ride this and force to create the file out of VFS.

     

     

    Thanks for your help

    Monday, August 25, 2008 9:07 PM

Answers

  • curio,

     

    Do you have this C:\Program files\ {application B directory} on the sequence (does it show on the VFS tab)? If so, just remove it from there (or change it to semi-virtualized by taking "Virtualized" -check away from the context menu of the folder in the VFS tab) as copy to non-virtualized folders will go to real filesystem?

     

    br,

    Kalle

    • Proposed as answer by znack Thursday, July 16, 2009 8:59 PM
    • Marked as answer by Aaron.ParkerModerator Thursday, March 8, 2012 9:05 PM
    Thursday, August 28, 2008 8:46 AM
    Moderator

All replies

  • Your package root directory should be Q:\8.3 (Q:\AppB.v1)

    http://blogs.technet.com/softgrid/archive/2007/10/04/getting-to-the-root-of-the-8-3-root.aspx

     

     

    Wednesday, August 27, 2008 3:20 AM
  •  

    check this link...might be u'r area of interest...

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2920718&SiteID=17

    Wednesday, August 27, 2008 5:29 AM
  • curio,

     

    Do you have this C:\Program files\ {application B directory} on the sequence (does it show on the VFS tab)? If so, just remove it from there (or change it to semi-virtualized by taking "Virtualized" -check away from the context menu of the folder in the VFS tab) as copy to non-virtualized folders will go to real filesystem?

     

    br,

    Kalle

    • Proposed as answer by znack Thursday, July 16, 2009 8:59 PM
    • Marked as answer by Aaron.ParkerModerator Thursday, March 8, 2012 9:05 PM
    Thursday, August 28, 2008 8:46 AM
    Moderator
  • Yes that works.

    If the package does not have any reference to "program files" location the file copy works.

    I am also trying to evaluate the other two options mentioned in previous replies BoruRR & spontaneous.

     

    I will post the details of my findings and the solution we selected.

     

    Thanks for your help.

     

    • Proposed as answer by znack Thursday, July 16, 2009 8:59 PM
    • Unproposed as answer by Aaron.ParkerModerator Thursday, March 8, 2012 9:05 PM
    Thursday, August 28, 2008 3:39 PM
  • Just wanted to update the solution thats finally used,

     

    The suggested solutions - by Kalle and "spontaneous" works.

    We finally decided to use a startup script to copy the files.

     

    Thanks for your help.

    Tuesday, September 2, 2008 4:24 PM