none
Department values are not showing up in people search results

    Question

  • Greetings,

    We have Directory Sync setup in our environment. All of the users and corresponding user profile attributes are provisioned directly from our local AD. However, when searching through the OOTB People Search page, neither search results nor the search refiner shows people's department. The only two properties I can see here are Job Title and Keywords...

    Below are the areas that I've examined so far:

    1. Checked the User Profiles service (People -> Manage User Profiles) in the SharePoint admin center. All of the users have the correct properties and values synced from our local AD
    2. Checked the Search Schema for Managed Properties. Department property is mapped with"People:Department" and "ows_Department". Department property is Queryable, Retrievable, and Refinable
    3. Called the SharePoint REST API to retrieve current user's properties. I can see the correct properties and values on my JSON result 

    Did I miss something here? Any help or guidance would be truly appreciated.



    • Edited by Terry8023 Wednesday, February 8, 2017 8:54 PM
    Wednesday, February 8, 2017 8:52 PM

All replies

  • Hi Terry8023,

    There are two Department properties in User Profile.

    Please ensure the following Department has value.  


    Then we need to wait some time for crawling, the Department values will show in the refiner.

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, February 9, 2017 10:19 AM
  • Hello Linda,

    Thanks for getting back to me. Yes, both Department properties have the correct values. As far as timing, we have our environment sync to local AD for months...

    I know in SharePoint Online, there's no way I can schedule a re-crawling/re-indexing from the Admin Center. Is there any way I can get Microsoft involve and get this done from you end?

    Thanks,

    Terry 

    Thursday, February 9, 2017 5:00 PM
  • Hi Terry,

    For the crawling requirement, you should contact Office 365 technical support.

    An article about how to create service requests to contact Office 365 support for your reference:

    http://blogs.technet.com/b/praveenkumar/archive/2013/07/18/how-to-create-service-requests-to-contact-office-365-support.aspx

    Provide as much additional information as possible to describe your issue.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, February 10, 2017 2:12 AM