none
Error while creating powershell MA RRS feed

  • General discussion

  • I just followed the blog and tried creating the powershell MA and got attached error
     
    Could you please suggest me on what can be done to solve this error
     
    Or please let me know the detailed procedure step by step of creating the powershell MA

    Vinoth Kumar. M

    Monday, April 15, 2013 4:21 PM

All replies

  • I am traying to create office 365 powershell MA and followed http://blog.goverco.com/p/powershell-management-agent.html

    Vinoth Kumar. M

    My environment is FIM 2010 R2 SP1
    Monday, April 15, 2013 4:23 PM
  • When you create the MA, make sure to check the box (Run this MA in a seperate process)

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Monday, April 15, 2013 4:29 PM
  • Hi Soren,

    Yes I selected that but still getting this error

    First I downloaded the Granfeldt.Powersheel.ManagementAgent.dll and installed it on FIM Sync box

    Then I tried creating it and started getting the error

    Any other inputs?

    Thanks,

    Vinoth


    Vinoth Kumar. M

    Monday, April 15, 2013 4:32 PM
  • Removing the checkmark :-) ?

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Monday, April 15, 2013 4:34 PM
  • Tried but no luck

    Vinoth Kumar. M

    Monday, April 15, 2013 4:34 PM
  • Do I need to modify anything on Import or Export script?

    Vinoth Kumar. M

    Monday, April 15, 2013 4:36 PM
  • Which version are you on? If on 4.5, you need Service Pack 1 on the Sync Service. Also, check that the .DLL is not blocked


    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt


    Monday, April 15, 2013 4:37 PM
  • I am using 4.5.1 and my FIM is 2010 R2 SP1.

    Yes the DLL is unblocked only


    Vinoth Kumar. M

    Monday, April 15, 2013 4:39 PM
  • FIM Product version is 4.1.3419.0

    Vinoth Kumar. M

    Monday, April 15, 2013 4:39 PM
  • Anything in eventlog? I had this issue at a customer but that did have to do with the checkbox mentioned earlier.

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Monday, April 15, 2013 4:44 PM
  • The event details as below:

    Log Name:      Application

    Source:        FIMSynchronizationService

    Date:          4/15/2013 9:35:17 AM

    Event ID:      6801

    Task Category: Server

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      *****************

    Description:

    The extensible extension returned an unsupported error.

    The stack trace is:

     "System.ArgumentException: The path is not of a legal form.

       at System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength)

       at System.IO.Path.GetFullPath(String path)

       at Granfeldt.PowerShellManagementAgent.Microsoft.MetadirectoryServices.IMAExtensible2GetParameters.ValidateConfigParameters(KeyedCollection`2 configParameters, ConfigParameterPage page)

    Forefront Identity Manager 4.1.3419.0"


    Vinoth Kumar. M

    Monday, April 15, 2013 4:54 PM
  • Aaaah, make sure that the path to the schema script (and the other scripts) does not contain spaces. The current version does not support that.

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Monday, April 15, 2013 4:56 PM
  • I placed the scripts in C:\Temp only. There is no space in between


    Vinoth Kumar. M

    Monday, April 15, 2013 5:00 PM
  • Could anyone please suggest next action on this? We are not able to proceed further because of this error and I have very limited knowledge on analyzing the MA coding.

    I just followed the blog and worked on it but no clue where did I miss?

    Please suggest


    Vinoth Kumar. M

    Monday, April 15, 2013 5:40 PM
  • make sure Everyone has full access to C:\Temp folder, just in case, might be a permissions issue on the folder :)

    Regards Furqan Asghar

    Monday, April 15, 2013 5:48 PM
  • I tried that as well but no luck

    Vinoth Kumar. M

    Monday, April 15, 2013 5:53 PM
  • Do I need to enable the option below which is highlighted in Yellow.

    At present it is NOT ENABLED


    Vinoth Kumar. M

    Monday, April 15, 2013 5:55 PM
  • OK, I have never used this management agent before :)

    But I am pretty certain this is NOT where you give the DLL Name and stuff :)

    Unmark all the highlighted check boxes here and go to the management agents tab and create a new Extensible Management Agent 2.0

    Thats where you provide this dll name and all the settings i suppose ;)


    Regards Furqan Asghar


    Monday, April 15, 2013 6:04 PM
  • Okay. Surprise. To create a management agent of this type go to Management Agent tab and click Create, select PowerShell in the dropdown and go through the steps. See documentation for more information.

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt


    Monday, April 15, 2013 6:24 PM
  • I have unselected all the options and trying to create the POwerShell MA but still not going through

    Stuck in same error

    Please any other inputs


    Vinoth Kumar. M

    Monday, April 15, 2013 6:39 PM
  • I'm sorry but I think you're trying to configure the MA a completely wrong place in the interface; have a look at the steps in this (http://technet.microsoft.com/en-us/library/hh859459(v=ws.10).aspx) under the section Create the ADMA that show you the basics of configuring an MA. The tabs will be different for the PowerShell MA but you can find more in the documentation for the MA on that. Basically, the initial steps are -

    1. Click Start, click All Programs, click Microsoft Forefront Identity Manager, and then click Synchronization Service.
    2. In the Synchronization Service, click the Management Agents button at the top.
    3. In the Management Agents view, on the right, under Actions, click Create. This will bring up the Create Management Agent dialog box.
    4. On the Create Management Agent screen, under Management Agent for, select Active Directory Domain Services. Under Name enter AD and then click Next.
    5. .... go with documentation for the specific MA from there...

    You may have to read up on FIM Sync and how to configure...


    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Monday, April 15, 2013 6:45 PM
  • Am creating in the proper place only. I crossed till AUTHENTICATION window and stuck in choosing the IMPORT & EXPORT file

    I have choosen PowerSheel MA only while creating MA

    I am already running AD MA, SQL MA, FIM MA without any issues.

    No clue why this powershell MA creation is failing


    Vinoth Kumar. M

    Monday, April 15, 2013 6:50 PM
  • Is anyone tested this MA & Scripts in FIM 2010 R2 environment?

    Vinoth Kumar. M

    Monday, April 15, 2013 10:42 PM
  • I have this running at at least 8 of my customers with no problems. Version 4.5 is built on R2 and needs SP1 for R2.

    I would be helpful if you could add screendumps of every step of the configuration of the MA. The screendump that you already put in here is not where you configure an MA - it is where you configure provisioning extensions. So please do similar stuff that you did for the AD MA and the SQL MA.

    Also, make sure that you're FIM Sync service account has permissions to execute PowerShell scripts (see documentation for the MA about Set-ExecutionPolicy);


    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Tuesday, April 16, 2013 4:48 AM
  • I have created the MA finally, it was looking for the location details of Password sync. I passed the location info and MA created


    Vinoth Kumar. M

    Wednesday, April 24, 2013 10:53 AM
  • Soren - we've just been running into the same issue as above, but were deleting the value in the password sync script field because we are not doing password sync ... this was causing the error because when we created a dummy passwordsync.ps1 file and referenced that we were able to create the MA.  Either need to make this value mandatory or fix the code :).

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using FIM Event Broker for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Thursday, July 24, 2014 3:26 AM