locked
Installing OCS 2007 Speech Server on Windows 7 X64 RRS feed

  • Question

  • Hi,

    I'm trying to install OCS 2007 Speech server on my development machine.  I am unable to install UCMA 1.0 and it reports the following error:

    "Microsoft Office Communications Server 2007, Unified Communications Managed API v1.0 Redist 64-bit installation requires Microsoft .Net Framework version 2.0.  Installation can not continue."

    When I try to install .Net Framework 2.0, I receive the following error:

    "This product is already installed as part of the operating system."

    If this is not a supported development environment, how can I get hold of OCS Speech Server 2010?  I'm a MSDN premium subscriber.

    Cheers,

    Matt

    • Moved by Daniel Chow - MSFT Friday, May 21, 2010 4:06 PM wrong forum (From:Microsoft Fix it Center)
    Wednesday, May 19, 2010 3:24 PM

All replies

  • Hi You could try to install it on a windows server 2003. That should work better. Microsoft communications server "14" will be released later this year and there is no public beta available yet.
    // Tommy Clarke - Blog: http://www.cinline.se/ - Twitter: http://twitter.com/itommyclarke
    Thursday, June 10, 2010 4:24 PM
  •  

    Per this KB, I uninstalled .Net 4.0 (Reboot) and was then able to install the UcmaRedist.msi

    http://support.microsoft.com/kb/2224981

     

    I noticed .net 2.0 was in Add/Remove programs and must have been installed by one of the other other prerequisites for Speech Server 2007, most likely VS 2005.

    Also, in the prereqs, it was required to enable .net in the Windows Features, which I think is .net 3.0.  I did not have to deselect or uninstall this to get the UCMARedist.msi to install.

     

    Dan

    • Proposed as answer by DanFoxley Wednesday, August 11, 2010 6:59 PM
    Wednesday, August 11, 2010 6:53 PM