none
Office Click-to-Run in MDT Image RRS feed

  • Question

  • I am looking to create a customized Windows 10 image. I have installed an MDT 2013 Update 2 server to do the install. Within my image I would like to install Office Click-to-Run 2016. I am using the following article for guidance:

    https://technet.microsoft.com/en-us/library/dn314789.aspx

    I am using MDT to both deploy and capture the image. When the image finishes capturing I am getting the following warning:

    "Unexpected return code while re-arming Office 2016, RC = -1073425660"

    Image

    Any help in determining if this is an issue and fixing it would be appreciated.

    Thanks,

    Mike


    Solutions Architect

    Tuesday, August 23, 2016 6:26 PM

All replies

  • According to the article you can run:    cscript.exe "%programfiles%\Microsoft Office\Office15\ospp.vbs" /dstatus to determine if there is an issue.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Tuesday, August 23, 2016 7:47 PM
    Moderator
  • Hi

    Did you activate the Office in your base image??

    I have never seen that error with click to run - only with the MSI installer of Office 2016.

    Kind regards
    Per Larsen
    Microsoft MVP - Enterprise Mobility
    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, August 23, 2016 7:56 PM
  • I ran the following and it the response was no product keys detected.  cscript.exe "%programfiles%\Microsoft Office\Office16\ospp.vbs" /dstatus

    I did not have an Office15 folder but i had an Office16 folder.


    Solutions Architect

    Tuesday, August 23, 2016 9:11 PM
  • I did not..

    I ran the following and it the response was no product keys detected.  cscript.exe "%programfiles%\Microsoft Office\Office16\ospp.vbs" /dstatus



    Solutions Architect

    Tuesday, August 23, 2016 9:12 PM
  • This is from the LTISysprep.wsf script.

    To get passed this i created this variable, I did it in my customsettings.ini file, but you should be able to add it to the Task Sequence.  It just needs to be set before the Sysprep steps.

    SkipRearm=YES

    Below is a snippet from the LTISysprep.wsf script

    '//----------------------------------------------------------------------------
    '//  Rearm Office 2016 if it is present
    '//----------------------------------------------------------------------------

    If not UCase(oEnvironment.Item("SkipRearm")) = "YES" then
    For each sOSPPPath in Array(oEnvironment.Substitute("%ProgramFiles%\Microsoft Office\Office16\OSPPREARM.EXE"), oEnvironment.Substitute("%ProgramFiles(x86)%\Microsoft Office\Office16\OSPPREARM.EXE"))
    If oFSO.FileExists(sOSPPPath) then

    oLogging.CreateEntry "Re-arming Office 2016 activation", LogTypeInfo
    iRetVal = oUtility.RunWithConsoleLogging("""" & sOSPPPath & """")
    If iRetVal = 0 then
    oLogging.CreateEntry "Re-armed Office 2016 successfully.", LogTypeInfo
    Else
    oLogging.CreateEntry "Unexpected return code while re-arming Office 2016, RC = " & iRetVal, LogTypeWarning
    End if

    End if

    Next
    Else
    oLogging.CreateEntry "Re-arming skipped by user request.", LogTypeInfo
    End if

    Thursday, August 25, 2016 6:16 PM
  • Thanks Keith,

    I will add that step to the task sequence.  So really what you are saying is that this can be ignored, and your step in the task sequence is skipping the rearm process for Click to Run.


    Solutions Architect

    Friday, September 2, 2016 8:07 PM
  • Many thanks, adding the SkipRearm=YES step in to the task sequence fixed this problem for me as well!

    Monday, September 12, 2016 1:26 PM
  • SkipRearm=Yes worked for me as well after beating my head for two days why it was failing.

    I set up captures in MDT every week for customers and have never seen this happen, but thanks for the workaround.

    Tuesday, November 8, 2016 9:12 PM
  • Not realizing that our newest version of Office 2019 was click to run, I too was getting the re-arm error during MDT right before Sysprep. Adding the SkipRearm=Yes to my task sequence right before capture resolved my issue and it picks up the KMS licensing fine. Thank you!
    Friday, November 30, 2018 4:36 PM
  • Do Click-To-Run versions need to be rearmed to avoid the grace period time on new deployments older than 30 days?
    Friday, November 30, 2018 7:55 PM
  • Where in the sysprep and capture task did you place the SkipRearm = Yes?
    Wednesday, February 20, 2019 11:22 PM
  • Under State Restore, right before "Imaging."

    Thursday, February 21, 2019 3:46 PM
  • This did work for me, but it was pretty particular about where i placed this. All the screen shots above have some kind of more complicated imaging process, whereas mine is just a sysprep and capture. The location i used is below:

    Wednesday, March 20, 2019 3:47 PM