none
COM Ports Missing RRS feed

  • Question

  • On windows 10 this seems to be a very common problem. The internet is full of posts from people who have windows 10 and at some point notice all their com ports no longer show up in device manager.

    Why doesn't MS do something about this obvious problem in windows 10?

    So my com ports have disappeared again. I need to select the com port my Ardunio board is connected to so I can use Visual Studio 2017 and debug my code...but I can't because the com port list is empty!

    This is very annoying and more so since it is an obvious problem many win10 users are having.

    Tuesday, June 19, 2018 4:25 AM

All replies

  • Hi,

    I have one test machine have same problem. You can install it manually:

    1. Right click Start button to select Device Manager.

    2. Click Action -> Add legacy hardware, then click Next.

    3. Select Install the hardware that I manually select from a list (Advanced) -> then click Next.

    4. Select Ports (COM & LPT), then click Next.

    5.Select Standard port types or Manufacturer type as you desired, then click Next.

    Additional, I will submit this feedback via our own channel. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, June 20, 2018 2:18 AM
    Moderator
  • Doesn't work. It adds a driver that has a status of:

    Windows cannot determine the settings for this device.  Consult the documentation that came with this device and use the Resource tab to set the configuration. (Code 34)

    I need to set a USB to a COM port for a legacy device. There must be a way to do this.
    Saturday, June 22, 2019 2:06 AM
  • So you don't have a native COM port on your Mainboard, but an USB to serial adapter? You did install the drivers by the manufacturer?

    What is the adapter model?

    Saturday, June 22, 2019 4:57 AM
  • Installed the USB to serial adapter and it appears once after the install but with every restart the port disappears. PL2303 driver. 

    I have to reinstall the driver several times and multiple restarts before the port reappears. It's clearly a Windows issue. 

    Sunday, July 21, 2019 6:10 PM